BGP set community prepend issue

Answered Question
Jan 15th, 2009

Hello,

I am trying to prepend out routes using one of my upstream providers. I was told by the ISP that I needed to do this using a set community command. In order to prepend routes to this ISP i was instructed to use as example 1234:XXX (where 1234:2 would prepend 2 times, 1234:3 three times, etc.

I added set community 1234:2 to my out going route map, but now my config shows the following:

set community 283312130 and therefore my routes are not prepending out this ISP connection.

Any one seen this before or am I just doing something incorrectly?

thanks

I have this problem too.
0 votes
Correct Answer by Harold Ritter about 7 years 10 months ago

Jesse,

You need to use the "ip bgp-community new-format" in order to see the community in the format.

The reason the prepending is not taking place has nothing to do with this though. You need to configure "neighbor x.x.x.x send-community" for the community to be sent to the peer (upstream provider in this case). Setting it in the route-map alone will not do it.

Regards

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (1 ratings)
Loading.
Correct Answer
Harold Ritter Thu, 01/15/2009 - 11:23

Jesse,

You need to use the "ip bgp-community new-format" in order to see the community in the format.

The reason the prepending is not taking place has nothing to do with this though. You need to configure "neighbor x.x.x.x send-community" for the community to be sent to the peer (upstream provider in this case). Setting it in the route-map alone will not do it.

Regards

Actions

This Discussion