MPLS VPN Traffic Issue

Answered Question
Jan 15th, 2009
User Badges:

I have a functioning MPLS VPN configured. We had our core router reboot this morning. When this happened, The MPLS VPN didnt come up correctly. We see traffic passing on the main vpn. We see a full route list on the VRF, however it wont pass any traffic.


Thanks

Greg

Correct Answer by Giuseppe Larosa about 8 years 6 months ago

Hello Greg,

probably there is a problem on the forwarding plane


verify with

sh mpls ldp discovery


if you see correct LDP adjacencies on all MPLS interfaces of core router.

if you don't see the neighbor LDP router-id followed by :0 that link is not working well.


and verify with

sh mpls forwarding PE-loopback-address correct action should a label value or pop tag if you see untagged this breaks the MPLS VPN connectivity.



in that case do shut wait 60 seconds no shut of the link to give LDP a chance to restart on the link


Hope to help

Giuseppe


  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (1 ratings)
Loading.
Correct Answer
Giuseppe Larosa Thu, 01/15/2009 - 14:12
User Badges:
  • Super Silver, 17500 points or more
  • Hall of Fame,

    Founding Member

Hello Greg,

probably there is a problem on the forwarding plane


verify with

sh mpls ldp discovery


if you see correct LDP adjacencies on all MPLS interfaces of core router.

if you don't see the neighbor LDP router-id followed by :0 that link is not working well.


and verify with

sh mpls forwarding PE-loopback-address correct action should a label value or pop tag if you see untagged this breaks the MPLS VPN connectivity.



in that case do shut wait 60 seconds no shut of the link to give LDP a chance to restart on the link


Hope to help

Giuseppe


Actions

This Discussion