Enabling CDP on Q-in-Q Links

Unanswered Question
Jan 16th, 2009
User Badges:

Hi,


I submitted this question on the Network Management forum yesterday & was advised that CDP must be enabled to allow Campus Manager to discover trunk links correctly. I was advised to submit on this forum as to whether anything further can be done from a LAN switching perspective. Thanks.....Pete


We have a customer with Cat6500 VSS chassis configured with Etherchannel 802.1Q-in-Q links between Edge & Distribution switches. The distribution end of the link is configured as an IEEE802.1Q tunnel port whilst the Edge end of the link is an IEEE802.1Q trunk port (assymmetrical link).


CDP is automatically disabled for this configuration so link status on campus manager doesn't work correctly. If we enable CDP on the links then we get "native vlan mismatch" error messages. Is there a way around this other than filtering/ignoring the messages?


  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
Tshi M Fri, 01/16/2009 - 08:00
User Badges:
  • Silver, 250 points or more

what is the native VLAN on either devices?

pnahirny Fri, 01/16/2009 - 08:12
User Badges:

This is the config of the Q-in-Q port


interface Port-channel3

description Etherchannel to UKX1SWT02-CSN

switchport

switchport access vlan 55

switchport mode dot1q-tunnel

switchport nonegotiate

spanning-tree portfast

spanning-tree bpdufilter enable


This is the configuration of the dot1q port


interface Port-channel2

description Etherchannel to UKX1SWT01-CSN

switchport

switchport trunk encapsulation dot1q

switchport trunk native vlan 97

switchport trunk allowed vlan 2-4

switchport mode trunk

switchport nonegotiate


I'm sure we've tried changing the native vlan so it's the same at both ends, ie defaulting the native vlan at the dot1q end but still the same & I think this is due to the link being assymmetrical. Documents I've seen on CCO all suggest ignoring the messages but I was hoping somebody may have another workaround?


Thanks

Giuseppe Larosa Fri, 01/16/2009 - 09:16
User Badges:
  • Super Silver, 17500 points or more
  • Hall of Fame,

    Founding Member

Hello Peter,

in QinQ scenarios you can choice to send all frames tagged


Use the vlan dot1q tag native global configuration command to configure the edge switch so that all packets going out an IEEE 802.1Q trunk, including the native VLAN, are tagged. If the switch is configured to tag native VLAN packets on all IEEE 802.1Q trunks, the switch accepts untagged packets, but sends only tagged packets.


see


http://www.cisco.com/en/US/docs/switches/lan/catalyst3750/software/release/12.2_46_se/configuration/guide/swtunnel.html#wp1008635


This could solve your issue.


Hope to help

Giuseppe


Actions

This Discussion