Multicast setup 4507R & 3750 Access

Unanswered Question
Jan 16th, 2009

Hi,

Im trying to enable multicasting on our network for ghosting.

We are using a 4507R as our router and 3750 for our access switches.

I have enabled IP multicast-routing and ip pim sparse-dense-mode on the affected VLAN interface's on the 4507.

I havent changed the default multicast settings on the 3750's

Ghostcast will not work and I presume I have not properly configure multicast routing.

the 3750's are running the base IP IOS

how should I best configure my hardware to enable multicasting.

Kind regards

G

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 3 (1 ratings)
Loading.
austin0824 Fri, 01/16/2009 - 03:12

Hi G,

You are running IP Base feature set. You will have to upgrade to the Advanced Feature set...c3750-advipservicesk9-tar.122-40.SE.tar

Regards

garethmitchell Fri, 01/16/2009 - 03:33

Hi Austin,

Thanks, I was hoping there would be an alternative as its going to take me a while to update all the switches.

Is there any assosiated cost with upgrading the IOS to advancedIP? (also thanks for taking the time to find the filename)

presumably I will then just need to follow the instructions on setting up basic multicasting as outlined in chapter 44 of the 3750 config guide :)

Kind regards Gareth

Jon Marshall Fri, 01/16/2009 - 03:42

Giuseppe / Gareth

Funnily enough i was just about to write the same thing !. If all the inter-vlan routing is done on the 4507 then as you say you just need IGMP snooping. I just checked Feature Navigator and IGMP snooping is supported in IP Base.

Jon

garethmitchell Fri, 01/16/2009 - 05:35

Ok, thats great news but Im afraid I dont understand what commands I should be using to enable snooping or on which interfaces?

Do I need to change any settings for the uplink interface or just for the VLAN or both? and should snooping be enabled on the 4507?

sorry for being so hopeless and thank you all for your time

Giuseppe Larosa Fri, 01/16/2009 - 06:00

Hello Gareth,

you need to enable ip igmp snooping only on the C3750.

you just need

config t

ip igmp snooping vlan

or simply

ip igmp snooping

to enable on all vlans

the 4507 will provide the IGMP querier and PIM DR roles

igmp snooping allows the L2 switch to optimize multicast forwarding by listening to IGMP messages from router and end users.

instead of sending the multicast stream out all ports of vlan 5 it builds a L2 list of ports of vlan 5 that have to receive the traffic and filters it out other ports of same vlan5.

if there is an interested receiver out a port the switch intercepts the PC IGMP report for the group.

Hope to help

Giuseppe

garethmitchell Fri, 01/16/2009 - 06:11

Hi Giuseppe,

ok that makes more sense to me now thanks, but ive check the snooping on the 3750 and its enabled (I think this might be default?) on all VLAN's but im still not having any Joy with the ghost casting.

Is it possible there is something wrong with the setup on the 4507? what should I check?

Many thanks

Gareth

Giuseppe Larosa Fri, 01/16/2009 - 06:48

Hello Gareth,

you need to enable multicast routing

ip multicast-routing

then on each Vlan including the source vlan (where the ghost server is connected) you need

int vlan X

ip pim sparse-dense-mode

you should be fine in this way even without setting an RP.

Hope to help

Giuseppe

Jon Marshall Fri, 01/16/2009 - 07:14

Gareth

In addition to Giuseppe's post you also need to make sure that the Ghost application is setting the TTL in the packets to > 1. If all vlans are routed off your 4500 then a value of 2 would be fine.

Ghost by default uses a TTL of 1 i believe and this means it won't route between the vlans.

Jon

garethmitchell Mon, 01/19/2009 - 06:31

Hi Jon,

Thanks for joining in, yes I believe all the IGMP packets coming from ghost are set with a TTL of 1 and I do not know of any way to change this.

This chap Nigel Bree an apparent employee at symantec has something to say on the matter although his comments on RFC 2236 do not seem to agree with the document as I read it.

https://forums.symantec.com/syment/board/message?board.id=109&message.id=5809

Is there any other way to stop the packets from being discarded before reaching the router?

Gareth

Giuseppe Larosa Mon, 01/19/2009 - 07:31

Hello Gareth,

routers cannot modify the TTL field with an increment they can only modify it with a decrement.

You need to find a way to increase TTL at the application level or you need to revert to unicast and to use

ip helper-address to convert a broadcast request to a routable unicast packet towards the server.

other forms of helper addresses exist for example

ip multicast helper-map

see

http://www.cisco.com/en/US/docs/ios/ipmulti/command/reference/imc_03.html#wp1033212

but this converts a broadcast to a multicast.

Hope to help

Giuseppe

Jon Marshall Mon, 01/19/2009 - 11:55

Gareth

There is some confusion here. That thread is talking about increasing the TTL on IGMP packets. Quite rightly the thread states that you wouldn't want to do this because IGMP is local to the subnet.

What i am talking about is not increasing the TTL of the IGMP packets but the TTL of the multicast data traffic which is something completely different. The Ghost application sends out multicast packets (nothing to do with IGMP) and for these packets to traverse a routed interface they must have a TTL > 1.

So somewhere within the Ghost application there will be a checkbox or setting to increase the TTL on the multicast packets. If there wasn't Ghost would be a pretty useless application.

Edit - had a further search on symantec forums. Looks like Ghost uses a TTL of 16 by default which is more than enough altho some people reported problems and it looks like it can be overriden by the OS at times. If you could capture one of the multicast packets with Wireshark you would know for sure.

Jon

Actions

This Discussion