CCME - H323 incoming call oneway voice

Answered Question
Jan 19th, 2009
User Badges:

Guys,


I have problems with inbound calls on my CME, the PSTN provider is giving us incoming calls on H323. Now calls internally and to my other sites are fine but when someone tries calling us from a PSTN, the Telecom Provider routes this call through a H323 connection, when the call is answered there is one way audio. They can hear us but we cannot hear them. Now on my CME router I have 2 ethernet interfaces, one is for the internal LAn and the second one direct connection to the Telecom Service Provider. So the calls are not hitting our ASA firewall. I cant figure out why we have one way voice on the PSTN calls. The service provider says we have routing issue on our side but I doubt it because the calls are directly going thru the external interface on the voice gateway (CME). I can ping their signalling IP and trace route shows the path is thru the external interface. Please can someone shed some light on this.


cheers,


K

Correct Answer by Nicholas Matthews about 8 years 4 months ago

What does show call active voice brief show? Show run?



-nick

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 4 (1 ratings)
Loading.
Nicholas Matthews Mon, 01/19/2009 - 05:30
User Badges:
  • Red, 2250 points or more

Hi K,


Check out this doc, see if it helps clear up what may be causing this.


Most one-way audio issues come down to a layer 3 packet level, and ACLs, firewalls, and a lack of a route are the most common causes.


It's still possible to have something like a bad PVDM or phone that would send empty packets, but it is less likely.


Is the CME the default gateway of the phones?


Could you post a show run? Sometimes odd commands like 'ip verify unicast reverse-path' 'no ip classless' and the likes will cause problems.



hth,

nick



kiranoddiraju Mon, 01/19/2009 - 05:52
User Badges:

Thanks for the quick reply Nick. When you say firewall does it mean on my end or the Telecom's end? I have set CME as the default gateway for the phones but still have the issue...anyother ideas mate???

Correct Answer
Nicholas Matthews Mon, 01/19/2009 - 06:01
User Badges:
  • Red, 2250 points or more

What does show call active voice brief show? Show run?



-nick

kiranoddiraju Mon, 01/19/2009 - 08:39
User Badges:

ahhaaa...the debug shows the Telco was receiving my CME IP instead of the external interface IP. Tried many settings but none worked. So I changed the protocol to SIP and it was fine (I dont know how SIP protocol fixed it...). Anyways my problem is fixed, many thanks Nick.


Cheers,

K

Actions

This Discussion