SPAN on CE 500

Unanswered Question

I'm trying to configure a diagnostic port on my Catalyst Express 500 G-12TC switch.


I have followed the docs (http://www.cisco.com/en/US/products/hw/switches/ps708/products_tech_note09186a008015c612.shtml#Cat500) in setting up a diagnostic port, but I'm not seeing the traffic from the mirrored port. For example, I set up port Gi7 as the diagnostic port, monitoring port Gi5. The only traffic I see is broadcast and multicast. I do get a CDP packet every so often that says "Device ID: CiscoSwitch Port ID: GigabitEthernet5" but that's it.


Anyone know what I might have messed up?


Thanks!


  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
Nicholas Matthews Mon, 01/19/2009 - 12:12
User Badges:
  • Red, 2250 points or more

A few things:

You may have sourced the wrong port, and thus you're only getting broadcast

You may have plugged the source into the wrong port

You may have plugged the sniffer in the wrong port, and you're only getting broadcast. (Note that if you get an IP address and have any type of connectivity on your sniffer this is the case).

You may have put the wrong destination port in.


On your CE500 (IP add A.B.C.C) you can go to:

http://A.B.C.D/exec


And then you can type commands like 'show run', 'show monitor session all'


As well, you can go into global config mode and configure SPAN just like a normal switch. Except you do it via the HTTP CLI interface, it's a little clunky, but it works.



hth,

nick

Thank you for the suggestions. I am new to managing switches and I appreciate the help. I'm used to just telling someone to "mirror port a to port b" and it happens... never had to do it myself before! :D



I checked over the source port and my connections and they all seem correct per the document.


I ran the "show monitor session all" and got the following:


Session 1

---------

Type : Local Session

Source Ports :

Both : Gi5

Destination Ports : Gi7

Encapsulation : Replicate

Ingress : Disabled



When I go into the CNA and get the details on my diagnostic port (Gi7), it shows:


Role: Diagnostics, Ingress VLAN: none, Source Port: GigabitEthernet5


We only have one VLAN, (Default)... if I set the ingress VLAN to default, then my sniffer (wire shark on a laptop) will see it's own traffic, but still only broadcast and multicast otherwise.


Any more suggestions for the newb? :)


Actions

This Discussion