FXO doesn't go offhook using H323

Unanswered Question
Jan 19th, 2009


I have one CM in the main site and VG in the main site and the remote brance, CM version is 4.2, H323 is configured on the Main site VG and it is working fine. but in the remote site H323 is not working such that the call doesn't land on the operator phone while it is working fine using MGCP. when I do sho voice call status it shows "S_WAIT_RELEASE_NC".

Show run and Show version is attached.


I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Nicholas Matthews Mon, 01/19/2009 - 11:11

Sounds like you have stuck ports.

You can try upgrading to something like 12.4(22)T to see if this resolves it.

Looking at your custom disconnect tones, you may want to modify these parameters to something like this:

voice class dualtone-detect-params 1

freq-max-deviation 25

freq-max-power 0

freq-min-power 25

no freq-power-twist

cadence-variation 4

You can also try reducing your disconnect time:

voice-port x/x/x

timeouts call-disconnect 1

timeouts wait-release 1

wait_release is generally a bad sign, and is indicative of a stuck port.



mohdashraq Mon, 01/19/2009 - 11:21

thanks for your reply.

the issue is not stuck ports, the issue is that I am not able to reveive the call on the operator phone from the VG, even if I try csim start 2701 (operator extension) the call fail. codec is g711ulaw and the operator phone and the VG are in the same device pool (same region).

appreciate your cooperation

Nicholas Matthews Mon, 01/19/2009 - 11:59

Something doesn't make sense then.

S_WAIT_RELEASE is the state for a FXO/FXS port.

If you're calling from an internal IP phone DN via H323 to another IP phone DN, this has nothing to do with your problem and something else is going on with the call flow.

If the FXS/FXO port is in the call flow, please explain how the operator with a DN is connected.



This Discussion