stub - summary eigrp

Answered Question
Jan 20th, 2009

what advantages and disadvantages has put the router3 and router 2 as stub, and make summary of the route default 0.0.0.0 0.0.0.0 in the interfaces serial and ethernet of router 1.

I Want router 2 and router 3 have only the routes connected in their routing table and a path default to router 1

Router 1

-----------

interface Serial0/0

description router 3

IP ADDress 10.1.2.5 255.255.255.252

ip summary-address eigrp 1 0.0.0.0 0.0.0.0 5

bandwidth 2048

no ip address

no ip mroute-cache

interface Serial0/1

description router 2

IP ADDress 10.1.2.1 255.255.255.252

ip summary-address eigrp 1 0.0.0.0 0.0.0.0 5

bandwidth 2048

no ip address

no ip mroute-cache

interface FastEthernet0/1.30

bandwidth 4096

encapsulation dot1Q 30

ip address 10.1.1.3 255.255.255.0

no snmp trap link-status

ip summary-address eigrp 1 0.0.0.0 0.0.0.0 5

router eigrp 20

redistribute connected

network 10.0.0.0 0.0.0.255

no auto-summary

Router 3

----------

interface Serial0/0

IP ADDress 10.1.2.2 255.255.255.252

bandwidth 2048

no ip address

no ip mroute-cache

interface FastEthernet0/1.30

bandwidth 2048

encapsulation dot1Q 30

ip address 10.1.1.1 255.255.255.0

no snmp trap link-status

router eigrp 20

redistribute connected

passive-interface FastEthernet0/1.4

passive-interface FastEthernet0/1.5

network 10.0.0.0 0.0.0.255

no auto-summary

eigrp stub connected summary

Router 2

----------

interface Serial0/0

IP ADDress 10.1.2.6 255.255.255.252

bandwidth 2048

no ip address

no ip mroute-cache

interface FastEthernet0/1.30

bandwidth 2048

encapsulation dot1Q 30

ip address 10.1.1.2 255.255.255.0

no snmp trap link-status

router eigrp 20

redistribute connected

passive-interface FastEthernet0/1.4

passive-interface FastEthernet0/1.5

network 10.0.0.0 0.0.0.255

no auto-summary

eigrp stub connected summary

Attachment: 
I have this problem too.
0 votes
Correct Answer by Richard Burts about 7 years 12 months ago

Pedro

Thank you for posting back to the forum and indicating that you have put this into production and that it is working as you wanted it to. It makes the forum more useful when there is confirmation that things did work following the advice given in the forum. I am glad that our responses were helpful as you worked out these concepts.

Thr forum is an excellent place to learn about Cisco networking and I encourage you to continue your participation in the forum.

HTH

Rick

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 4.6 (5 ratings)
Loading.
Giuseppe Larosa Tue, 01/20/2009 - 04:50

Hello Pedro,

your setup is good.

the summary route out the serial ports provide minimum size routing table on R2 and R3.

The EIGRP stub feature helps in reducing EIGRP query scope.

If R2 and R3 receive and EIGRP query they answer back with code unreachable.

This configuration is recommended for branch routers with no other routers downstream to them.

It is advantageuos in case of multihomed branch routers to avoid EIGRP query propagation.

It helps to keep EIGRP protocol stable.

Said this, in your case by receiving only a default route and if not multi-homed R2 and R3 would answer back to EIGRP query even without the stub option.

Hope to help

Giuseppe

Richard Burts Tue, 01/20/2009 - 04:54

Pedro

There are several aspects of your configuration that are problematic. For example in the first serial interface config you have this:

interface Serial0/0

IP ADDress 10.1.2.5 255.255.255.252

ip summary-address eigrp 1 0.0.0.0 0.0.0.0 5

no ip address

why are you removing the IP address? It seems that every serial interface you remove the IP address after you configure it?

The network that you show here is not a good candidate for EIGRP stub. EIGRP stub is appropriate (and potentially a good thing) on a router that does not forward traffic from another router. In your case when we consider the serial links then router 1 is the hub and router 2 and 3 are spokes and are configured as stub. However it appears that router 2 and 3 are connected by VLAN 30 (subnet 10.1.1.0/24). So if the serial link from router 2 to router 1 would fail, then router 3 would forward traffic from router 2 to router 1. This is especially true since VLAN 30 is not a passive interface. router 2 and router 3 will become neighbors on VLAN 30 and share routes with each other. The fact that router 2 would forward traffic for router 3 makes it not a good situation for EIGRP stub.

HTH

Rick

richard.m.gilbert Tue, 01/20/2009 - 06:35

Pedro,

I agree with rburts in wondering why you remove the address after adding it. Also, shouldn't you be using your AS in the summary-address command (20 vs 1)?

Richard

Richard Burts Tue, 01/20/2009 - 06:54

Richard

Yes the mismatch of EIGRP AS number between the summary command and configuration of the EIGRP process is another problematic aspect of the configs.

HTH

Rick

pesanchez2002 Tue, 01/20/2009 - 16:13

Hi,

Sorry, The command "not ip address" is an transcription error. Thank You for realizing the mistake.

The command "ip summary-address eigrp 1 0.0.0.0 0.0.0.0 5 ", is also a transcription error

Correction:

"ip summary-address eigrp 20 0.0.0.0 0.0.0.0 5 "

¿ How i can do, for that router 2 and router 3 have only the routes connected in their routing table and a path default to router 1, and the links serial and ethernet are redundant for r2 and r3?

The correct Configuration:

Router 1

-----------

interface Serial0/0

description router 3

IP ADDress 10.1.2.5 255.255.255.252

ip summary-address eigrp 20 0.0.0.0 0.0.0.0 5

bandwidth 2048

no ip mroute-cache

interface Serial0/1

description router 2

IP ADDress 10.1.2.1 255.255.255.252

ip summary-address eigrp 20 0.0.0.0 0.0.0.0 5

bandwidth 2048

no ip mroute-cache

interface FastEthernet0/1.30

bandwidth 4096

encapsulation dot1Q 30

ip address 10.1.1.3 255.255.255.0

no snmp trap link-status

ip summary-address eigrp 20 0.0.0.0 0.0.0.0 5

router eigrp 20

redistribute connected

network 10.0.0.0 0.0.0.255

no auto-summary

Router 3

----------

interface Serial0/0

IP ADDress 10.1.2.2 255.255.255.252

bandwidth 2048

no ip mroute-cache

interface FastEthernet0/1.30

bandwidth 2048

encapsulation dot1Q 30

ip address 10.1.1.1 255.255.255.0

no snmp trap link-status

router eigrp 20

redistribute connected

passive-interface FastEthernet0/1.4

passive-interface FastEthernet0/1.5

network 10.0.0.0 0.0.0.255

no auto-summary

eigrp stub connected summary

Router 2

----------

interface Serial0/0

IP ADDress 10.1.2.6 255.255.255.252

bandwidth 2048

no ip mroute-cache

interface FastEthernet0/1.30

bandwidth 2048

encapsulation dot1Q 30

ip address 10.1.1.2 255.255.255.0

no snmp trap link-status

router eigrp 20

redistribute connected

passive-interface FastEthernet0/1.4

passive-interface FastEthernet0/1.5

network 10.0.0.0 0.0.0.255

no auto-summary

eigrp stub connected summary

Richard Burts Tue, 01/20/2009 - 20:16

Pedro

You should remove the eigrp stub connected summary from both router 2 and router 3. The summary address that you have configured on the serial interfaces of router 1 will produce the results that you want. With the summary address configured on the serial interfaces of router 1 it will only advertise the default route to routers 2 and 3. You do not need eigrp stub on them to reduce the routing table since the summary-address will do that for you.

HTH

Rick

Giuseppe Larosa Tue, 01/20/2009 - 23:59

Hello Rick, Pedro

looking at the last drawing we see that routers R2 and R3 are multihomed.

I would keep the eigrp stub configuration on them to be sure to have a good control on Query Scope.

R2 and R3 should answer back to a query for the summary route they receive but I don't see any drawback in keeping also the eigrp stub configuration

Hope to help

Giuseppe

Richard Burts Wed, 01/21/2009 - 04:28

Giuseppe

If you keep the eigrp stub on r2 and r3 then neither one can provide effective redundancy for the other one, since r2 could learn the LAN subnet from r3 but would not advertise it (and r3 could learn the LAN from r2 but would not advertise it). In a previous post Pedro says that part of his requirement is:" and the links serial and ethernet are redundant for r2 and r3?". If r2 needs to be able to advertise the LAN from r3 up its serial (which would be a requirement to provide effective redundancy) then you can not have r2 or r3 configured as stub.

The summary address configured on the serials of r1 provide a sufficient mechanism to control the query scope at r2 and r3 and you do not really need eigrp stub on them to control query scope.

HTH

Rick

Giuseppe Larosa Wed, 01/21/2009 - 05:31

Hello Rick,

you're right if Pedro wants to be able to route to R3 via R2 or viceversa the stub eigrp has to be removed

It covers the case of failure of

HUB man link + one serial link at the same time according to the last drawing

Hope to help

Giuseppe

pesanchez2002 Wed, 01/21/2009 - 06:52

Thanks Rick and Giuseppe.

Rick,

Because of the metric lower, introduced by the links fasethernet these are the main links.

The line "ip summary-address eigrp 20 0.0.0.0 0.0.0.0 5" in interface interface FastEthernet0/1.30 of router 1, have the same behavior, that the same line in interface interface Serial0/0 and Serial0/1?

richard.m.gilbert Wed, 01/21/2009 - 07:10

Hello all,

One thing I am not understanding is how any of the networks are being advertised by eigrp since the network command in each eigrp process is advertising 10.0.0.0 0.0.0.255. The 10 nets on the interfaces are all 10.1.x.x which is not within the subnets advertised in eigrp.

Am I missing something there?

Richard

Giuseppe Larosa Wed, 01/21/2009 - 08:21

Hello Richard,

you are right a network command like

10.0.0.0 0.0.0.255

is not good

for Pedro:

if this is not another mistyping you need to correct this

Hope to help

Giuseppe

Richard Burts Wed, 01/21/2009 - 09:08

The ip summary-address on the FastEthernet subinterface in router 1 would have the same behavior as it has on the serial interfaces. That behavior is to advertise only the default route and to suppress all other more detailed prefixes.

There is an obvious reason why you would want to configure this on the serial interfaces, since it reduces the prefixes advertised to the down stream routers. I am not clear whether there is some reason to also configure it on the FastEthernet subinterface. If there is some router running EIGRP and connected on the FastEthernet subinterface then that may be a reason to configure the ip summary-address. If there is no router connected on the FastEthernet subinterface then there is no reason to configure the ip summary-address on the FastEthernet subinterface.

HTH

Rick

pesanchez2002 Wed, 01/21/2009 - 09:44

Rick,

Thanks for you answer.

I don`t know if i am understanding well.

In the picture annex, the 3 router are connected by interface FastEthernet0/1.30, and the 3 router are running eigrp. Only This routers are connected by metro ethernet.

That is reason to configure ip summary-address on fasethernet subinterface?

pesanchez2002 Fri, 01/23/2009 - 16:23

Hi I puted in production the configuration, and that function correctly.

Router 1 and Router 2 have in your routing table only routes connected,

route default learning by eigrp summary.

I don't use "eigrp stub connected summary".

I can see that R1 to learn route conected of r2 and viceversa.

With the command show ip eigrp topology, i can see that r1 and r2

learn the route default by link serial and ethernet.

Thanks Rick and Giuseppe by your support

Correct Answer
Richard Burts Sat, 01/24/2009 - 09:11

Pedro

Thank you for posting back to the forum and indicating that you have put this into production and that it is working as you wanted it to. It makes the forum more useful when there is confirmation that things did work following the advice given in the forum. I am glad that our responses were helpful as you worked out these concepts.

Thr forum is an excellent place to learn about Cisco networking and I encourage you to continue your participation in the forum.

HTH

Rick

Actions

This Discussion