Problem Applying QoS Policy to ATM Interface

Answered Question
Jan 20th, 2009

Greetings i have a Cisco2801 ISR with G.SHDSL HWIC installed, it has the following QoS/ATM configuration at present however when i try to apply the policy to the ATM subinterface it wont stick, we are running 12.4(21)Advanced security, the strange thing is that i dont receive any error messages indicating as to why the policy apply, any suggestions would be much appreciated.

controller DSL 0/1/0

mode atm

line-term cpe

line-mode auto

dsl-mode shdsl symmetric annex B


class-map match-any Voice-Media

match ip dscp ef

class-map match-any Voice-Signalling

match ip dscp cs3

match ip dscp af31



policy-map SDSL-WAN-OUT

class Voice-Media

priority 256

class Voice-Signalling

bandwidth 8

class class-default

set ip dscp default



interface ATM0/1/0

no ip address

no atm ilmi-keepalive


interface ATM0/1/0.1 point-to-point

bandwidth 2048

pvc 0/38

encapsulation aal5mux ppp dialer

dialer pool-member 1

**Trying to insert Service Policy here**



I have this problem too.
0 votes
Correct Answer by Paolo Bevilacqua about 7 years 9 months ago


insert the policy under the PPP dialer interface.

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (1 ratings)
exonetinf1nity Tue, 01/20/2009 - 16:59

Thank you for that, i had tried the same previously but it reported an error stating that there wasnt enough free bandwidth on the link, i forgot to add the "bandwidth" statement under the dialer interface.

All is working now, thank you for your time.



This Discussion