Conf-reg

Unanswered Question
Jan 20th, 2009
User Badges:

I have my Cisco 4507R switch in the ROM mon mode & the config-register value is seen to be some junk value.

I tried executing the command

confreg 0x2102. This doesn't work.


I get the below options:


ommon 5 >confreg


Configuration Summary :

=> load rom after netboot fails

=> console baud: 9600

=> autoboot from: commands specified in 'BOOT' environment variable


do you wish to change the configuration? y/n [n]:

enable "diagnostic mode"? y/n [n]:

enable "use net in IP bcast address"? y/n [n]:

disable "load rom after netboot fails"? y/n [n]:

enable "use all zero broadcast"? y/n [n]:

enable "break/abort has effect"? y/n [n]:

enable "ignore system config info"? y/n [n]:


change console baud rate? y/n [n]:


change the boot characteristics? y/n [n]:


Configuration Summary :

=> load rom after netboot fails

=> console baud: 9600

=> autoboot from: commands specified in 'BOOT' environment variable


do you wish to save this configuration? y/n [n]:



Can you please assist? I need to get the sup-module up.

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
Giuseppe Larosa Wed, 01/21/2009 - 00:20
User Badges:
  • Super Silver, 17500 points or more
  • Hall of Fame,

    Founding Member

Hello Deepa,

IOS switches use config-register differently


0x2102 is good for routers not for switches


should be something like


0x000F


Hope to help

Giuseppe


deepa.muralidharan Wed, 01/21/2009 - 00:22
User Badges:

hi,

But the command - confreg 0x2102 / 0xffff doesn't work. It doesn't accept the Confreg usage this way.


Please check the output below:


rommon 8 >confreg 0x2102

usage: confreg

rommon 9 >reset


Resetting .......



rommon 10 >






**********************************************************

* *

* Welcome to Rom Monitor for WS-X4515 System. *

* Copyright (c) 2002 by Cisco Systems, Inc. *

* All rights reserved. *

* *

**********************************************************

Rom Monitor Program Version 12.1(12r)EW


Board type 2, Board revision 7

Swamp FPGA revision 28, Dagobah FPGA revision 71


MAC Address : 00-0c-85-8b-9e-26

IP Address : 172.24.40.1

Netmask : 255.255.254.0

Gateway : 172.24.40.1

TftpServer : 172.24.44.50

Main Memory : 512 MBytes




***** The system will autoboot in 5 seconds *****



Type control-C to prevent autobooting.

. . . . .


******** The system will autoboot now ********



config-register = 0x42

Autobooting using BOOT variable specified file.....


Could not find a valid file in BOOT environment variable.

BOOT variable can be set from IOS. To find currently set

Rom Monitor variables, please type 'set' command.


For help on choosing a boot method, type 'confreg' command.

rommon 1 >

rommon 1 >

Jon Marshall Wed, 01/21/2009 - 03:11
User Badges:
  • Super Blue, 32500 points or more
  • Hall of Fame,

    Founding Member

  • Cisco Designated VIP,

    2017 LAN, WAN

Your switch is configured to auto boot using the BOOT variable but it doesn't have a boot variable set. Do you know where the image is stored and what it is called ? If so


rommon 1> boot /


then when the switch has booted up in your config


4500(config)# boot system flash /


Jon

deepa.muralidharan Wed, 01/21/2009 - 04:12
User Badges:

the image is in bootflash.


Executed COmmands:

rommon 7 >dir bootr flash:


File size Checksum File name

--------------------------------------------------

8620144 bytes (0x838870) 0xf927975a cat4000-is-mz.121-13.EW.bin


Total space = 61341696 bytes, Available = 52721424 bytes


rommon 8 >boot bootflash:cat4000-is-mz.121-13.EW.bin



After this, the switch is booting & again returning to Rommon mode.


Jon Marshall Wed, 01/21/2009 - 04:20
User Badges:
  • Super Blue, 32500 points or more
  • Hall of Fame,

    Founding Member

  • Cisco Designated VIP,

    2017 LAN, WAN

"After this, the switch is booting & again returning to Rommon mode"


And it is giving the same output as in your previous post ie. it cannot find a boot variable value ?


Jon

Roberto Salazar Wed, 01/21/2009 - 12:02
User Badges:
  • Gold, 750 points or more

if you can boot it manually from the rommon the image is valid, the problem is your config register. After booting succesfully, see the result of show boot, make sure you have a boot variable and the config-register is 0x2102, if either or both are not what it should be, try the following:

1. conf t

boot system flash bootflash:

wr mem

2. conf t

config-register 0x2102

wr mem


show ver and show boot again to verify. If there is boot variable and config-register is 0x2102, reboot that should boot the IOS.

deepa.muralidharan Thu, 01/22/2009 - 00:47
User Badges:

I have already tried - boot system flash bootflash: & also tried config-register 0x2102.


'Confreg 0x2102' is not working. Even If i boot with the image & reload, the switch reboots & gets back to the Rommon mode.

Actions

This Discussion