SHDSL configuration on 2800 Router

Unanswered Question
Jan 21st, 2009
User Badges:

I need 4 SDSL ports on the 2800 router. Is i have to buy 4 WIC-1SHDSL-V3 cards for that?


Secondly Can you please provide me the template configuration to configure the router for SDSL link?


What information i need to get from the ISP to setup this link?


your help will be highly appriciated.

Thanks


  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 4 (2 ratings)
Loading.
Giuseppe Larosa Wed, 01/21/2009 - 08:42
User Badges:
  • Super Silver, 17500 points or more
  • Hall of Fame,

    Founding Member

Hello Tauseef,


1) yes you need 4 WIC


2) exact configuration varies an example can be


http://www.cisco.com/en/US/docs/routers/access/1800/1801/software/configuration/guide/pppoanat.html


3)


you need to ask the following information:


atm parameters: Vpi/Vci to be used these have values that vary from provider to provider so you need ask to yours

typical values are 0/35 or 8/35


type of service: PPPoA like in example above, PPPoE or IP over ATM this can include authentication data username. password and protocol (pap, chap, ms-chap)


Hope to help

Giuseppe


t4tauseef33 Sat, 01/24/2009 - 05:22
User Badges:

Hi,


Thanks for your reply. Its really helpfull Can you please also help me how to bundle these 4 SDSL lines together. I want to use all of these 4 sdsl lines as one link. how the ISP provides the bonded service.


Thanks


mszeftawy Tue, 01/27/2009 - 01:07
User Badges:

Since you have only 4 SDSL lines you can buy only 2 WIC's as the mentioned WIC supports 4-Wire mode. And you can arrange with your service provider to provision double speed links over 4-wire. Also it can work as separate 2wire lines over a single WIC


Regarding the bundling of the 4-links I think that you can use a tunnel interface between your router and service provider router but you should 1st check the service provider bundling policy.


t4tauseef33 Wed, 01/28/2009 - 07:35
User Badges:

Thanks,


By googling, i came to know that there are few methods of bonding


1) PPP Multilink

2) Static Routes load balancing

3) Tunnel interface


Is there any other way of bonding them together and which one is the best?

paolo bevilacqua Wed, 01/28/2009 - 09:24
User Badges:
  • Super Gold, 25000 points or more
  • Hall of Fame,

    Founding Member

Routing load balancing (doesn't need to be static) is ok in most situations. Note 3) requires 2)

mszeftawy Thu, 01/29/2009 - 00:29
User Badges:

If both the 4 links have the same BW then you can load balance over these links using static route also you have to inform your service provider to load balance the return traffic


And you can also create a tunnel interface that runs over the load balanced links, and that will act as a bundle for the 4 links and in case of adding any routes (Dynamic or static) you have to use the tunnel interface and that will handle the load sharing over the 4 links.


But before using the load balancing and bundling you have to enable ip cef and choose load sharing technique (per-packet or per-destination). And that depends on your traffic type.



MaseBarnes Thu, 01/29/2009 - 00:57
User Badges:

For bundling try this:


controller DSL 0/1/0

mode atm

line-term cpe

line-mode 2-wire line-zero

dsl-mode shdsl symmetric annex B

line-rate auto

no shut

!

controller DSL 0/2/0

mode atm

line-term cpe

line-mode 2-wire line-zero

dsl-mode shdsl symmetric annex B

line-rate auto

no shut

!

controller DSL 0/3/0

mode atm

line-term cpe

line-mode 2-wire line-zero

dsl-mode shdsl symmetric annex B

line-rate auto

no shut

!



interface Multilink1

ip address negotiated

load-interval 30

no cdp enable

ip nat outside

ppp ipcp dns request accept

ppp multilink

ppp multilink fragment disable

ppp multilink group 1

service-policy output grommit

!



interface ATM0/1/0.1 point-to-point

pvc b-dsl1 1/XX

ubr 2304

encapsulation aal5snap

protocol ppp Virtual-Template1

!

interface ATM0/1/0.2 point-to-point

ip unnumbered loopback 0

pvc noc1 0/XX

ubr 32

encapsulation aal5snap

oam-pvc manage 10

!

!

interface ATM0/2/0

no ip address

no atm ilmi-keepalive

no shut

!

interface ATM0/2/0.1 point-to-point

pvc b-dsl2 1/XX

ubr 2304

encapsulation aal5snap

protocol ppp Virtual-Template1

!

interface ATM0/2/0.2 point-to-point

ip unnumbered loopback 0

pvc noc2 0/XX

ubr 32

encapsulation aal5snap

oam-pvc manage 10

!

!

interface ATM0/3/0

no ip address

no atm ilmi-keepalive

no shut

!

interface ATM0/3/0.1 point-to-point

pvc b-dsl3 1/XX

ubr 2304

encapsulation aal5snap

protocol ppp Virtual-Template1

!

interface ATM0/3/0.2 point-to-point

ip unnumbered loopback 0

pvc noc3 0/XX

ubr 32

encapsulation aal5snap

oam-pvc manage 10

!

!


interface Virtual-Template1

bandwidth 2300

no ip address

ppp pap sent-username login password password

ppp multilink

ppp multilink fragment disable

ppp multilink group 1

!


Actions

This Discussion