In client properties Policy Manager State is DHCP_REQD problem

Unanswered Question
Jan 21st, 2009

Something happended to my controller and the security settings were changed. We run no Authentication and Level 2 security was enabled. I got that back and I noticed that DHCP Addr. Assignment was enabled under editing the WLAN. I unchecked it, rebooted the server, and tried connecting a computer but under client properties it is still DHCP_REQD instead of RUN. So the computers connect but they have no connectivity.

Any ideas?

Gary

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
Scott Fella Wed, 01/21/2009 - 12:41

Gary,

What code are you running on the wlc's and are these devices running dhcp? Does this happen when you power a bunch of devices up at a given time or everytime you power up certain devices?

gary.hostetler Wed, 01/21/2009 - 13:08

I am running 4.0.219. I have had this running on 2 controllers in 2 different buildings for a long time. They are not running dhcp. We use our normal dhcp building server. Something happened the other day maybe some kind of power blip and all of a sudden every computer was now being asked for a wep key. I have power some down one at a time and all 9 devices are the same.

The other WLC is fine and is another building so I look at that one to see if the settings are different. That was how I found out about the DHCP_RECD instead of RUN.

thanks

Gary

Scott Fella Wed, 01/21/2009 - 13:16

Wierd... what encryption are you using... I have seen this when a WEP or PSK gets corrupted from some odd reason.

gary.hostetler Wed, 01/21/2009 - 13:18

No encryption ever. That's why I wonder if a power blip could have caused some corruption.

Scott Fella Wed, 01/21/2009 - 13:23

What you can try to do is delete the wlan and recreate it and reboot the wlan. If that doesn't work, then maybe you should configure the wlc from scratch.

gary.hostetler Wed, 01/21/2009 - 15:43

I did delete the wlan but to no avail. I reloaded the 4.0.219 software. No go. Since I don't have my serial cable attached I will wait until I get there to reset to factory defaults. I did screen shots of my settings so I don't have to reinvent the wheel.

thanks

gary

Scott Fella Wed, 01/21/2009 - 19:50

When you blow the configuration and you reboot and complete the initial startup wizard, configure the rest either from the gui or the cli. Don't restore the configuration from a backup since that might be corrupted. Good luck and let us know if this worked or not.

gary.hostetler Thu, 01/22/2009 - 03:34

I decided not to restore the config because I'm also afraid it is corrupted in there somewhere. I took screen shots of my settings so as not to reinvent the wheel.

thanks

gary

gary.hostetler Thu, 01/22/2009 - 07:10

I fixed this after remembering that I had to change the DHCP server ip address to a virtual one and another address is now tied to the actual nic card in the DHCP server. As soon as I changed the DHCP setting in the WLC to the new one, bang they all started working. What tipped me off was a laptop would struggle to try and get an address on the network when connecting to the controller and the client properties would say dhcp required, but I also remembered that complaints came about the same time as when I swapped addresses on the DHCP server.

So there was nothing wrong with the WLC which is good to know.

thanks for the help.

Actions

This Discussion