Marking all inbound packets to DSCP=EF

Unanswered Question
Jan 21st, 2009
User Badges:

I need to mark all the traffic arriving at a particular switcg port with a dscp value of EF.


I have the following configuration but as best I can tell its not working. If I run show access list the hit counter never increments but when I sniff on the port I am applying the service-map to I see a mountain of UDP traffic.


Any thoughts would be helpful - thanks.



access-list 105 permit udp host 10.100.120.120 any


class-map match-all VOIP

match access-group 105

!

!

policy-map SETDSCP

class VOIP

set dscp ef


interface GigabitEthernet7/48

switchport

switchport access vlan 200

switchport mode access

no ip address

speed 1000

duplex full

mls qos statistics-export

mls qos trust cos

spanning-tree portfast

service-policy input SETDSCP

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
Jon Marshall Wed, 01/21/2009 - 15:34
User Badges:
  • Super Blue, 32500 points or more
  • Hall of Fame,

    Founding Member

  • Cisco Designated VIP,

    2017 LAN, WAN

Which switch type are you using ?


Jon

Jon Marshall Wed, 01/21/2009 - 15:52
User Badges:
  • Super Blue, 32500 points or more
  • Hall of Fame,

    Founding Member

  • Cisco Designated VIP,

    2017 LAN, WAN

Do you want to mark ALL traffic as EF ?


If so you should remove the "mls qos trust cos" statement because you don't want to trust any Cos values received you simply want to set the value to EF.


Jon

neil_titchener Wed, 01/21/2009 - 17:55
User Badges:

Run a span session on the vlan interface and filter it to only display the IP address in question. That will show you if the traffic is being marked.

It's better to span the VL interface and not the physical port as I think the traffic coppied to the span session is taken before any manipulation, i.e. before the DSCP markings would be added.


Have you enabled QoS globally?

Actions

This Discussion