LMS 2.6 / RME 4.0.6 : device update issue

Unanswered Question

trying to update device packages and get this in psu.log. I've tried the workaround for CSCsj58812 but they don't seem to fix things.

[ Wed Jan 21 17:14:37 PST 2009 ] WARN [CreateMaps : createPackageMaps] : oid : 1.3.6.1.4.1.141.1.1.7504 not found i

n e:\PROGRA~1\CSCOpx\lib\classpath\com\cisco\nm\cwcs\mdf\mdfdata.xml . Hence it will not be added to the device map.

[ Wed Jan 21 17:14:37 PST 2009 ] INFO [PackageManager : installPackages] : Releasing lock...

[ Wed Jan 21 17:14:37 PST 2009 ] INFO [InstallWrapper : installPkgs] : Installation exception

com.cisco.nm.xms.psu.packagemgmt.InstallerException: Repository in use. Another Package Support Updater client session

may be modifying device support.

at com.cisco.nm.xms.psu.packagemgmt.PackageManager.installPackages(Unknown Source)

at com.cisco.nm.xms.psu.packagemgmt.InstallWrapper.installPkgs(Unknown Source)

at com.cisco.nm.xms.psu.packagemgmt.InstallWrapper.installer(Unknown Source)

at com.cisco.nm.xms.psu.packagemgmt.InstallWrapper.main(Unknown Source)

[ Wed Jan 21 17:14:37 PST 2009 ] INFO [DeviceSupportHistory : init] : Loading history db frome:\PROGRA~1\CSCOpx\lib

\classpath\com\cisco\nm\xms\psu\conf\historyDB

[ Wed Jan 21 17:14:37 PST 2009 ] INFO [DeviceSupportHistory : init] : Number of Events Loaded in init()50

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
Joe Clarke Wed, 01/21/2009 - 18:08

Check NMSROOT/www/classpath/com/cisco/nm/xms/psu for a file called psu-installer.lock. If this file exists, delete it, then you should be able to install packages.

I deleted the lock and it seems to get a bit further, but device installation still fails. I tried installing one of the dependent packages and it says it's inconsistent:

[ Thu Jan 22 10:20:09 PST 2009 ] WARN [PsuPkgResolver : pickLatest] : No pac

kages to pick ..Empty package set passed .

[ Thu Jan 22 10:20:09 PST 2009 ] ERROR [PsuPkgResolver : populateResolverResul

t] : All selected packages failed consistency check..

[ Thu Jan 22 10:20:09 PST 2009 ] INFO [SimpleProgress : progressInfo] : Prog

ress: WARNING: SharedDcmaIOS(1.6.3): Consistency check failed for base package L

ibDcma

[ Thu Jan 22 10:20:09 PST 2009 ] INFO [PackageInstaller : installStep_resolve

] : Packages selected for install (satisfies consistency check) : []

[ Thu Jan 22 10:20:09 PST 2009 ] INFO [SimpleProgress : progressInfo] : Prog

ress: No packages to be installed

[ Thu Jan 22 10:20:09 PST 2009 ] INFO [PackageManager : installPackages] : C

reating maps in e:\PROGRA~1\CSCOpx\www\classpath\com\cisco\nm\xms\psu\pkgs\rme

[ Thu Jan 22 10:20:16 PST 2009 ] WARN [CreateMaps : createPackageMaps] : oid

: 1.3.6.1.4.1.11.2.3.7.5.19 not found in e:\PROGRA~1\CSCOpx\lib\classpath\com\c

isco\nm\cwcs\mdf\mdfdata.xml . Hence it will not be added to the device map.

Also, not sure if it's related to anything, but when I rebuild the map files, it works for rme, but cvw logs these messages:

at com.cisco.nm.xms.psu.packagemgmt.map.CreateMaps.createPackageMaps(Unk

nown Source)

at com.cisco.nm.xms.psu.packagemgmt.map.CreateMaps.main(Unknown Source)

java.util.zip.ZipException: error in opening zip file

at java.util.zip.ZipFile.open(Native Method)

at java.util.zip.ZipFile.(ZipFile.java:112)

at java.util.zip.ZipFile.(ZipFile.java:128)

at com.cisco.nm.xms.psu.util.PackageUtils.createPackageFromZip(Unknown S

ource)

at com.cisco.nm.xms.psu.packagemgmt.map.CreateMaps.createPackageMaps(Unk

nown Source)

at com.cisco.nm.xms.psu.packagemgmt.map.CreateMaps.main(Unknown Source)

java.util.zip.ZipException: error in opening zip file

at java.util.zip.ZipFile.open(Native Method)

at java.util.zip.ZipFile.(ZipFile.java:112)

at java.util.zip.ZipFile.(ZipFile.java:128)

at com.cisco.nm.xms.psu.util.PackageUtils.createPackageFromZip(Unknown S

ource)

at com.cisco.nm.xms.psu.packagemgmt.map.CreateMaps.createPackageMaps(Unk

nown Source)

at com.cisco.nm.xms.psu.packagemgmt.map.CreateMaps.main(Unknown Source)

Joe Clarke Thu, 01/22/2009 - 12:16

It looks like you have some package issues to say the least. This is typical on Windows servers. The safest solution is usually to reinstall RME from scratch after doing the following:

* Set the TEMP and TMP environment variables to short values (e.g. C:\WINDOWS\TEMP).

* Disable anti-virus software.

* Login on the server's console as a local Administrator.

* Install from locally mounted media.

In this case, it also appears you have a corrupt CiscoView package. Unfortunately, I can't tell what package is problematic. Attached is a list of CV packages and their MD5 checksums. These are all the latest packages for CV 6.1.5. Compare the checksums to files in NMSROOT/MDC/tomcat/webapps/CVng/WEB-INF/classes/com/cisco/nm/cvw/devpkgs and NMSROOT/www/classpath/com/cisco/nm/xms/psu/pkgs/cvw.

Attachment: 

Do I just re-run the RME 4.0 install from the LMS 2.5 media and run the updates or do I start from something else?

For CV, I checked the md5s and they are all OK.

There's a bunch of other files in the directory - some ending in cv50.v2-0.zip instead of just .zip. I also see a few empty files like ren.CVGenericPackage.zip - are these OK to get rid of?

Joe Clarke Wed, 01/28/2009 - 14:07

The files ending in cv50... are fine. There should be no zero-byte zip files installed by LMS in these directories. It sounds like you may have created these, so they are okay to remove.

For RME, it may not be very straight-forward. Re-running the installation alone will most likely not be successful. The best advice I can give is to reinstall all of LMS after performing my recommendations. Once it's all patched, restore your previous data.

There are ways around this, but they are rather complex, and you should probably open a TAC service request to have them help you with them.

Actions

This Discussion