Caller id information on FXO port

Unanswered Question
Jan 22nd, 2009
User Badges:

IOS: 12(4)15T

Caller id information is not pulling on Vic2-4FXO. Analog telephone pulls information correctly. Output of debug vpm signal reports "get_fxo_caller_id:Caller ID receive failed. parseCallerIDString:no data." Please help. What could be problem? bad FXO? Have tried different cptone, region, etc. with no luck. Bellcor is set as standard.

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (1 ratings)
Loading.
Chris Deren Thu, 01/22/2009 - 13:36
User Badges:
  • Super Silver, 17500 points or more
  • Hall of Fame,
  • Cisco Designated VIP,

    2017 IP Telephony, Contact Center, Unified Communications

Is this with CME or CM? If CM are you using H323 or MGCP? Caller ID is not supported with MGCP on this IOS.

If H323 then do you have caller-id enable on the voice port?


Chris

bwilloby46 Thu, 01/22/2009 - 13:38
User Badges:

CM. Caller-id enable command is on FXO ports. H323 gateway.

bwilloby46 Thu, 01/22/2009 - 13:46
User Badges:

any ideas? Currently have this issue at 2 seperate remote sites.

Chris Deren Thu, 01/22/2009 - 13:51
User Badges:
  • Super Silver, 17500 points or more
  • Hall of Fame,
  • Cisco Designated VIP,

    2017 IP Telephony, Contact Center, Unified Communications

looks like a bug, have you tried another IOS to see if this behaves the same way, i.e. 12.4.7g.

Have you looked through bug query?


Chris

bwilloby46 Thu, 01/22/2009 - 13:59
User Badges:

we have 3 sites that are up and running on the same version of code without any issues on exact same hardware and configuration. I have not checked the bug tool. An engineer from Berbee actually recommended this upgrade on our remote sites. We have 12.4(7)g running on our voice gateway in our C/O off of a PRI and caller ID is not accepted either although is being presented to smartjack, but that is a whole other issue. Issues seem to all be on Verizon Telco lines. Your thoughts?

Michael Owuor Thu, 01/22/2009 - 14:03
User Badges:
  • Cisco Employee,

Could very well be that the problem lines do not have the service enabled by the telco. A quick way to verify would be to plug the phone line into a plain analog phone and see if caller ID is received. If the same code and configuration works elsewhere, then the telco lines are the next likely cause.


Regards,

Michael.

bwilloby46 Thu, 01/22/2009 - 14:05
User Badges:

initial post confirms that analog phone pulls caller id info. see 1st post

Chris Deren Thu, 01/22/2009 - 14:07
User Badges:
  • Super Silver, 17500 points or more
  • Hall of Fame,
  • Cisco Designated VIP,

    2017 IP Telephony, Contact Center, Unified Communications

Can you attached the entire "debug vpm signal"


Chris

paolo bevilacqua Thu, 01/22/2009 - 15:07
User Badges:
  • Super Gold, 25000 points or more
  • Hall of Fame,

    Founding Member

Can you upgrade to latest 12.4(15)T and try again ? Also, could you try setting optimal impedance first with THL sweeps as described at:


http://www.cisco.com/en/US/tech/tk652/tk701/technologies_tech_note09186a0080477a06.shtml


If you want to explain also about the PRI problem, be welcome to open another thread.

Chris Deren Thu, 01/22/2009 - 15:09
User Badges:
  • Super Silver, 17500 points or more
  • Hall of Fame,
  • Cisco Designated VIP,

    2017 IP Telephony, Contact Center, Unified Communications

I would not recommend anything above 12.4.15T4 as there are major DTMF bugs I've been fighting with on all T5 - T8 versions. I keep waiting for a good release to find out the issues are not fixed every time it's released.


Chris

Nicholas Matthews Thu, 01/22/2009 - 15:28
User Badges:
  • Red, 2250 points or more

The bug you're talking about is fixed into T8.


CSCso87127.


Plus, all of this is a non-issue in 12.4(20)T and 12.4(22)T.




-nick

Chris Deren Thu, 01/22/2009 - 15:34
User Badges:
  • Super Silver, 17500 points or more
  • Hall of Fame,
  • Cisco Designated VIP,

    2017 IP Telephony, Contact Center, Unified Communications

Nick,


issue is still easily replicated with T8 in tandem with CVP as my team just validated it during recent testing, we have an open TAC case on it, plus the versions you reference are not supported with CVP, not to mention a lot of issues encountered with 12.4.20T, I have not had a chance to spend any time on 12.4.22T yet, so no comment there.

I have to admit that lately I've been very disappointed with IOS releases as it pertains to voice feature fixes as there seems to be no solid versions anymore, I still recommend 12.4.7g to majority customers and 12.4.15T4 to ones needing support in SRST for 3rd generation phones as all others have simply been too buggy, which in the field simply means trouble and a lot of wasted time and money.

Hopefully things will improve one day and we'll be back to old, better times...


Chris

Nicholas Matthews Thu, 01/22/2009 - 15:38
User Badges:
  • Red, 2250 points or more

Hi Chris,


If you email me the SR # I'll take a look. The particular DTMF bug in question is something I worked on and helped create a fix for, so I'm interested to see what issue you're running into on 12.4(15)T8. You may have something else going on (like not deleting the dsp_c5510_flex.rbf file between reloads), or a new bug.


-nick

Chris Deren Thu, 01/22/2009 - 15:41
User Badges:
  • Super Silver, 17500 points or more
  • Hall of Fame,
  • Cisco Designated VIP,

    2017 IP Telephony, Contact Center, Unified Communications

Nick,


Thanks, what's your email address?


Chris

Chris Deren Thu, 01/22/2009 - 14:04
User Badges:
  • Super Silver, 17500 points or more
  • Hall of Fame,
  • Cisco Designated VIP,

    2017 IP Telephony, Contact Center, Unified Communications

Connect an analog phone with caller ID to the jack instead of the GW and see if you get caller ID there.


Chris

Nicholas Matthews Thu, 01/22/2009 - 15:19
User Badges:
  • Red, 2250 points or more

A couple of things:

You could be having some fairly complex analog problems, and the FSK is getting distorted (provider problems). The router will be more sensitive to this than an analog phone, I'm guessing.


You may be also running into a bug on IOS. You can try running something like 12.3(14)T7 or the newest 12.4(22)T to see if the issue persists.



hth,

nick

bwilloby46 Tue, 02/03/2009 - 19:21
User Badges:

Issue was resolved. Turns out Verizon had missed configured hunt group and caller-id even after they confirmed all was working. Centrex was also on these lines. Telcos.....pretty much says it all. Thanks for all your help everyone.

paolo bevilacqua Wed, 02/04/2009 - 03:52
User Badges:
  • Super Gold, 25000 points or more
  • Hall of Fame,

    Founding Member

Telcos.....pretty much says it all.


Much truth in one line. I've rated this post!

ahab Wed, 02/04/2009 - 06:45
User Badges:

I am having the same issue. H323 gateway, tried multiple IOS revisions, same config as is working on another H323 gateway in another Canadian facility. I suppose it is time for me to go the telco route.

webberr Wed, 10/28/2009 - 05:58
User Badges:

I'm having the exact same issue. I'll call the provider, but any insight as to what they changed to make it work? It might save some time and aggravation if I knew what needed to be modified.


Thanks in advance!

Rob.

quynhnt2005 Tue, 07/05/2011 - 20:35
User Badges:

Hi

I have the same issue. But in previous time, after using command: caller-id enable, my IP phone can display the call in. It did not display in a month ago. I test the telephone line with analog phone, it is ok. Please help me!

Thanks,

Actions

This Discussion