Incoming CLI Manipulation (Verizon)

Unanswered Question
Jan 23rd, 2009

Hi All,

Has anybody had experience with a Verizon ISDN circuits in the UK?

I have an ISDN circuit provided by Verizon and another from BT.

As usual I manipulate the incoming CLI from the BT circuit to pre-pend '90' enabling the users to return calls from their call lists; '9' being for an outside line & '0' because BT never present the leading '0'!

I have tried to do the same on the Verizon circuit, they DO provide the leading '0' but I am trying to add a '9'. I have tried a h323 gateway as I use for BT and also tried an MGCP gateway by changing parameters in CUCM but neither will work.

Any ideas please?

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
iptuser55 Fri, 01/23/2009 - 03:02

Th ereason BT does not provide the leading digit 0 is becaseu you are using Euro, we also had an issue moving from DASS which did send the 0 to Euro which do not. How are you adding the 90 prefix for BT- is it via the Service Parms or via Translations in CCM or on the GW? What happens with a call from Verizon

davidjani Fri, 01/23/2009 - 03:21

Hi,

Thanks for the response.

As explained above I have tried both service parameters on an MGCP AND translations on the GW which both work successfully on the BT circuit but on the Verizon the number I see in q931 debug is passed through to the phone ignoring all of the settings and translations!

However, I have had a thought & when I can get back on to the GW I will be checking the type & plan of the call from Verizon as this may be affecting it.

Jani.

Paolo Bevilacqua Fri, 01/23/2009 - 03:43

Hi, when you're using MGCP you cannot apply translation on the GW, so check your CCM config.

Note it must be done so that one 90 is added for national calls, 900 for international.

davidjani Fri, 01/23/2009 - 03:53

Yes. Thank you for the effort but I am aware of this, as explained in the original description...

I have tried a h323 gateway as I use for BT and ALSO tried an MGCP gateway by changing parameters in CUCM but neither will work.

Both ways work for BT circuit so I know what I am doing is correct. Regardless of what I put into the parameters it will not change the number coming in from Verizon!

My question is more to do with the way Verizon present their information and other peoples experience with it rather than the configuration.

Paolo Bevilacqua Fri, 01/23/2009 - 03:57

Not really. Sometime the correct config can slip of any mind, so for example send your translation config here to check. Of course "debug isdn q931" is always useful as well.

Actions

This Discussion