mpls mtu & mtu

Unanswered Question
Jan 23rd, 2009

Hi,

I've gat a mtu issue between my PE routers. i'm trying to add another PE to my network and this bring the following problem :

Here is one of my routers working conf (Cisco 3825 c3825-adventerprisek9-mz.124-13.bin)

interface GigabitEthernet0/1

no ip address

no ip redirects

no ip unreachables

duplex full

speed 100

media-type rj45

no cdp enable

!

interface GigabitEthernet0/1.1500

encapsulation dot1Q 1500

ip address 192.168.100.10 255.255.255.248

mpls ip

mpls mtu 1508

no cdp enable

I don't change the mtu size on the interface, just the mpls mtu on the sub and it's working fine !

Now on my new 3845 (ios newer but not that much : c3845-advipservicesk9-mz.124-22.T.bin)

interface GigabitEthernet0/0

no ip address

duplex auto

speed auto

media-type sfp

negotiation auto

mpls ip

!

interface GigabitEthernet0/0.1501

encapsulation dot1Q 1501

ip address 192.168.200.10 255.255.255.248

mpls ip

no cdp enable

!

The command mpls mtu 1508 is not accepted on my sub. I must set the mtu on the interface larger than the mpls mtu size. The problem is that if i change this mtu size on this interface, my ospf neighboring does not go up as the other PE are configured with a mtu interface of 1500.

Is there a way to avoid this limitation ? Is this due to my recent IOS or something else ?

Thank you !

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (4 ratings)
Loading.
guruprasadr Fri, 01/23/2009 - 07:58

HI mathieu, [Pls RATE if HELPS]

If you attempt to set the MPLS MTU value higher than the interface MTU value, the software displays the following error, which reminds you to set the interface MTU to a higher value before you set the MPLS MTU value:

% Please increase interface mtu to xxxx and then set mpls mtu

The Open Shortest Path First (OSPF) routing protocol requires that the IP MTU values match on both ends of the link.

Try configuring "IP MTU 1500" on both ends of the sub-Interfaces and verify to see if the OSPF complete its initialization.

Hope I am Informative. Pls RATE if HELPS

Best Regards,

Guru Prasad R

mathieu.ploton Fri, 01/23/2009 - 08:01

I've done that.

I'm just wondering why it works previously on my 3825. The ip mtu is one of the solution and the ospf comes up but it seems to have some issues on the LAN after this modification ("unknown protocol drops" increase on the PE-EC interfaces).

Mohamed Sobair Sat, 01/24/2009 - 13:53

Hello,

MTU differs, The Interface IP MTU is 1500 Byte, why we should modify MPLS MTU? Cause with MPLS a label of 4 Byte is inserted between the l2 header and L3 header of the Packet + 4 Byte for the Control word which becomes 8 Bytes in total (1508). Never doing so , could result in Fragmentation which will lead to lack of Network Performanc (Not recommended).

HTH

Mohamed

Giuseppe Larosa Sun, 01/25/2009 - 05:25

Hello Mathieu,

I think Guru has provided a good workaround.

About why the change in behaviour of IOS:

You can think that now in more modern releases a tighter control is performed so you need to increase the interface mtu to be able to increase the mpls mtu.

This is logical if you consider interface MTU at OSI layer 2.5 (under L3).

I think there is some confusion in these commands I would prefer to set interface mtu and to be able to specify how many mpls labels the interface can support(mpls stack depth) .

Then, as Guru has suggested you can lower IP mtu to be able to build OSPF adjacencies.

To be noted MPLS frames cannot be fragmented or they are able to pass (to be sent and received on the link) or they are discarded.

Hope to help

Giuseppe

mathieu.ploton Sun, 01/25/2009 - 05:30

But the right thing to do would be :

review all my PE and set MTU to 1508 and MPLS MTU to 1508.

In that case, ospf adjancency will be up and my network will be working with no packet drops ?

Giuseppe Larosa Mon, 01/26/2009 - 02:51

Hello Mathieu,

for me the better is :

mtu 1512

ip mtu 1500

mpls mtu 1508

just to handle also 802.1Q four bytes header when present

Hope to help

Giuseppe

flymen331 Wed, 02/18/2009 - 08:33

Also, I think you can change interface MTU and add "ip ospf mtu-ignore" on the interface. That ospf should work fine.

Actions

This Discussion