cisco877W (ADSLoPOTS) connect to ADSLoISDN ?

Answered Question
Jan 24th, 2009
User Badges:

Is there a way to connect the cisco 877W (ADSLoPOTS) to an external dsl-modem ?

I've changed my telephoneline from analo to isdn.

Any help ?


Correct Answer by paolo bevilacqua about 8 years 3 months ago

If you have PPPoE, you configure that on the port that has a different vlan assigned to it:


http://www.cisco.com/en/US/products/hw/routers/ps380/products_configuration_example09186a0080094475.shtml


(note, you don;t need the vpdn group stuff in the example above).


But it is not said that you have PPPoE.


Hope this helps, please rate post if it does!

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (2 ratings)
Loading.
paolo bevilacqua Sat, 01/24/2009 - 14:07
User Badges:
  • Super Gold, 25000 points or more
  • Hall of Fame,

    Founding Member

With an advanced services image, you should be able to create a vlan for the external modem.


Hope this helps, please rate post if it does!



Carsten Radke Sun, 01/25/2009 - 04:01
User Badges:

If I understand right, I've to create a seperate VLAN to Fastethernet0, connect the DSL_Modem to Fastethernet0, make Fastethernet0 a member of my Diealergroup and thats it ?

Have you an example config for me ?


Carsten

Correct Answer
paolo bevilacqua Sun, 01/25/2009 - 11:38
User Badges:
  • Super Gold, 25000 points or more
  • Hall of Fame,

    Founding Member

If you have PPPoE, you configure that on the port that has a different vlan assigned to it:


http://www.cisco.com/en/US/products/hw/routers/ps380/products_configuration_example09186a0080094475.shtml


(note, you don;t need the vpdn group stuff in the example above).


But it is not said that you have PPPoE.


Hope this helps, please rate post if it does!

Carsten Radke Sun, 01/25/2009 - 12:24
User Badges:

I've tried your response, but the router doesn't connect to internet.

The debug shows:

internet#sh debug

Dial on demand:

Dial on demand events debugging is on

PPPoE:

PPPoE protocol events debugging is on

PPPoE data packets debugging is on

PPPoE control packets debugging is on

VPN:

VPDN events debugging is on

VPDN packet debugging is on

internet#

*Mar 1 01:21:34.751: padi timer expired

*Mar 1 01:21:34.751: Sending PADI: Interface = FastEthernet0

*Mar 1 01:21:34.751: pppoe_send_padi:

FF FF FF FF FF FF 00 24 14 43 6C 25 88 63 11 09

00 00 00 0C 01 01 00 00 01 03 00 04 83 BC 8E 08 ...


show vlan-switch:

VLAN Name Status Ports

---- -------------------------------- --------- -------------------------------

1 default active Fa1, Fa2, Fa3

10 ethernet0-dsl active Fa0


My config:

dot11 syslog

!

dot11 ssid test

authentication open

!

ip cef

no ip dhcp use vrf connected

ip dhcp excluded-address 10.10.10.1

ip dhcp excluded-address 192.168.10.2

!

ip dhcp pool sdm-pool

import all

network 192.168.10.0 255.255.255.0

default-router 192.168.10.2

domain-name navi.de

dns-server 62.72.64.237 62.72.64.241

lease 0 2

!

!

ip domain name cradke.de

ip name-server 62.72.64.237

ip name-server 62.72.64.241

!

vpdn enable

!

vpdn-group 1

request-dialin

protocol pppoe

!

vpdn-group pppoex

! Default L2TP VPDN group

!

!

!

username xxx privilege 15 password 7 1xxx8307927

!

!

archive

log config

hidekeys

!

!

!

bridge irb

!

!

interface ATM0

description DSL-Internet

no ip address

shutdown

no atm ilmi-keepalive

dsl operating-mode auto

!

interface FastEthernet0

description to DSL-Modem

switchport access vlan 10

pppoe-client dial-pool-number 1

!

interface FastEthernet1

!

interface FastEthernet2

!

interface FastEthernet3

!

interface Dot11Radio0

no ip address

!

ssid test

!

speed basic-1.0 basic-2.0 basic-5.5 6.0 9.0 basic-11.0 12.0 18.0 24.0 36.0 48.0 54.0

station-role root

bridge-group 1

bridge-group 1 subscriber-loop-control

bridge-group 1 spanning-disabled

bridge-group 1 block-unknown-source

no bridge-group 1 source-learning

no bridge-group 1 unicast-flooding

!

interface Vlan1

description

no ip address

ip nat inside

ip virtual-reassembly

zone-member security in-zone

ip tcp adjust-mss 1412

bridge-group 1

!

interface Dialer0

description xx

ip address negotiated

ip mtu 1492

ip nat outside

ip virtual-reassembly

zone-member security out-zone

encapsulation ppp

dialer pool 1

dialer-group 1

no cdp enable

ppp authentication chap pap callin

ppp chap hostname [email protected]

ppp chap password 7 xxx7E72

ppp pap sent-username [email protected] password 7 xxxx117F7D

!

interface BVI1

description $ES_LAN$

ip address 192.168.10.2 255.255.255.0

ip nat inside

ip virtual-reassembly

ip forward-protocol nd

ip route 0.0.0.0 0.0.0.0 Dialer0

ip http server

ip http access-class 23

ip http authentication local

ip http secure-server

ip http timeout-policy idle 60 life 86400 requests 10000

ip nat inside source list 100 interface Dialer0 overload

access-list 23 permit 10.10.10.0 0.0.0.7

access-list 23 permit 192.168.10.0 0.0.0.255

access-list 100 remark SDM_ACL Category=2

access-list 100 permit ip 192.168.10.0 0.0.0.255 any

access-list 101 remark SDM_ACL Category=128

access-list 101 permit ip host 255.255.255.255 any

access-list 101 permit ip 127.0.0.0 0.255.255.255 any

dialer-list 1 protocol ip permit

no cdp run

control-plane

bridge 1 protocol ieee

bridge 1 route ip


please help,


Carsten

paolo bevilacqua Sun, 01/25/2009 - 13:35
User Badges:
  • Super Gold, 25000 points or more
  • Hall of Fame,

    Founding Member

Hi,


you do not need vpdn-group.

Put the pppoe client under interface vlan10.


Hope this helps, please rate post if it does!

Actions

This Discussion