Multicast Dense Mode

Unanswered Question
Jan 24th, 2009

If i have multiple interfaces configured on same router with dense mode, How can i make traffic received on dense mode interface (Interface A) broadcasting to another dense mode interface (Interface B). Downstream router on Interface B is not sending "prune" messages because managed by another vendor and vendor does not want to configure anything on interface connecting to Interface B. I am seeing lots of output multicast packets on Interface B, originally received from Interface A upstread neighbor.

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
Giuseppe Larosa Sun, 01/25/2009 - 04:55

Hello Neil,

if you don't want to have multicast traffic received on interface A to be propagated to interface B you should probably move to IP PIM sparse mode so that in absence of signalling the interface is pruned from the multicast group oilist.

you can configure all interfaces with

ip pim sparse-dense-mode

then you define a loopback on your router as the RP and you use an ACL that includes that multicast group.

In this way that specific group is treated as Sparse mode and requires explicit join to send traffic out an interface

ip pim [vrf vrf-name] rp-address rp-address [access-list] [override] [bidir]

see

http://www.cisco.com/en/US/docs/ios/ipmulti/command/reference/imc_04.html#wp1014400

to be noted for all groups not matching the ACL they are processed in dense mode so this has a light and tunable impact.

In the future should other groups need to be filtered out it you just need to add lines to the ACL used in pim rp-address command

another possible option could be to use

Cisco IOS 12.3(11)T and Subsequent T and Mainline Releases

ip multicast boundary access-list [filter-autorp | in | out]

with the out option

But I didn't test this.

Hope to help

Giuseppe

NeilP12345 Sun, 01/25/2009 - 06:14

Hi Giuseppe,

Thanks for reply.

Configuring sparse mode or sparse-dense mode is not an option because of some legacy configuration. I am also running 12.2(17)SX on 6500 with Sup720.

Thanks

Harold Ritter Sun, 01/25/2009 - 11:51

Neil,

I don't completely understand what the issue is here. You are asking how you can send multicast traffic received on Interface A to Interface B and then you are saying that you are seeing the multicast traffic being sent to Interface B. Can you be a bit more explicit about what you are trying to achieve and maybe who is the other vendor and what they are and are not able to support.

Regards

NeilP12345 Tue, 01/27/2009 - 10:44

Interface A is connected to Vendor A

Interface B is connected to Vendor B.

Interface A and B are in dense mode and do not want to change that configuration.

Interface A sends multicast feeds which also goes to Interface B. Vendor B does not send "prune" messages so Traffic from Interface A continously goes to Interface B.

Changing Dense mode to sparse mode is not an option. I am running IOS 12.2.17 SXD.

Thanks

Neil

Harold Ritter Tue, 01/27/2009 - 12:04

Neil,

Is the goal to prevent traffic from Interface A not to get to Interface B? If so, you could isolate interface B and all other interfaces that need to communicate with it by putting them all in a VRF.

Regards

Mohamed Sobair Tue, 01/27/2009 - 13:24

Neil,

Both routers has to be (Pim Dense or Sparse-dense Enabled) in order to be Pim Neighbors.

Another way is to have (Stub Multicasting) Configured to eleminate Pim Neighborship, preventing unnecessary pim dense Messages (Join,Prune ,Graft , Graft Ack).

HTH

Mohamed

Actions

This Discussion