CUBE on 2611XM does not register with SIP provider

Unanswered Question
Jan 25th, 2009

Hi, I'm trying to register my 2611XM (c2600-adventerprisek9_ivs-mz.124-23.bin) with my SIP provider to make in and outgoing SIP calls to CUCM6. But whatever I try, my CUBE does not register with my SIP provider. Does anyone now what's wrong?

Best regards, Peter

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 4.6 (5 ratings)
Nicholas Matthews Sun, 01/25/2009 - 21:03

So for CUBE, it's a little trickier.

There are two ways to make a number attempt to register with the registrar:

-A pots dial peer with a destination pattern

-An ephone-dn in CME

The pots dial peer is normally not available for CUBE due to a lack of analog voice ports.

You can do something like this:


ip source

max-ephone 1

max-dn 1

ephone-dn 1


That's the trickiest part of registration on CUBE. 'debug ccsip messages' helps and 'show sip status reg' and 'show sip regist stat' help. I get the last two commands mixed up, so I generally use both :)



pverstegen Mon, 01/26/2009 - 12:32

Hi Nick,

Your solution is extremely helpfull. At least there is some activity now, but I'm still not registered yet.

Line peer expires(sec) registered

==== ==== ============ ===========

0475881803 20001 110 no

Problem is that my provider listens on SIP-port 38383 instead of 5060 and it seems that my router also has to listen on port 38383 to register succesfull. With my IOS version I'm not able to use the sip listening-port command under "service voip voip - sip". I tried to fix this with my PIX using static nat, but without succes at the moment.

Do you have any idea how I can fix this?

Best regards, Peter

Nicholas Matthews Mon, 01/26/2009 - 13:03

Hi Peter,

It may be trickier to do it with NAT. The port gets put into the Contact: and From: fields, and I don't know if the PIX will NAT fix-up those fields or not.

My advice is to get to 12.4(20)T, I believe anyway, where the feature with the listen-port was added.



pverstegen Tue, 01/27/2009 - 01:49

Hi Nick,

The latest T-release on CCO for my 2611XM is c2600-ipvoice_ivs-mz.124-15.T8.bin.

I'm not sure if it supports sip listen-port command and besides that I have to upgrade flash and dram (currently 32/128 installed)

Any suggestion? Peter.

Nicholas Matthews Tue, 01/27/2009 - 05:39

Yes, true. This is a 12.4(20)T feature which your 2600 will not support.

The only other option is deep packet inspection with SIP that will change the port fields in the SIP messages, or finding a different provider which doesn't have this restriction.



pverstegen Tue, 01/27/2009 - 12:46

Hi Nick,

I have been testing with a different SIP provider (using 5060). My sip-ua status was registered immediately. But calls still don't reach my CUCM. According to debugging output there are some problems with codec.

Do you know some good documents regarding my setup: CUCM6-H323-CUBE-(MTP)-SIP-provider.

Best regards, Peter

Nicholas Matthews Tue, 01/27/2009 - 13:32

Hi Peter,

If you're troubleshooting codec problems, sometimes it's best to put 'codec transparent' on both incoming and outgoing dial-peers. This just lets the codec negotiations pass through the CUBE.

You will have to check your dial peer destination patterns to see if they're going to CUBE.

Debugging 'debug h245 asn1' and 'debug h225 asn1' will help you see if you're even sending it towards your CUCM. If you are, you'll see a whole bunch of debugs. That means your CUCM doesn't like something you're sending, or you have CUCM config problems (like CSS).

Things to check:

-You have the h323 bind command on the interface you have configured in CUCM.

-CSS assigned to H323 gateway contains partition of phone you're dialing

-You are dialing the number in the format that the number is in on CUCM (significant digits, leadings 9's 1's, etc)



pverstegen Wed, 01/28/2009 - 13:16

Hi Nick,

debugging h245/h225 asn1 doesn't show any messages. Perhaps you can take a look at the config of my 2611XM which is behind PIX only doing PAT.

Many many thanks.


Attached: CUBE.txt

Nicholas Matthews Wed, 01/28/2009 - 13:54

If you're looking in your logging buffer, you are only looking at information level debugs:

logging buffered 1000000 7


conf t


make sure your logging is on, or 'term mon'.

then add 'debug ccsip messages' and make sure you're actually receiving the SIP messages.



Nicholas Matthews Wed, 01/28/2009 - 14:42

Could be a few things:

-Maybe you don't have reachability to CUCM

-Maybe CUCM isn't set up for H323 for this IP address


-Bug in 12.4 mainline

Try downloading 12.4(15)T8 see if it helps. Codec transparent isn't supported in this IOS, among other things.



pverstegen Thu, 01/29/2009 - 06:28

Hi Nick,

12.4(15)T8 will not fit(256/64MB).

Perhaps you can answer following questions I'm currently not sure of:

1) Should I use the interface facing the CUCM as h323 source interface and the interface facing the PIX as SIP source interface?

2 Do I realy need MTP functionality? The MTP config does not support codec-transparant.

Just take your time...


Nicholas Matthews Thu, 01/29/2009 - 07:40

1) Yes. Bind both of them, and make sure that you reference the correct IP addresses on each side.

2) Codec transparent is a CUBE feature that says "pass all the codec negotiations through without changing them". The MTP is completely oblivious to this, and of course supports it. MTPs are required by different call versions and situations. Generally for SIP-H323 it becomes required, but not always. I would keep it on.

If it doesn't fit on the flash, try something like this:

Router(config)#boot system flash tftp://



pverstegen Sat, 01/31/2009 - 06:24

Hi Nick,

I just ordered some DRAM. If it's installed I will let you know.

All the best,


pverstegen Wed, 02/04/2009 - 12:52

Hi Nick, I made some progress now. 12.4.15T8 is running now and I'm able to make outside calls. But when I dial my provider asigned number 31475712078, I get busy tone (logging.txt). In my Callmanager I have configured a translation pattern which turns 31475712078 into 600 (which is a huntgroup ringing all phones). Please take a look at the logging and config.

Best regards, Peter

pverstegen Sun, 02/08/2009 - 11:20


I am still not able to dial into my CUBE to CallManager6. It seems that all inbound call's to 31475712078 hit my ephone-dn instead of the dial-peer to CallManager6, which destination-pattern is equal to my ephone-dn number. That's why (I think) all inbound call's get busy tone. I tried to give my ephone-dn preferance 10 but nothing helps. Do you have any suggestions?

Regards, Peter

Nicholas Matthews Sun, 02/08/2009 - 12:54

Hi Peter,

You may want to do something like this:

Say the DID is 5551234.

ephone-dn 1

number 5551234

call-forward all 1234

dial-p v 1 voip

destination-pattern 1234

session target ipv4:

Then in CCM you can have a translation pattern. Alternatively, you can put an outgoing translation pattern on dial-peer 1 that changes the number back.



pverstegen Tue, 02/10/2009 - 12:57

Hi Nick,

I tried call-forward all to 500. This is what happens:

019873: Feb 10 21:43:38.423 CET: //636/54005FBC8423/CCAPI/ccCallForwardTo:

Call Forward Number=500, Call Forward Cause Reason=15, Call Id=636

019874: Feb 10 21:43:38.435 CET: //636/54005FBC8423/CCAPI/cc_api_call_disconnected:

Cause Value=16, Interface=0x84E47A44, Call Id=636

A test call to 500 (csim start 500) seems to work fine...

Any suggestions?

Best regards, Peter

Nicholas Matthews Tue, 02/10/2009 - 13:00

I can't tell why the call is disconnecting with those debugs.

It disconnects with cause 16 which is a normal disconnect cause.


pverstegen Tue, 02/10/2009 - 13:12

nick, please tell me what output you need. i will sent it as an attachment.

many thanx, Peter

pverstegen Wed, 02/11/2009 - 01:31

Hi Nick,

Please find attached the "CUBE config", the "debug voice ccapi all" output, as well as my CUCM6 "RoutePlanReport".

Thank you for your patience...


Nicholas Matthews Wed, 02/11/2009 - 06:47

You need to look at the SIP messaging to find out why this is happening. From the debugs it looks like the call goes out.


pverstegen Wed, 02/11/2009 - 08:32


According to the SIP debugging(attached) it looks that we get an 3456XX Error Response after which the call is disconnected.

Do you know what this error message means?


Nicholas Matthews Wed, 02/11/2009 - 09:08

Looks like we're using a 302 message - they probably don't support that.

Try this:

voice service voip

no supplementary sip moved


pverstegen Wed, 02/11/2009 - 10:11


You are GREAT!!!

This command solved my issue.

Thank you very very much for your assistance.


Nicholas Matthews Wed, 02/11/2009 - 11:13

Hi Peter,

Thanks for the kind comments/ratings!

I'm glad I could help you figure this out.



This Discussion