Router Audit Tool

Unanswered Question
Jan 25th, 2009
User Badges:

Hi,

I chanced upon this tool on the internet some days back and have been trying to use it without any success.I have looked everywhere without any troubleshooting documents as well.I have installed Active Perl as well as the RAT on the C drive as follows with the default unstallations. C:\Perl and C:\CIS. I have a sample configuration file called SampleIOSConfig.txt in the path C:\CIS\RAT\etc\configs\cisco-ios as well as the local.conf file. The rat.exe is in the pathC:\CIS\RAT\bin\ .When I run C:\CIS\RAT\bin\rat -r local.conf SampleIOSconfig.txt, I get this message:

C:\>CIS\RAT\bin\rat -r local.conf SampleIOSConfig.txt

No configuration files available to audit at rat line 897.Yet,when I put the files in the temp directory and run I get it run successfully as shown:

C:\>cd temp


C:\Temp>C:\CIS\RAT\bin\rat -r local.conf SampleIOSConfig.txt

auditing SampleIOSConfig.txt...

Parsing: /local.conf/

Checking: SampleIOSConfig.txt

done checking SampleIOSConfig.txt.

Parsing: /local.conf/

ncat_report: writing SampleIOSConfig.txt.ncat_fix.txt.

ncat_report: writing SampleIOSConfig.txt.ncat_report.txt.

ncat_report: writing SampleIOSConfig.txt.html.

ncat_report: writing rules.html (cisco-ios-benchmark.html).

ncat_report: writing all.ncat_fix.txt.

ncat_report: writing all.ncat_report.txt.

ncat_report: writing all.html.


C:\Temp>


How do I get it run correctly?

Any assistance please



  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
xhackuss1 Fri, 01/30/2009 - 01:24
User Badges:

Thanks Eddie. I have already tried nipper. I is very easy to use.The only prolem I have with nipper which I am still investigating is why it gave me a report that my 3750 switch had ssh port open when infact,the IOS doesn't support ssh.


Any idea how I can get accurate results from an audit?



Actions

This Discussion