Configuring CUPS 7.0.2 with CUCM 6.1.2 for OCS2007

Unanswered Question
Jan 26th, 2009

Hi,

I am trying to setup OCS2007 with CUPS 7.0.2 and CUCM 6.1.2.

I followed the documentation that I found on the cisco web-site, but the integration is not working.

In attach you can find an overview of my configuration.

Does anyone have an idée of what I am doing wrong here?

Here are the links to the documentation I have used:

http://www.cisco.com/en/US/docs/voice_ip_comm/cucme/pbx/interop/notes/617030nt.pdf

http://cisco.com/en/US/docs/voice_ip_comm/cups/7_0/english/integration_notes/IntegrationNoteOCS_CUP70_MOCCallControl.html

Thanks in advance.

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (2 ratings)
Loading.
htluo Mon, 01/26/2009 - 06:39

From the log, CUPS sent successful response to OCS. But OCS didn't trust the message.

If you looked at OCS log, you should see something like this "Result-Code: 0xc3e93f1e SIPPROXY_E_INVALID_RECORD_ROUTE".

To fix this problem, go to OCS management control, right-click on "Front Ends" folder, go to "Properties > Host Authorization". Add the CUPS IP address to the list with the following options:

Outbound Only: No

Throttle as server: Yes

Treat as Authenticated: Yes

After applying the changes, restart Front End service.

I recommend you take a look at this book:

http://www.lulu.com/content/5552336

The book has in-depth explanation of CUPS and OCS. It also give you some real examples using OCS debug tools.

Also, take a look at my blog:

http://htluo.blogspot.com/

Thanks!

Michael

RUOO Tue, 01/27/2009 - 02:14

Hi,

Thanks for your reply.

I have checked the OCS Configuration.

We already configured the hostname of the CUPS Server under the Host Authorization of the Front-End with the options Throttle as server and Treat as Authenticated.

So I assume that this is correct?

In attach you can find the OCS Configuration.

Attachment: 
htluo Tue, 01/27/2009 - 06:32

no, that is NOT correct. You have to following my suggestion to the letter. :)

ie. Use IP address instead of hostname.

On network layer, hostname and IP makes no difference as long as hostname can resolved to the correct IP.

On SIP, it makes BIG difference.

Michael

RUOO Wed, 01/28/2009 - 01:16

Hi,

The integration is working now.

After modifying the OCS Host Authorization to the IP-Address of the Presence Server.

Many thanks for your help.

Regards,

Rudy.

Actions

This Discussion