NM-NAM Get Set Status Message

Unanswered Question
Jan 26th, 2009

We are running an NM-NAM on our 3845 router. We are setting up External Capture Data Storage to an NFS Share. We defined a volume for the NAM, and then configured the "Capture Data Storage" configuration screen on the NAM.

When we configured the appropriate settings, and then clicked Apply, we received the following error:

"NFS remote storage set. However, getting set status failed."

We are not certain what this means.

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
Joe Clarke Mon, 01/26/2009 - 12:59

This typically points to a permissions problem on the NFS server. However, the problem may also be that you are not running an RPC lock daemon on the server. The NAM tries to get an exclusive lock on the NFS volume. If this fails, you get the error. The NAM will access the NFS volume with UIDs 80 and 0, so make sure that the server allows this.

Kevin Melton Mon, 02/02/2009 - 09:40

We have not had success in getting the NAM to see the NFS share or authenticate to it. As an alternative method, we tried creating an iSCSI volume on our NetApp instead. We then configured the NAM to use the NetApp. It sees the volume we believe, in that we are not getting the same error message, and it creates a Storage Entry. The only issue is that it indicates "unknown target" in the Free Storage section of the Capture Data Storage Table. It has asked us to reboot the NAM twice when we attempted to configure the iSCSI section.

It also fills in a "-1" value for "use existing partition" each time.

I am including an attachment which illustrates what I am describing.

Joe Clarke Mon, 02/02/2009 - 10:04

This looks like a problem with the iSCSI provider. The NAM tries to connect to the specified target, but it doesn't find it.

I suppose this could also be a problem on the NAM side, but I have not seen any customers complaining of similar errors. I have not personally tested the NAM with iSCSI as I do not have any providers. I have, however, got the NAM working with NFS to Solaris and FreeBSD servers.

I suggest you open a TAC service request so more analysis can be done. The NAM developers can confirm exactly why this error message is occurring.

trlayton Tue, 09/15/2009 - 13:27

Researching the iSCSI configuration on the NetApp and NAM module for you but can help with the NFS configuration on the NetApp now.

NetApp volumes have two types of qtrees (either NTFS or UNIX). It is likely that your system is configured to default to the NTFS qtree type. Thus attempting to mount the NFS volumes is being denied because the NAM cannot interpret the NTFS access policy. Have your netapp administrator go into the volume management area of NetApp filerview. Go to qtree's select manage and then change the qtree type to Unix.

The next thing you want to do is go to the NFS section of filer view. Select exports. Then click on the NFS export and edit the export rules to allow root to mount the volume from the IP address of the NAM in your case 192.168.15.51 (if that is the IP that will be the source of the mount request to the NetApp). Also enter that same address in the authorized to read and write field.

Your NFS mount should work then.

Actions

This Discussion