trunking

Unanswered Question
Jan 26th, 2009
User Badges:

layout:.

server1---dell-Switch---Cisco4948---Server2


dot1q trunking setup between dell and cisco.

Trunk set to on.

Etherchannel between dell and cisco. Set to

lcap.

------------ connection to dell switch

interface GigabitEthernet1/2

switchport trunk encapsulation dot1q

switchport mode trunk

channel-protocol lacp

channel-group 2 mode active

-------------------

interface Port-channel2

switchport

switchport trunk encapsulation dot1q

switchport mode trunk

-----------------------

show etherchannel summary

Po2(SU) LACP Gi1/2



now when I set server1 to be on native vlan 1

(no tagging)

I can ping server 2 with packet size 1500

When server2 is set to other vlan, maximum packet size that i can get is 1496. If set ping to send 1497byte packets i do not get icmp' back.

Now i create new port-channel on cat 4948. Ch5

Po5(SU) LACP 18(P)


sh run

Gi1/interface Port-channel5

switchport

switchport trunk encapsulation dot1q

switchport mode trunk

-------------

interface GigabitEthernet1/18

switchport trunk encapsulation dot1q

switchport mode trunk

channel-protocol lacp

channel-group 5 mode active


I create the new port g1/18 exactly as the gi 1/2.

pull the cable from gi1/2 plug in into 1/18

do a ping test with 1500bytes packet. Works great.

I do not see any difference between those two ports. trunking setting are all the same. but something is wrong with gi1/2. I checked counters no errors.

I believe there has to be something wrong with gi1/2 interface but i cannot find out what.




  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
sarahr202 Mon, 01/26/2009 - 20:31
User Badges:
  • Bronze, 100 points or more

Hi

I need more info

etherchannel between cisco dell switch:


for example ports on dell switch and ports on cisco switch, configurations on both switches.


Connection between dell switch and server 1:

ports on each and their configurations


connection between cisco switch and sever 2:

ports on each and their configuration


Thanks a lot!

prekursor Tue, 01/27/2009 - 06:18
User Badges:

Here is sh run from dell PowerEdge 5316

server is on g1

etherchannel to cisco is on g12-16

====================

interface ethernet g1

spanning-tree portfast

interface port-channel 1

switchport mode trunk

interface range ethernet g(12-16)

switchport mode trunk

interface port-channel 1

switchport trunk allowed vlan add 10

interface port-channel 1

switchport trunk allowed vlan add 50

interface ethernet g1

switchport access vlan 10

port-channel load-balance layer-2-3

interface range ethernet g(12-16)

channel-group 1 mode auto

---------------------

Now on cat4948 I have 5 channels.

Only channel 2 is bad. that is where dell switch was connected before.

Now i moved dell switch to channel 5.

Channel 2 port is down also, since i moved dell to channel 5

--------------------

Group Port-channel Protocol Ports

------+-------------+-----------+-----------

2 Po2(SD) LACP Gi1/2(D)

5 Po5(SU) LACP Gi1/18(P) Gi1/19(P) Gi1/20(P)

---------------------------------

sh run (cat4948 for channels 2 and 5)

interface Port-channel2

switchport

switchport trunk encapsulation dot1q

switchport mode trunk

!

interface Port-channel5

switchport

switchport trunk encapsulation dot1q

switchport mode trunk

!

interface GigabitEthernet1/2

switchport trunk encapsulation dot1q

switchport mode trunk

channel-protocol lacp

channel-group 2 mode active

!

interface GigabitEthernet1/18

switchport trunk encapsulation dot1q

switchport mode trunk

channel-protocol lacp

channel-group 5 mode active

!

========================

sh int port-channel 2


Port-channel2 is down, line protocol is down (notconnect)

Hardware is EtherChannel, address is 0000.0000.0000 (bia 0000.0000.0000)

MTU 1500 bytes, BW 100000 Kbit, DLY 100 usec,

reliability 255/255, txload 1/255, rxload 1/255

Encapsulation ARPA, loopback not set

Keepalive set (10 sec)

Auto-duplex, Auto-speed, media type is N/A

input flow-control is off, output flow-control is unsupported

ARP type: ARPA, ARP Timeout 04:00:00

Last input 14:07:12, output never, output hang never

Last clearing of "show interface" counters never

Input queue: 0/2000/0/0 (size/max/drops/flushes); Total output drops: 0


sh int port-channel 5


Port-channel5 is up, line protocol is up (connected)

Hardware is EtherChannel, address is 0021.d880.7713 (bia 0021.d880.7713)

MTU 1500 bytes, BW 3000000 Kbit, DLY 10 usec,

reliability 255/255, txload 2/255, rxload 24/255

Encapsulation ARPA, loopback not set

Keepalive set (10 sec)

Full-duplex, 1000Mb/s, media type is N/A

input flow-control is off, output flow-control is unsupported

Members in this channel: Gi1/18 Gi1/19 Gi1/20

ARP type: ARPA, ARP Timeout 04:00:00

Last input 14:05:11, output never, output hang never

Last clearing of "show interface" counters never

Input queue: 0/2000/0/0 (size/max/drops/flushes); Total output drops: 0

Queueing strategy: fifo

Output queue: 0/40 (size/max)

5 minute input rate 285173000 bits/sec, 31512 packets/sec

5 minute output rate 32298000 bits/sec, 17549 packets/sec


==================================

sh int gi 1/2

show interfaces gigabitEthernet 1/2

GigabitEthernet1/2 is down, line protocol is down (notconnect)

Hardware is Gigabit Ethernet Port, address is 0021.d880.7701 (bia

0021.d880.7701)

MTU 1500 bytes, BW 1000000 Kbit, DLY 10 usec,

reliability 255/255, txload 1/255, rxload 1/255

Encapsulation ARPA, loopback not set

Keepalive set (10 sec)

Auto-duplex, Auto-speed, link type is auto, media type is 10/100/1000-TX

input flow-control is off, output flow-control is off

ARP type: ARPA, ARP Timeout 04:00:00

Last input 14:07:16, output never, output hang never

Last clearing of "show interface" counters

Giuseppe Larosa Tue, 01/27/2009 - 07:45
User Badges:
  • Super Silver, 17500 points or more
  • Hall of Fame,

    Founding Member

Hello Mariusz,

a difference of four bytes in the two directions is exactly the size of the 802.1Q header and makes to think someone is tagging native vlan unexpectedly.


Another possibility is that the problem was caused by the sequence of commands used to build the second port-channel.

Like for example you had before an access layer bundle and then you changed it to a trunk link.


Is port-channel 5 now connected to dell switch working well ?


Hope to help

Giuseppe


prekursor Tue, 01/27/2009 - 09:17
User Badges:

yes channel 5 is working great. no problems


I also suspect incorrect command sequence, because none of the ports that belong to channel2 (non working channel) had problems trunking. (gi 1 - 5)

So now i tried to clear all the settings from Gi 1/1 - 5 and run no interface port-channel 2 command.


However when I recreated port channel again using the same ports. it is still having the same problem. I am wondering now if i have to reset somehow those ports or do something else to really remove port-channel 2 from the switch



prekursor Tue, 01/27/2009 - 13:04
User Badges:

i setup plain trunk between two cisco sw.

forget dell.

to do that I have used one of the ports that were bad.

Trunk still not working but i have some more info.

sw1 (good cisco switch no issues with trunking)


show platform hardware interface gigabitEthernet 1/1 statistic

Switch Phyport Gi1/1 Non-Zero Hardware Statistics

RxDot1qTaggedPackets : 1411705

TxDot1qTaggedPackets : 11150

RxIslTaggedPackets : 6

RxIpHeaderGoodPackets : 2049523

TxBytesQueue0 : 48424

TxBytesQueue1 : 890526

TxBytesQueue3 : 367961



Gigaport41(Gi1/1) Non-Zero Hardware Statistics

RxPackets64 : 54941

TxPackets64 : 347

RxPackets65to127 : 614705

TxPackets65to127 : 10537

RxPackets128to255 : 23110

TxPackets128to255 : 678

RxPackets256to511 : 342100

TxPackets256to511 : 332

RxPackets512to1023 : 194086

TxPackets512to1023 : 111

RxPackets1024to1518 : 1137677

TxPackets1024to1518 : 61

RxPackets1519to1548 : 2576

TxPackets1519to1548 : 100

RxMcastPackets : 528679

TxMcastPackets : 9561

RxUcastPackets : 6093

TxUcastPackets : 2585

RxBcastPackets : 1834423

TxBcastPackets : 20

RxGoodBytes : 1910203800



switch with broken trunking on one interface


show platform hardware interface gigabitEthernet 1/2 statistics

Switch Phyport Gi1/2 Non-Zero Hardware Statistics

TxDot1qTaggedPackets : 179119169

RxIslTaggedPackets : 152

RxIpHeaderGoodPackets : 3309518049

TxBytesQueue0 : 18323748

TxBytesQueue1 : 103671389

TxBytesQueue2 : 293

TxBytesQueue3 : 1003257000


Gigaport40(Gi1/2) Non-Zero Hardware Statistics

RxPackets64 : 2935954

TxPackets64 : 13764264

RxPackets65to127 : 2482336432

TxPackets65to127 : 4141905070

RxPackets128to255 : 175226843

TxPackets128to255 : 391477450

RxPackets256to511 : 276128267

TxPackets256to511 : 1976534223

RxPackets512to1023 : 158339447

TxPackets512to1023 : 1596983340

RxPackets1024to1518 : 216580464

TxPackets1024to1518 : 2545732621

TxPackets1519to1548 : 396214

RxMcastPackets : 265428

TxMcastPackets : 4020304

RxUcastPackets : 3311279034

TxUcastPackets : 1834793543

RxBcastPackets : 2945

TxBcastPackets : 238044743

RxOversizedPackets : 300

RxGoodBytes : 2586157299

RxErrorBytes : 456516


Notice that there is no stats for RxDot1qTaggedPackets here

unlike on sw1 that has both counters.

Also,second switch says RxOversizedPackets 300.

now when I ping a serveri(ping -M do -s 1469) in non native vlan that is connected to sw1

that counter is increasing.

So it looks like when this port receives full dot1q tagged frame it does not

know what to do with it and thinks that it is oversized.

It cannot recognize that this is tagged frame.




Actions

This Discussion