OSPF down due to too many retransmissions

Unanswered Question
Jan 27th, 2009
User Badges:
  • Bronze, 100 points or more

Hi All,


We have around 5 routers in a single LAN where we are running OSPF. The issue is one router we configured the MTU as 1546 bytes but the other routers are configured with 1500 bytes. Initially we had OSPF neighborship issues on the LAN and were getting the logs "OSPF down due to too many retranmissions".


While checking found that the MTU mismatch is the cause of this.


Option is either to configure the same MTU size on all the routers or to configure "ip ospf mtu-ignore". Since we were not able to configure the same MTU we went and configured "ip ospf mtu-ignore" on all the routers post which everything started working fine.


But still we are facing the OSPF neighborship issue couple of times and it comes up automatically. Still getting the same OSPF down due to too many retranmission:"


I would like to know the only solution for the above issue is to have the same MTU size on all the routers?


thanks

Arun Kumar

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
Giuseppe Larosa Tue, 01/27/2009 - 07:10
User Badges:
  • Super Silver, 17500 points or more
  • Hall of Fame,

    Founding Member

Hello Arun,

the best solution is to have the same ip mtu on all devices connected to the same LAN segment.


to be noted that at interface level you can:

increase the generic MTU with


mtu 1546


keep a standard 1500 byte mtu for IP with


ip mtu 1500


add other specific per protocol mtu commands for example for MPLS

mpls mtu 1542


another suggestion is to make the router with different settings DR other on the segment so that its activity is reduced to minimum.

For doing this you can apply


ip ospf priority 0


in interface configuration mode


Hope to help

Giuseppe


Actions

This Discussion