CUPC login fails

Answered Question
Jan 27th, 2009

CUPC 7.0(1.13056) client fails to download the firmware load from CUCM 7.0.1.21007-1. The latest device pack is installed (7.0.1.21014-1).

The CUPS version is 7.0.1.10000-28

The 'LDAP' and 'Logon Server' system status is green in the CUPC server health window, the rest of them are red or grey.

Extract from the CUPC client log:

2009-01-27 15:59:31,475 [0x000004c0] ERROR LCMiddleware - (MWMSG_CFGMGR_PARSEFAILED) TFTPConnectionImpl::connect() - Failed to download UPC712.cnf.xml

2009-01-27 15:59:31,475 [0x000004c0] DEBUG LCConnection - CALLMANAGER_TFTP reportResult(DISCONNECTED): reason=UNREACHABLE, functionality=NONE

Please advise anyone..

Cheers,

I have this problem too.
0 votes
Correct Answer by htluo about 7 years 10 months ago

If file not found, obviously you haven't configured your UPC device on CUCM yet.

Go to CUCM > Device > Phone. Add a new phone. Phone type: Cisco Unified Personal Communicator. Device name: UPC712.

Thanks!

Michael

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (2 ratings)
Loading.
therealstargazer Tue, 01/27/2009 - 10:05

tftp -i get UPC712.cnf.xml

the response is 'Error on server: File not found'...

There is a similar error when monitoring the TFTP service using RTMT, UPC712.cnf.xml is clearly missing on the CUCM.

The installed CUCM release is Engineering Special 7.0.1.21007-1, the latest release on CCO still seems to be 7.0.1.11001-8.

I might just open a TAC case as i dont have any good ideas left..

Correct Answer
htluo Tue, 01/27/2009 - 14:55

If file not found, obviously you haven't configured your UPC device on CUCM yet.

Go to CUCM > Device > Phone. Add a new phone. Phone type: Cisco Unified Personal Communicator. Device name: UPC712.

Thanks!

Michael

therealstargazer Wed, 01/28/2009 - 00:09

Thats it, thanks Michael! I did have a UPC configured but with a slightly different name. Nice blog by the way, just added it to my favourites..

Regards,

santiago_figuer... Thu, 08/02/2012 - 22:32

Hello Michael, I have an issue with CUPC 7, "login failed. Make sure your username and password are correct". I already run the troubleshooter diagnostic on CUPS and everything is green checked, also the CUCM Publisher Configuration and everything is successful and connected, green check too.

I have already reset the Tomcat service, actually the whole server but still got the same error.

I downloaed the logs from CUPC and found this:

2012-02-13 16:55:52,492 [0x000021e8] ERROR LCMiddleware - (MWMSG_EIM_SOAPLOGINFAILED) Failed to log in to SOAP server https://10.32.13.3/EPASSoap/service, The username/password entered is invalid.

2012-02-13 16:55:52,493 [0x000021e8] DEBUG LCConnection - CUPS_CONFIG setReason(): [REFUSED] --> [INVALID_CREDENTIALS]

My credetentials are fine, I already got login in CUPS user web page and CUCM user webpage.

I have downloaded the

Cisco UP Client Profile Agent" logs and "Cisco Tomcat Security" logs

but I can't find anything.

please any help ??

Presence  7.0.5.10000-18

CUCM  7.1.3.10000-11

Best Regards

Actions

This Discussion