WAN QoS

Unanswered Question
Jan 27th, 2009

We are using Class of Service with our MPLS VPN provider for voice/critical data. I would like to have our edge router configuration verified. I wasn't sure about marking on the egress interface (multilink1). Is this ok?


class-map match-any dscp26

match access-group 100

class-map match-any dscp46

match ip dscp ef

!

!

policy-map QoS

class dscp46

priority percent 35

class dscp26

bandwidth percent 25

set ip dscp af31

class class-default

fair-queue


interface Multilink1

bandwidth 3088

ip address 192.168.14.21 255.255.255.252

no ip redirects

no ip unreachables

no ip proxy-arp

ip accounting output-packets

ip flow ingress

load-interval 30

no cdp enable

ppp multilink

ppp multilink fragment disable

ppp multilink group 1

service-policy output QoS


access-list 100 permit ip host 192.168.32.55 host 172.18.1.156


  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
Mohamed Sobair Tue, 01/27/2009 - 10:48


You will need to have similar config for Class dscp46 be applied in class26. The Applied QoS policy on the Multilink should contain DSCP matches on both classes.


You will also need to contact the provider to see what kind Of QoS policies they apply? They are 3 different models of MPLS QoS:

a- Uniform Model b- short Pipe Model

c- Short model.


So, either they preserve ur QoS policy u already applied OR they could apply their Own QoS policy for You.


Hope it helps,

Mohamed

mikesparker Tue, 01/27/2009 - 11:11

Thanks Mohamed. Could you please show an example of what you mean by "similar config" for the classification? I have the provider's router config but I'm not sure what model they use:


interface Multilink110

ip vrf forwarding V6526:isigin

ip address 192.168.14.22 255.255.255.252

no ip directed-broadcast

no peer neighbor-route

no cdp enable

ppp multilink

no ppp multilink fragmentation

multilink-group 110

service-policy output ipcos-isigin-Q1B9



policy-map ipcos-isigin-Q1B9

class dscp46

priority

police rate percent 35

class dscp26

bandwidth percent 25



class-map match-any dscp46

match ip dscp 46



class-map match-any dscp26

match ip dscp 26


Mohamed Sobair Tue, 01/27/2009 - 11:27

Mike,


What I meant by similar config is the folowing:


In the Policy-Map Qos, u have class dscp26, u shouldnt set Dscp within this class, but u should match the DSCP which was already set Inbound direction. Ur last sample Config is correct, removing (Set ip dscp af31) from class dscp26 is desired.


On the Other hand, If a Service Provider uses Pipe Model, then ur QoS config wont be reserved, The Only Model that preserve ur config is (Short Pipe Model), thats why I mentioned 2 ask the SP whether they preserve ur QoS policy or Not.



HTH

Mohamed

Joseph W. Doherty Tue, 01/27/2009 - 17:29

I believe, you should be able to run the policy on multilink interface.


Some suggestions:


On most platforms, don't use FQ within class-default if you really need to guarantee class dscp26 a certain amount of bandwidth. (Use a bandwidth statement within class-default.)


You probably should mark the class-default as BE.

Actions

This Discussion