6.1.2 h323 outcalling on newer phones disconnects

Unanswered Question

II am running CCUCM 6.1.2.1002-1. I have a PRI on a h323 gateway(2821). The problem I am seeing is calls out from newer phones don't work(7941s,7921s,7970s). But calls out from classic phones (7960/7940s) work fine.

Getting error on gateway:

Cause i = 0x80AF - Resource unavailable, unspecified.

I tried 12.4.11XW9 and 12.4.22T and they both have the issue when used with 6.1.2.1002-1) not with 4.x versions of call manager.

I have found if I go to a mainline release like 12.4.23 or an older release like 12.3.?T it works fine for out calling. However I wanted the XW or 22T for inbound calling name support on PRI.


Has anyone else seen this or are having this problem?


  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
marina.kaminski Wed, 01/28/2009 - 05:27
User Badges:

The only reason i can see is the automatic usage of G722 codec by newer phones. Try to disable it in the enterprise parameters (advertise g722 codec -> disabled)

Wes Schochet Thu, 01/29/2009 - 08:07
User Badges:

Are you using the inbound or outbound fast start feature? I am not quite sure what that is, but I know that in my application, I had the same issue and it was resolved by using outbound fast start. In my case, the H.323 gateway is an Avaya Call Manager rather than an IOS device.


When you say the call disconnects, can you verify that any RTP stream is ever created. Again, in my case, the signaling was working fine, but the RTP never established.


Also, it seems that even though all parties on the call are using G711, the call also invokes a transcoding resource from CCM. I am in the process of trying to figure out what the niteractions are here.

Actions

This Discussion