Unity 7.0.2 ADSchemaSetup Fails on 64-Bit OS

Unanswered Question
Jan 27th, 2009
User Badges:

I'm installing Unity 7.0.2 and when running the ADSchemaSetup.exe on the Schema Master I recieve the error:


ADSchemaSetup can only be executed on a server running a supported 32-bit version of Windows.


The AD environment is Windows 2008 on 64-bit hardware w/64-bit OS.


Have any of you been able to get past this?

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (2 ratings)
Loading.
Frederick Nielsen Tue, 01/27/2009 - 14:00
User Badges:
  • Bronze, 100 points or more

The schema extension files are actually located on the CD under \Schema\LdifScripts


You can manually apply them against the schema master via the ldifde command. If you are unfamiliar with ldifde, do study up and be cautious.


You need to either manually replace the values within the LDF file(s) with the path appropriate for your AD, and/or use the -c option from the command line to accomplish this.


Let me know if you run into trouble or need clarification.

plwichert Tue, 01/27/2009 - 14:19
User Badges:

Thank you for the speedy response. TAC has advised of the following. Your ldifde command suggestion was spot on with thier findings. Not being that confident in my syntax abilities and the supportability of them we are opting to install a 32-bit OS and tranfer the schema master role to it for this procedure.


Thanks again..


*********************************************


CISCO BUG INFO


*********************************************

CSCsl48851 “ADSchemaSetup should give error message when run on 64bit Windows server

Symptom:

When running ADSchemaSetup on a 64bit server you get no error prompting that it will not work.

Workaround:

You need to run adschemasetup on a 32 bit server. It will not currently run on a 64 bit server.

Further Problem Description:

It should detect 64-bit Windows, display an error message that says what's wrong, and then exit gracefully.

CSCsk10833 “running schemasetup errors out”

Symptom:

Running ADschemaSetup.exe results in an error:

Event Type: Information

Event Source: Application Error

Event Category: (100)

Event ID: 1004

Date: 8/16/2007

Time: 8:29:16 AM

User: N/A

Computer:

Description:

Reporting queued error: faulting application ADSchemaSetup.exe, version

0.0.0.0, faulting module msvcrt.dll, version 7.0.3790.3959, fault address

0x00038e21.

Workaround:

Run schema extension scripts from the command line instead.

For example:

For all Unity systems:

The ldifde command line is: ldifde.exe -i -k -c "" "CN=Configuration,DC=achengdom,DC=ecsbu-lab-sea,DC=cisco,DC=com" -s "ACHENGDEV" -f "\Schema\LdifScripts\avdirmonex2k.ldf" -j "C:\Documents and Settings\Administrator.ACHENGDOM\Desktop\ldif logs\08162007_153115\avdirmonex2k"

If Unity system is using Unity Bridge also run:

The ldifde command line is: ldifde.exe -i -k -c "" "CN=Configuration,DC=achengdom,DC=ecsbu-lab-sea,DC=cisco,DC=com" -s "ACHENGDEV" -f "\Schema\LdifScripts\omnigateway.ldf" -j "C:\Documents and Settings\Administrator.ACHENGDOM\Desktop\ldif logs\08162007_153115\omnigateway"

If Unity system is using VPIM also run:

The ldifde command line is: ldifde.exe -i -k -c "" "CN=Configuration,DC=achengdom,DC=ecsbu-lab-sea,DC=cisco,DC=com" -s "ACHENGDEV" -f "\Schema\LdifScripts\vpimgateway.ldf" -j "C:\Documents and Settings\Administrator.ACHENGDOM\Desktop\ldif logs\08162007_153115\vpimgateway"

1) Replace "CN=Configuration,DC=achengdom,DC=ecsbu-lab-sea,DC=cisco,DC=com" with your target configuration container DN

2) Replace "ACHENGDEV" with your server name

3) Specify an applicable log file name after -j

Some users have had troubles generating a log file, and left out the -j and had it then run through fine.


ahochau_2 Thu, 02/12/2009 - 21:30
User Badges:

According to the bug information, this is fixed with version 7.0(.148), however the version of ADSchemaUpdate.exe that comes on the Disk 1 for Unity 7.02 seem to be 4.0(0) and the version that comes on the Unity 5 CD seems to be 5.0.0. That alone seems a bit backwards to me. Anyone know where the current version of this utility can be found?

ahochau_2 Thu, 02/12/2009 - 22:46
User Badges:

Just got off the phone with TAC, the "fix" is that the application now gives an error message. As I am sitting at a customer site trying to upgrade their unity to version 7 while their MS Server guys are whispering “We have Exhange 07 already, there is no need for unity” I'm having to make this call to TAC. It isn't like 64 bit OS can still be considdered new, I am disappointed that Cisco has not come up with a fix for this.


The suggested fix is to build a 32bit domain controller for running the AD setup.

steakandeggs Sat, 09/26/2009 - 00:23
User Badges:

Ran the ldifde manually. Worked great, the example made it very easy.

kgroves42 Tue, 07/06/2010 - 09:05
User Badges:

I ran into issues running the update manually. However what I did, which seemed to work is use the Schema update that comes on the Unity 8.0 DVD that will run on 64-bit OS. According to the Docs It is the same schema update as in Unity 5.x and 7.x. This might be posted somewhere else here but I could not find it. So I hope this helps someone.


Ken

Actions

This Discussion