Trunk Configuration on Layer2 2960

Unanswered Question
Jan 28th, 2009
User Badges:

Hello,


I have 3550 switch at HeadOffice and 2960 at branch office connected via Wireless link.


Vlans are not able to pass between them.


<< 3550 configuraiton >>

interface GigabitEthernet4/24

switchport trunk encapsulation dot1q

switchport mode trunk


<<2960 configuration >>

interface FastEthernet0/24

switchport mode trunk


There is no command as switchport trunk encapsulation on 2960..


VTP domain and VTP password are configured Correctly...


Cisco IOS Software, C2960 Software (C2960-LANBASE-M), Version 12.2(25)SEE2, RELEASE SOFTWARE (fc1)


I am able to ping between both the switches on loopback ip...


Any Help....


  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 4 (1 ratings)
Loading.
mahmoodmkl Wed, 01/28/2009 - 04:02
User Badges:
  • Gold, 750 points or more

Hi


I think the defautl encap on 2960 is dot1q thats why u r not able to see the command.


for test purpose create a test vlan to see if it makes the changes.


whats the status of the trunk ports.


Thanks

Mahmood

rohitrattan Wed, 01/28/2009 - 04:14
User Badges:

Hello Dear,


the reason you are able to ping the loopback ip is because the ping packets are sent untagged on the trunk i.e. they are sent using Vlan 1 or the native Vlan. Specify a non native vlan svi as the source in the ping and see if it passes. e.g. ping x.x.x.x source y.y.y.y.


You have configured trunk on the switches but are these switches directly connected... probably not and that's because you have some sort of a Wireless device between the switches that has to be at least layer 2 and essentially is the device you should be trunking with..But then i do not know if you can trunk with the wireless device but if the device is Layer 1 the configuration should work but again it is not working so i believe that you should investigate the issue from the wireless perspective.


change the interface mode to dynamic desirable and see if a trunk is negotiated, if the trunk is negotiated then i guess the wireless device is layer 1 and if the trunk is not negotiated then the device is at least layer 2 and that might be the problem.


switchport mode dynamic desirable


and check using


show interface gi4/24 switchport


check the "operational mode", the administrative mode should be "dynamic desirable"


Regards

Rohit

Amin Shaikh Wed, 01/28/2009 - 04:23
User Badges:

This is what I have .... on 2960


Name: Fa0/24

Switchport: Enabled

Administrative Mode: trunk

Operational Mode: trunk

Administrative Trunking Encapsulation: dot1q

Operational Trunking Encapsulation: dot1q

Negotiation of Trunking: On

Access Mode VLAN: 1 (default)

Trunking Native Mode VLAN: 1 (default)

Administrative Native VLAN tagging: enabled

hunnetvl01 Wed, 01/28/2009 - 04:28
User Badges:

And if you do nonegotiate on both links then


sh int trunk..what is the output?


Vlad

glen.grant Wed, 01/28/2009 - 04:30
User Badges:
  • Purple, 4500 points or more

Make sure the layer 2 vlan definitions are in both devices. Verify with a "show vlan" command . Your vlans should show active on both sides. The trunk config is ok but thats the trouble with forcing on a trunk it will say its trunking as long as you have a layer 1 connection even if its not working . As far as trying to pass it wirelessly can't help you , have never tried it and is not a common practice. What are the devices it is passing thru , did you check the wireless device docs for setup info on something like this ?

Amin Shaikh Wed, 01/28/2009 - 04:35
User Badges:

I created a temp-vlan at HQ to re-initiate the vlan flow.. but still no luck...


Wireless-link is acting as a bridge between two switches...




sh interfaces trunk


Port Mode Encapsulation Status Native vlan

Fa0/24 on 802.1q trunking 1


Port Vlans allowed on trunk

Fa0/24 1-4094


Port Vlans allowed and active in management domain

Fa0/24 1


Port Vlans in spanning tree forwarding state and not pruned

Fa0/24 1

Actions

This Discussion