OSPF configuration

Unanswered Question
Jan 28th, 2009
User Badges:

I have two routers connected by a serial cable. I have configured ospf but it's not working.


this is how I did it/;

conf t

router ospf

network 192.1.1.0 0.0.0.255 area 0


and on the other router exactly the same but different network number but the same area, my problem here is I cannot see the networks that i am advertising on the on the router and vice versa.


please help what could be a problem here?

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
mailaglady2 Wed, 01/28/2009 - 06:00
User Badges:

Do I need to do all these steps or one between them.


Please show me the first one lets say my serial ip's are 165.148.120.1/30 and .2/30 for router A and B respectively.

Joseph W. Doherty Wed, 01/28/2009 - 06:12
User Badges:
  • Super Bronze, 10000 points or more

The two routers need to share a link with OSPF. You write you're using a "different network number" on the other router. If you want to see other routes, those interfaces need to be known to OSPF.


Assuming the shared link is 192.1.1.0/24 and the first router has another interface such as 192.1.2.0/24 and the second router 192.1.3.0/24, config might look like:


first router:


router ospf

network 192.1.1.0 0.0.0.255 area 0

network 192.1.2.0 0.0.0.255 area 0


second router:


router ospf

network 192.1.1.0 0.0.0.255 area 0

network 192.1.3.0 0.0.0.255 area 0


mailaglady2 Wed, 01/28/2009 - 06:40
User Badges:

I have tried that but I still cant see these routes on my routing table.. when I do my "sh ip route" I can't see these routes. i can only see the directly connected ones.

netwalkr1 Wed, 01/28/2009 - 09:05
User Badges:

If both serial interfaces are configure in a point-to-point (PPP/HDLC) configuration make sure you have IP connectivity. I know this is basic but, without the configs posted I'm assuming worst case scenario. Once you verified connectivity, use the network statements 192.1.1.0 0.0.0.255 area 0 if that is the IP subnet of the serial interfaces. You may also want to configure loopback interfaces for the neighbor ID.


See this link for a step-by-step walkthrough.

http://www.cisco.com/en/US/tech/tk365/technologies_configuration_example09186a0080094057.shtml


HTH,

Shaun

zartar911 Wed, 01/28/2009 - 09:35
User Badges:

As what Shaun said, first make sure your layer 2 (port & line are up) & 3 (Ping the other IP address) are working.


After verifying that a sample OSPF configuration could be as follows:


ROUTER1


router ospf 1

network 192.1.1.0 0.0.0.255 area 0

network 165.148.120.0 0.0.0.252 area 0


ROUTER2


router ospf 1

network 192.1.2.0 0.0.0.255 area 0

network 165.148.120.0 0.0.0.252 area 0


One other thing to check is the ospf network types are the same.


Tim

mailaglady2 Thu, 01/29/2009 - 00:56
User Badges:

Thanks it worked, my problem was with the serial.


I had configured like this 165.148.120.0 0.0.0.0 area 0 instead of

165.148.120.0 0.0.0.3 area 0.


Thanks good people, you have been a great help.

netwalkr1 Thu, 01/29/2009 - 05:49
User Badges:

Your welcome! Please mark this thread as "solved" and don't forget to rate the responses.

Actions

This Discussion