1121's - do they roam properely or not? Please, help me out here

Unanswered Question
Jan 28th, 2009
User Badges:

Guys,


Been configuring, reconfiguring, trying everything that has been suggested for a month now.


Question: How can you configure 1121g's to roam properely? I can get them to work for data ( although still not roaming cleanly) but still miss a couple of pings from one to another. This is not acceptable for voice which is the intended purpose of these.

I have them setup with one acting as the Master AP and running radius on it also.

The rest can all be seen by the Master but will NOT authenticate with the Master. I have tried all that has been suggested here such as:

1. Starting over from scratch

2. Different types of encryption and checking, rechecking, and rechecking again that all keys and such match.

3. Checking signal strength (most were strong between each other - I eliminated this issue by going back to a lab setup with them 10 feet apart, 25 feet apart, 50 feet apart, no obstructions, etc.

4. Copying a config posted the other day, no change.

5. Have tried 3 different code versions

6. I have a box full of these AP's and as such have tried many different AP's, I don't think HW is an issue


I am at my witts end here and about to get my butt handed to me on a platter.


Does anyone have known good configs they can send to me? Hopefully all I would have to do is change the SSID's, IP's, and Passwords and be up and running.

I need FSR running I believe to get seemless voice roaming.


PLEASE HELP - THANK YOU

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
CFayNTAdmin83 Wed, 01/28/2009 - 09:18
User Badges:

Hi, I'm sorry to hear that your having roaming problems. From what I've noticed in the field, there are quite a few factors that can affect roaming.


1. Channel assignments - Use only 1,6, or 11 for the 2.4 Ghz range and make sure that adjacent AP's do not have the same channel. So for example you wouldn't want two AP's next to each other with the same channel.


2. AP location - The AP's need to see at least a few other AP's with decent signal strength. If the signal is too low or too high then the clients will not roam properly.


3. If using 802.1x / CCKM, the EAP Type that you use will also affect roaming.


4. The location of your radius server can also affect roaming.


5. The position of the antennas on your AP's can cause roaming problems. It looks like the 1121G's have internal antennas. I found from the 1100 series hardware installation guide that they should be mounted with the "grill mark" facing the floor. They're probably 180 degree omni's. The link below has a picture that you can refer to. Are your AP's mounted like the guide shows?


http://www.cisco.com/en/US/docs/wireless/access_point/1100/installation/guide/110h_c3.html#wpxref52654


6. QoS can also have an effect on roaming.


Do you have a config file from one of your AP's that I can look at?


How far apart are the AP's (roughly)?


Also, what power levels are you using?


Is the building multiple floors? or do you only have to cover one floor?


The majority of my AP's are the 1200 series. Before moving to LWAPP I used to run 12.3(8) JA2. That worked out very well for me. The download section recommends 12.3(8)JEB1 as a general deployment though. If you're having this problem across multiple IOS releases then I'm thinking that the problem is not related to the code you're running.



brasicot22 Wed, 01/28/2009 - 10:09
User Badges:

CFay,


Thank you.

To answer each:

I was originally using the default of use least congested. I then broke them up and where ever they were close I made sure they were using different channels. I was using all the channels, not just 1-6 and 11. No 2 like channels near each other.

2. They are spread out all over the building

3. Lost on this one - recommendation?

4. The radius box was on the Master AP in a central location to all other AP's

5. Most are point down - not all.

6. QOS - I was using two policies per SpectraLink: Incoming - Voice <10 ms Latency 6

and Outgoing - Voice <10 me Latency 6 applied according to their specs on the FE and Radio interface


Unfortunately I blew several of them away this morning and upgraded four ot them to the latest code: 12.3(8)-JEC2. I was going to start over again.


The config I will post on the next post (space issues) will show the last config I tried yesterday based on a config posted here - same issues. It worked great with data sitting at my desk but still did not roam.

* Various distances between but walking around, the signals were decent - 2 floors

* Yesterday they were apx. 40 feet apart with no obstructions.

* Power levels - I left default for a while then set them to throughput priority.

* Two floors

12.3(8)JA2 would not work at all for me.


Like I have said on other posts - I am at a loss here. At this point I have four AP's defaulted and upgraded to 12.3(8) JEC2 and hope I can get some good configs to load into them.


Your help is MUCH appreciated.

CFayNTAdmin83 Wed, 01/28/2009 - 10:52
User Badges:

OK, well from what you said in the reply there are a few things I can recommend that you can try in order to see if the roaming improves.


1. For 2.4 Ghz, 802.11b/g, it is very important that you only assign channels 1,6, or 11 on the AP's. Cells should be similar to the diagram below. Do not use the other channels like 2-5, 7-10, etc, as they will cause interference with each other, or possible roaming problems because the AP's cannot talk right.


11

|

6 - 1 - 6 - 1 - 11 - 1

|

11


For 3D, or multiple floors, this makes channel assignments a little trickier, but not impossible. For example see below.


Floor 1 has the following AP's...


11

|

6 - 1 - 6 - 1 - 11 - 1

|

11



So... a floor above it should have something like this, to account for the AP's below it.


1

|

11 - 6 - 11 - 6 - 1 - 6

|

1


Now of course this is just approximation, a site survey could prove to show different channels are better, but as a general rule of thumb 1-6-11 or 11-1-6 or 6-1-11 , etc. will work well for channel assignments.



Now, onto the other problem I noticed. If you're AP's are only 40 feet away from each other, then they will most likely NOT need to be a full power. If the power is turned up too high they will not roam correctly. For 50mW or 17dBm, I can roughly get about a 125-150 foot radius useable signal. That is not even at full power. At full power, 100mW, usually I can get 180ft radius out of an AP at 1MBPS. For only 40 feet, you'd want to use a way lower power level than the default. I would try setting the AP's to 12mW or lower if they're very close together like that and increase power one level up if you notice that the AP drops clients.


Once you have the 1,6, and 11 channel assignments in place and the power levels turned down let us know how the clients roam.


brasicot22 Wed, 01/28/2009 - 11:00
User Badges:

On it right now - thanks and I'll let you know what happens.

brasicot22 Mon, 02/02/2009 - 08:19
User Badges:

CFay - thank you.


On Thursday I shut down all but three of the AP's. At this point the layout is as follows:

Master AP - channel 11

AP1 - Channel 1

AP2 - Channel 6


I picked these three based on the distance factor, they are in a triangle apx 110 feet apart. They are all sharing the same switch for the FE links and can talk to each other vie this copper. The radios were tested using full strength and then stepped down in power. They still get the error "AP Timed out authenticating to the WDS"


This is from all boxes to include the Master - it does not seem to be able to authenticate to itself even.


Please advise and thank you.

CFayNTAdmin83 Mon, 02/02/2009 - 09:27
User Badges:

Ok, well I'm glad that you have the AP's on non overlapping channels. Also, at 110 ft away from each other the AP's should probably be around 50 mW. You could even try 25mw, but I'd use 50 mW first as a test. Also, I recommend that you redo your WDS config. Please use the link below for a guide that will help you with this.


http://www.cisco.com/en/US/products/hw/wireless/ps4570/products_configuration_example09186a00801c951f.shtml#step1


When doing the WDS config, make sure that your WDS username and password matches for all devices that use it.

After re-doing the WDS config,

I would check the menu where it says "WDS Information" on your master WDS AP and check to see what state your WDS devices are in. They should be "ACTIVE" and "registered".


If you get that far, then try a test with a laptop and see if roaming improves. If that works well then try a phone next...



Actions

This Discussion

 

 

Trending Topics: Other Wireless Mobility

client could not be authenticated
Network Analysis Module (NAM) Products
Cisco 6500 nam
reason 440 driver failure
Cisco password cracker
Cisco Wireless mode