Policing on a 6500 not working

Unanswered Question
Jan 28th, 2009


I have a Catalyst 6500 with PFC2 and MSFC2 running CatOS (Layer2) + IOS (Layer3). I need to configure a limit of 1Mbps on the bandwidth available for a specific VLAN so I tried to configure policing on the routing engine but it is not working.

I have tested it and checked the "show policy-map interface" command but statistics do not increase when there is normal traffic. It only increases a little bit when I access the router with a computer on the VLAN.

Anybody knows what could be the problem?

I am using the following configuration:

class-map match-all test

match access-group 111

policy-map 1mbps

class test

police 1000000 31250 31250 conform-action transmit exceed-action drop

interface Vlan200

service-policy input 1mbps

service-policy output 1mbps

access-list 111 permit ip any any



I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
fabianalfaro Wed, 01/28/2009 - 08:25

Thanks! I am going to try it that way as I just found out the following:

"On Catalyst 6500 Switches that run Hybrid OS, the configuration of rate-limit does not give the desired output."

"The reason behind this is that the MSFC takes care of only control functions, but actual traffic forwarding occurs on PFC ASICs on the supervisor. The MSFC compiles the FIB and adjacency tables, as well as other control information, and downloads it to PFC to implement in hardware. With the configuration you have created, you rate-limit only the software switched traffic, which should be minimal (or none)."



This Discussion