QoS on 3570

Unanswered Question
Jan 28th, 2009

Hello,

I have a 2960 switch that holds all voice connections in a location of the company.

This switch is connected to 3750 switch that is used for something like Core device.

There is an uplink from 2960 to 3750 Core. I want to configure QoS on the 3750 Core using Auto QoS. Can I do it in following fashion?

First, create an access list that matches all voice ports on 3750, then create a class map and match the access list in it. Then create a policy map and set DSCP to EF for the previously created class. Apply this policy map under the uplink port on 3750 (connection to the voice 2960 switch) in input direction. Then go to a Layer 3 interface on the 3750 (connected to remote office) and enable auto qos under it.

In this case will Auto QoS keep in consideration the DSCP values already set by the policy map or no?

If the procedure above is not correct please advice how to mark voice traffic with access list (or in another way) and to use Auto QoS? Thanks in advance guys!

rvr

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
chuckwirth Thu, 01/29/2009 - 14:41

If you have cisco phones, you don't have to do all that, just use autoqos on the 2960 and 3750.

Before using auto-qos CDP must be enabled on the phone interfaces.

This marks voice traffic EF and prioritizes the output queue on the interfaces attached to phones:

-if#auto qos voip cisco-phone

use:

-if#auto qos voip trust

on the trunk and remote office link. You should be using QoS on the other side too.

If you're not using cisco phones, then your method should work and auto qos will consider the dscp marking. If only phones (no workstations) are on the 2960, you could use the following commands on the 3750 trunk from the 2960. Both are needed to mark traffic.

if#mls qos cos 5

if#mls qos cos override

then use auto qos voip trust on the remote office link. This will mark everything coming from the 2960 with COS 5 and the 3750 will put it in a priority queue.

Use this command to verify everything is working:

#show mls qos interface gigabitethernet1/0/2 statistics

-if#auto qos voip {cisco-phone | cisco-softphone | trust}

http://www.cisco.com/en/US/docs/switches/lan/catalyst2960/software/release/12.2_25_see/command/reference/cli1.html#wp2737523

http://www.cisco.com/en/US/docs/switches/lan/catalyst3750/software/release/12.2_25_sed/command/reference/cli1.html#wp2737523

Actions

This Discussion