IP phones can't register on CME

Unanswered Question
Jan 28th, 2009
User Badges:

Hi,

I have CME version 4.1 on IOS 12.4(15)T8 & 7941 & 7911 ip phones.

I have 64 MB flash & 256 DRAM.

IP phones can't register & i got the following error:

CME error writing config file XMLDefault7961GE-1.cnf.xml -1/1151


CME error writing config file XMLDefault7961GE-2.cnf.xml -1/1224


CME error writing config file XMLDefault7941.cnf.xml -1/1059


CME error writing config file XMLDefault7941GE.cnf.xml -1/1059


CME error writing config file XMLDefault7931.cnf.xml -1/1047


CME error writing config file XMLDefault7911.cnf.xml -1/1047


CME error writing config file XMLDefault7906.cnf.xml -1/1047


CME error writing config file XMLDefault7985.cnf.xml -1/1047


CME error writing config file XMLDefault7912.cnf.xml -1/834


CME error writing config file XMLDefault7910.cnf.xml -1/515


CME error writing config file XMLDefault7935.cnf.xml -1/414


CME error writing config file XMLDefault7960.cnf.xml -1/929


CME error writing config file XMLDefault-1.cnf.xml -1/1033


CME error writing config file XMLDefault-2.cnf.xml -1/1106


ITS error writing config file XMLDefaultCIPC.c

Jan 28 18:49:53.115: Can't open file flash:/XMLDefault7961GE-1.cnf.xml

Jan 28 18:49:53.115: Can't open file flash:/XMLDefault7961GE-1.cnf.xml

Jan 28 18:49:53.119: Can't open file flash:/XMLDefault7961GE-2.cnf.xml

Jan 28 18:49:53.119: Can't open file flash:/XMLDefault7961GE-2.cnf.xml

Jan 28 18:49:53.119: Can't open file flash:/XMLDefault7941.cnf.xml

Jan 28 18:49:53.119: Can't open file flash:/XMLDefault7941.cnf.xml

Jan 28 18:49:53.119: Can't open file flash:/XMLDefault7941GE.cnf.xml

Jan 28 18:49:53.123: Can't open file flash:/XMLDefault7941GE.cnf.xml

Jan 28 18:49:53.123: Can't open file flash:/XMLDefault7931.cnf.xml

Jan 28 18:49:53.123: Can't open file flash:/XMLDefault7931.cnf.xml

Jan 28 18:49:53.123: Can't open file flash:/XMLDefault7911.cnf.xml

Jan 28 18:49:53.123: Can't open file flash:/XMLDefault7911.cnf.xml

Jan 28 18:49:53.123: Can't open file flash:/XMLDefault7906.cnf.xml

Jan 28 18:49:53.127: Can't open file flash:/XMLDefault7906.cnf.xml

Jan 28 18:49:53.127: Can't open file flash:/XMLDefault7985.cnf.xml

Jan 28 18:49:53.127: Can't open file flash:/XMLDefault7985.cnf.xml

Jan 28 18:49:53.127: Can't open file flash:/XMLDefault7912.cnf.xml

Jan 28 18:49:53.127: Can't open file flash:/XMLDefault7912.cnf.xml

Jan 28 18:49:53.127: Can't open file flash:/XMLDefault7910.cnf.xml

Jan 28 18:49:53.131: Can't open file flash:/XMLDefault7910.cnf.xml

Jan 28 18:49:53.131: Can't open file flash:/XMLDefault7935.cnf.xml

Jan 28 18:49:53.131: Can't open file flash:/XMLDefault7935.cnf.xml

Jan 28 18:49:53.131: Can't open file flash:/XMLDefault7960.cnf.xml

Jan 28 18:49:53.131: Can't open file flash:/XMLDefault7960.cnf.xml

Jan 28 18:49:53.131: Can't open file flash:/XMLDefault-1.cnf.xml

Jan 28 18:49:53.135: Can't open file flash:/XMLDefault-1.cnf.xml

Jan 28 18:49:53.135: Can't open file flash:/XMLDefault-2.cnf.xml

Jan 28 18:49:53.135: Can't open file flash:/XMLDefault-2.cnf.xml

Jan 28 18:49:53.135: Can't open file flash:/XMLDefaultCIPC.cnf.xml

Jan 28 18:49:53.135: Can't open file flash:/XMLDefaultCIPC.cnf.xmlnf.xml -1/1011


Any ideas????

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
youssef.ahmed Wed, 01/28/2009 - 21:07
User Badges:

outer(config-telephony)#do sh run

Building configuration...



Current configuration : 3723 bytes

!

! No configuration change since last restart

!

version 12.4

service timestamps debug datetime msec

service timestamps log datetime msec

no service password-encryption

!

hostname Router

!

boot-start-marker

boot system flash c2800nm-ipvoicek9-mz.124-15.T8.bin

boot-end-marker

!

!

no aaa new-model

clock timezone EG 2

dot11 syslog

!

!

ip cef

no ip dhcp use vrf connected

!

ip dhcp pool voice

network 192.168.200.0 255.255.255.0

option 150 ip 192.168.100.230

default-router 192.168.200.221

domain-name wr

!

!

multilink bundle-name authenticated

!

!

voice-card 0

dspfarm

dsp services dspfarm

!

!

!

voice service voip

allow-connections h323 to h323

allow-connections h323 to sip

allow-connections sip to h323

allow-connections sip to sip

!

!

!

!

!

!

!

!

!

!

!

!

!

!

!

!

!

archive

log config

hidekeys

!

!

!

!

!

!

interface FastEthernet0/0

no ip address

duplex auto

speed auto

!

interface FastEthernet0/0.2

encapsulation dot1Q 2

ip address 192.168.200.230 255.255.255.0

ip helper-address 192.168.100.230

!

interface FastEthernet0/0.3

encapsulation dot1Q 3

ip address 192.168.100.230 255.255.255.0

ip helper-address 192.168.100.230

!

interface Service-Engine0/0

ip unnumbered FastEthernet0/0.3

service-module ip address 192.168.100.231 255.255.255.0

service-module ip default-gateway 192.168.100.230

!

interface FastEthernet0/1

ip address 10.11.12.1 255.255.255.0

duplex auto

speed auto

!

ip forward-protocol nd

ip route 192.168.100.231 255.255.255.255 Service-Engine0/0

!

!

ip http server

no ip http secure-server

!

!

!

tftp-server flash:apps41.8-3-2-27.sbn

tftp-server flash:cnu41.8-3-2-27.sbn

tftp-server flash:cvm41sccp.8-3-2-27.sbn

tftp-server flash:dsp41.8-3-2-27.sbn

tftp-server flash:jar41sccp.8-3-2-27.sbn

tftp-server flash:SCCP41.8-3-3S.loads

tftp-server flash:term41.default.loads

tftp-server flash:apps41.8-2-2ES1.sbn

tftp-server flash:cnu41.8-2-2ES1.sbn

tftp-server flash:cvm41sccp.8-2-2ES1.sbn

tftp-server flash:dsp41.8-2-2ES1.sbn

tftp-server flash:jar41sccp.8-2-2ES1.sbn

tftp-server flash:SCCP41.8-2-2SR1S.loads

tftp-server flash:P00308000400.bin

tftp-server flash:P00308000400.loads

tftp-server flash:P00308000400.sb2

tftp-server flash:P00308000400.sbn

!

control-plane

!

!

!

voice-port 0/2/0

!

voice-port 0/2/1

!

!

!

sccp ccm 192.168.100.200 identifier 1

!

sccp ccm group 123

associate ccm 1 priority 1

associate profile 1 register mtp001bd4706a18

keepalive retries 5

switchover method immediate

switchback method immediate

switchback interval 5

!

dspfarm profile 1 transcode

codec g711ulaw

codec g711alaw

codec g729ar8

codec g729abr8

maximum sessions 6

associate application SCCP

shutdown

!

!

!

!

telephony-service

load 7941GE P00308000400.sbn

load 7941 P00308000400

max-ephones 3

max-dn 3

ip source-address 192.168.100.230 port 2000

auto assign 1 to 3

cnf-file location flash:

voicemail 3030

max-conferences 8 gain -6

transfer-system full-consult

create cnf-files version-stamp 7960 Jan 29 2009 07:59:33

!

!

ephone-dn 1 dual-line

number 4000

call-forward busy 3030

call-forward noan 3030 timeout 18

!

!

ephone-dn 2 dual-line

number 4001

call-forward busy 3030

call-forward noan 3030 timeout 18

!

!

ephone-dn 3 dual-line

number 4002

call-forward busy 3030

call-forward noan 3030 timeout 18

!

!

ephone 1

no multicast-moh

mac-address 001B.D4A0.7B65

type 7941GE

button 1:1

!

!

!

ephone 2

no multicast-moh

mac-address 001B.0C96.5FAF

type 7911

!

!

!

ephone 3

no multicast-moh

!

!

!

line con 0

line aux 0

line 194

no activation-character

no exec

transport preferred none

transport input all

transport output pad telnet rlogin lapb-ta mop udptn v120 ssh

line vty 0 4

login

!

scheduler allocate 20000 1000

ntp master

!

end


Router(config-telephony)#

Erick Bergquist Wed, 01/28/2009 - 23:59
User Badges:
  • Silver, 250 points or more

Try removing the command "cnf-file location flash:" under telephony-service. The default is store the config files in memory.


Do you have enough space free on the router flash, and is it inserted in the router all the way? Can you save the running config to the flash (see if new files can be saved, etc on the flash). Is there a write-protect switch on the flash you are using maybe?


youssef.ahmed Thu, 01/29/2009 - 03:18
User Badges:

I did the following:


1-erase flash

2-Uploaded flash:c2800nm-adventerprisek9-mz.124-11.XJ4.bin on the flash.

3-Uploaded CME files related to IOS.

4-Put alternate TFTP server,the same ip address of primary ip address,as work around,then save.

reloaded ip phones.


Finally the problem solved by the previous conf.


Thanks for your replies :)


Rrgards,

Ahmed Kamal

Nicholas Matthews Thu, 01/29/2009 - 06:10
User Badges:
  • Red, 2250 points or more

Hi Ahmed,


As suspected, it sounds like you have some flash problems. I would take some time and see if you're having problems and possibly reformat the compact flash.



hth,

nick

Actions

This Discussion