ISDN

Answered Question
Jan 28th, 2009
User Badges:

Hello,

A company has 2800 series router with NM-1CE1T1-PRI (1-port Channelized

E1/T1/ISDN-PRI ) card at HQ and 1800 series router with 2 cards WIC-1B-U-V2

(1-Port ISDN BRI NT-1-WIC) at remote sites.


They have 1 Mbps ISDN link at HQ and 128 kbps ISDN link at branch office.

I want to set up isdn config on the routers to inteconnect them.I have seen

some configs but i am not sure of what to choose.


1- Do I need another card or are these cards enough to set up isdn ?

2- Can you advise me on sample configs ?


Correct Answer by Giuseppe Larosa about 8 years 6 months ago

Hello Kouferidji,


to be able to handle multiple branch offices.


use a subnet /28 like

10.10.10.32/28


the HQ needs to use a dialer profile and not legacy ISDN


an example is:


controller E1 6/1

pri-group timeslots 1-31

!


interface Serial6/1:15

no ip address

encapsulation ppp

dialer rotary-group 5

isdn switch-type primary-net5

isdn incoming-voice data

isdn sending-complete

ppp multilink

no ppp multilink fragmentation

!



int dialer 5

ip address 10.10.10.33 255.255.255.240


encapsulation ppp

dialer pool 5

dialer-group 2

ppp multilink

ppp timeout multilink link add 1

no ppp multilink fragmentation

ppp authentication chap


! then you have multiple dialer map commands


dialer map ip 10.10.10.35 name pippo153 broadcast 6152

dialer map ip 10.10.10.36 name pippo154 broadcast 6154

...


dialer map ip 10.10.10.44 name pippo155 broadcast 6155

dialer map ip 10.10.10.45 name pippo156 broadcast 6156


dialer-list 2 permit ip



where name is the branch router name and you need to change the extension to your actual numbers


you need also a

username remote password remote-password for every branch


where again remote= branch router

on the branch router you need a mirror command

username hq-router-name password thesame_password


make the remote branch to call when needed.


Hope to help

Giuseppe


Correct Answer by ohassairi about 8 years 6 months ago

some working examples

http://hassairi.50megs.com/#configr


some changes may be necessary depending on your isp switch

Correct Answer by Giuseppe Larosa about 8 years 6 months ago

Hello Kouferidji,

your hardware is good but an ISDN provider wan cloud is needed in the middle.

you cannot connect them back to back in a lab setup.


you can use both B channels to connect to HQ.


For sample configurations you may refer to DDR examples.


see for example


http://www.cisco.com/en/US/tech/tk801/tk133/technologies_configuration_example09186a0080094cd6.shtml


I recommend to use ppp chap authentication and isdn caller screening


Hope to help

Giuseppe


  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (3 ratings)
Loading.
Correct Answer
Giuseppe Larosa Thu, 01/29/2009 - 01:35
User Badges:
  • Super Silver, 17500 points or more
  • Hall of Fame,

    Founding Member

Hello Kouferidji,

your hardware is good but an ISDN provider wan cloud is needed in the middle.

you cannot connect them back to back in a lab setup.


you can use both B channels to connect to HQ.


For sample configurations you may refer to DDR examples.


see for example


http://www.cisco.com/en/US/tech/tk801/tk133/technologies_configuration_example09186a0080094cd6.shtml


I recommend to use ppp chap authentication and isdn caller screening


Hope to help

Giuseppe


kolawole1 Thu, 01/29/2009 - 05:00
User Badges:

Thanks for the reply


When connnecting remote sites via pri,this command is linking 2 remotes sites with the same interface.I thought we should use different interfaces.

interface Serial 1/0:15

no shutdown

description connected to Cisco801_1,Cisco801_2

no ip address

encapsulation ppp

dialer pool-member 2

dialer pool-member 1



kolawole1 Thu, 01/29/2009 - 05:32
User Badges:

Thank you for the reply.In my case i am having one primary rate interface card in HQ with 2mbps link and the wan cloud is there already.


Your config applies for bri interface, what about PRI interface like NM-1CE1T1-PRI ?

I am HAVING SEVERAL branch offices how do i do this?

kolawole1 Thu, 01/29/2009 - 08:58
User Badges:

I have read that chanelized E1 cards like NM-1CE1T1-PRI have no built in D channels.Signaling is done inband


Can this card be used for ISDN PRI connection in a central site where the company has several branch offices having WIC-1B-U-V2 card ?

Correct Answer
Giuseppe Larosa Thu, 01/29/2009 - 09:45
User Badges:
  • Super Silver, 17500 points or more
  • Hall of Fame,

    Founding Member

Hello Kouferidji,


to be able to handle multiple branch offices.


use a subnet /28 like

10.10.10.32/28


the HQ needs to use a dialer profile and not legacy ISDN


an example is:


controller E1 6/1

pri-group timeslots 1-31

!


interface Serial6/1:15

no ip address

encapsulation ppp

dialer rotary-group 5

isdn switch-type primary-net5

isdn incoming-voice data

isdn sending-complete

ppp multilink

no ppp multilink fragmentation

!



int dialer 5

ip address 10.10.10.33 255.255.255.240


encapsulation ppp

dialer pool 5

dialer-group 2

ppp multilink

ppp timeout multilink link add 1

no ppp multilink fragmentation

ppp authentication chap


! then you have multiple dialer map commands


dialer map ip 10.10.10.35 name pippo153 broadcast 6152

dialer map ip 10.10.10.36 name pippo154 broadcast 6154

...


dialer map ip 10.10.10.44 name pippo155 broadcast 6155

dialer map ip 10.10.10.45 name pippo156 broadcast 6156


dialer-list 2 permit ip



where name is the branch router name and you need to change the extension to your actual numbers


you need also a

username remote password remote-password for every branch


where again remote= branch router

on the branch router you need a mirror command

username hq-router-name password thesame_password


make the remote branch to call when needed.


Hope to help

Giuseppe


Actions

This Discussion