2960 Portchannel failure

Unanswered Question
Jan 29th, 2009
User Badges:

Has anyone seen any issue with the 2960's where a member of the portchannel fails, causing the whole Portchannel to fail? We had a situation where both our uplinks failed. They were the only ports to go out, and they are both members of the same portchannel. The uplink switch just reported link and line proto down.. Upon a reboot, 1 of the interfaces can back up, the other stays in shutdown. I have seen this happen before, but not sure why both uplinks fail.


Model number WS-C2960-48TT-L


Version 12.2(25)SEE4

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
owillins Wed, 02/04/2009 - 14:18
User Badges:
  • Silver, 250 points or more

Begin troubleshooting Portchannel and trunking issues by verifying that you have completed following actions first:

• Use the show port-channel compatibility-parameters CLI command to determine PortChannel requirements.

• Ensure that one PortChannel is not connected to different sets of switches. PortChannels require point-to-point connections between the same set of switches.

• Verify that either side of a PortChannel is connected to the same number of interfaces.

• Verify that each interface is connected to the same type of interface on the other side.

• Verify that all required VSANS on a TE port are in the allowed-active VSAN list.


The following commands may be useful in troubleshooting PortChannel and trunking:

• show port-channel compatibility-parameters

• show port-channel summary

• show port-channel database

• show port-channel consistency detail


Leo Laohoo Wed, 02/04/2009 - 19:20
User Badges:
  • Super Gold, 25000 points or more
  • Hall of Fame,

    The Hall of Fame designation is a lifetime achievement award based on significant overall achievements in the community. 

  • Cisco Designated VIP,

    2017 LAN, Wireless

Can you post the config?

jbeltrame Thu, 02/05/2009 - 05:56
User Badges:

Here is the config. It has run fine for 1.5 years, and all of a sudden both uplinks failed. Reboot brought one uplink back, 2nd stays in permanent shutdown:


interface Port-channel1

description Po41

switchport trunk allowed vlan 1,115,116

switchport mode trunk

load-interval 30

spanning-tree bpdufilter enable


interface GigabitEthernet0/1

description Fa1/0/41

switchport trunk allowed vlan 1,115,116

switchport mode trunk

load-interval 30

channel-group 1 mode passive

spanning-tree bpdufilter enable


interface GigabitEthernet0/2

description Fa2/0/41

switchport trunk allowed vlan 1,115,116

switchport mode trunk

load-interval 30

channel-group 1 mode passive

spanning-tree bpdufilter enable

glen.grant Thu, 02/05/2009 - 06:04
User Badges:
  • Purple, 4500 points or more

How is the other end configured ?

jbeltrame Thu, 02/05/2009 - 06:18
User Badges:

interface Port-channel41

description Po1

switchport trunk encapsulation dot1q

switchport trunk allowed vlan 1,115,116

switchport mode trunk

load-interval 30

spanning-tree bpduguard enable

spanning-tree link-type point-to-point

spanning-tree guard root

end


interface FastEthernet1/0/41

description Gi0/1

switchport trunk encapsulation dot1q

switchport trunk allowed vlan 1,115,116

switchport mode trunk

load-interval 30

channel-group 41 mode active

spanning-tree bpduguard enable

spanning-tree link-type point-to-point

spanning-tree guard root

end


interface FastEthernet2/0/41

description Gi0/2

switchport trunk encapsulation dot1q

switchport trunk allowed vlan 1,115,116

switchport mode trunk

load-interval 30

channel-group 41 mode active

spanning-tree bpduguard enable

spanning-tree link-type point-to-point

spanning-tree guard root

end

Mohamed Sobair Thu, 02/05/2009 - 06:07
User Badges:
  • Gold, 750 points or more

Hi,


What is the objective of configuring (spanning-tree bpdu filter enable) on the port channel and member ports??


Etherchannel provides redundancy and loadbalancing scheme but in One condition:

When Spanning-tree Instance treat both physical ports as Single Logicl Interface.


Configuring (BPDU filter enable), will preven BPDUs to be recieved by particular port, thus eleminating Spanning-tree functionality. Basically Disabling Spanning-tree on those Ports.


HTH

Mohamed

Actions

This Discussion