Unity - COBRAS Export Failure -DOH failed for message extraction

Unanswered Question
Jan 29th, 2009
User Badges:

Tried logging in as UnityInstall/UnityAdmin, and UnitySVC which have access to the Domain and still getting this error (also tried logging in as local Administrator.:


1/29/2009 9:45:20 AM: Attaching to DOH to check for rights to export messages from Unity

1/29/2009 9:45:20 AM: (error) attaching to DOH message store -2147221492 (Method '~' of object '~' failed) in procedure InitMessageExport of Module modMessages

1/29/2009 9:45:20 AM: (error) failed to log into DOH for message extraction

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
lindborg Thu, 01/29/2009 - 07:47
User Badges:
  • Cisco Employee,

The unity install account is not the right account - whatever account is associated with AvCsMgr is the one you need to log into - domain access means nothing here. It needs to be able to bind to the service directly.

e.giron Thu, 01/29/2009 - 07:50
User Badges:

OK,


AVCSMgr Properties for Local Computer has :

This account: COXNEWS\UnitySVC - which is what I am logged in as, and its still giving me the error

Bradford Magnani Thu, 01/29/2009 - 07:55
User Badges:
  • Cisco Employee,

Jeff,


Sounds like they may be integrated with Domino if he has "unitysvc". Are you running Domino as the message store Edilsa? There are certain requirements for the COBRAS Domino Export according to the help file.


Brad

lindborg Thu, 01/29/2009 - 07:58
User Badges:
  • Cisco Employee,

ah... I was assuming Exchange...

e.giron Thu, 01/29/2009 - 07:59
User Badges:

Yes you would be correct about integration with Domino! Is it terribly difficult to figure out?

lindborg Thu, 01/29/2009 - 08:05
User Badges:
  • Cisco Employee,

well, lets start from the begining.


Unity version?

Config?

COBRAS Export version?

e.giron Thu, 01/29/2009 - 08:55
User Badges:

Cisco Unity 4.0.5 -

Integrated with Domino v.6.5

COBRAS Export version -7.0 Build 45

lindborg Thu, 01/29/2009 - 10:57
User Badges:
  • Cisco Employee,

Double checked, ran some tests and talked with a few QA folks that tested this against Domino installs and everyone agrees that logging in as the same account assigned to the AvCsMgr service should work (I don't have a 4.0(5) Domino install but I did check it this morning against a 5.0 and 7.0 install).


The only other thing that I can think to check is to make sure the "wedge" DLL (used to bridge the connection to the running service with Domino) is installed and registered properly. Look in the install directory for COBRAS and you should see a file called "ggotdohsvr.dll" - run regsvr32 against it to be sure it's COM interfaces are registered properly and then try it again (assuming you are logged in locally on the system with the AvCsMgr service account).

e.giron Thu, 01/29/2009 - 11:19
User Badges:

OK, will check these settings, see if it runs..

e.giron Thu, 01/29/2009 - 12:09
User Badges:

ran the regsvr32 /u and /iagaints the ggotdohsvr.dll and it said:

"ggotdohsrv.dll was loaded, but the DllInstall entry point was not found. DllInstall may not be exported, or a corrupt version of ggotdohsrv.dll maybe in memory. Consider using Pview to remove it.?"


Not sure what that means. I made sure all the services that UnitySVC was responsible for were running and now I'm re-installing COBRAS

lindborg Thu, 01/29/2009 - 12:31
User Badges:
  • Cisco Employee,

well... that would certainly explain a few things. Maybe the DLL in the install package is damaged? Longshot but you never know...


by the way, are you running this on the local console or via VPN/remote desktop? I've seen WAV related utilities get tripped up via remote interfaces.

e.giron Thu, 01/29/2009 - 12:40
User Badges:

hmm yes I am using Remote Desktop, I will re-download a clean version of Cobras Export, and use VNC instead.

lindborg Thu, 01/29/2009 - 14:01
User Badges:
  • Cisco Employee,

VNC has the same issue - in fact on some of my tools I check to see if you're not on the local desktop and bail (I should probably do that here as well but I haven't ported the code over for it). Anything that does WAV handling (i.e. message extraction) can get hosed when running remotely... if you can, run it from the local box.

lindborg Fri, 09/10/2010 - 07:58
User Badges:
  • Cisco Employee,

this was from quite some time ago (Jan/2009) - I can't recall specifically but there's been lots and lots of Domino exports since then as folks are moving to Connection.


The recommendation is to always run the export logged in locally - I suspect that was the source of the issue here since we didn't hear back after that.

Actions

This Discussion