how to create a route-map policy that will route a particular subnet

Answered Question
Jan 29th, 2009
User Badges:

I am having trouble routing one particular subnet. I have no experience in policy-based routing so I'm asking the gurus.


I have 5 cities:

A = 10.110.0.0

B = 10.120.0.0

C = 10.130.0.0

D = 10.140.0.0

E = 10.150.0.0


How do i create some sort of policy-based route that says:


10.A.2.0, 10.B.2.0, 10.C.2.0, 10.D.2.0and 10.E.2.0 to send to one particular router?


At the same time, leave all other routing in place.


Thanks!



Or something else.


How do you stop a particular router from advertising a particular route via EIGRP?


If i could make one router no advertise 10.120.2.0, 10.130.2.0, 10.140.2.0, and 10.150.2.0, from a particular interface, I think it would accomplish this problem also.

Correct Answer by Tshi M about 8 years 5 months ago

I would permit the desired subnets and use a deny at the end of the statement


ip access-list standard PERMIT-SUBNETS-OUT

remark allowed SUBNETS

permit x.x.x.0 0.0.0.255

permit y.y.y.0 0.0.0.255

deny any


router eigrp 10

network z.z.z.0 0.0.0.3

passive-interface default

distribute-list PERMIT-SUBNETS-OUT out int fa0/0.2

no auto-summary


regards,

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (1 ratings)
Loading.
Tshi M Thu, 01/29/2009 - 10:46
User Badges:
  • Silver, 250 points or more

you could use acl

ip access-list stand 99

permit ip 10.A.2.0 0.0.0.255 any

permit ip 10.B.2.0 0.0.0.255 any

...

...

...


route-map permit_subnets permit 10

match ip address 99

set ip next-hop x.x.x.x



For the EIGRP you could use redistribute ACL.


Regards,

the_crooked_toe Thu, 01/29/2009 - 10:50
User Badges:

ok i'm thinking out of the box again.


Forget the first question all together.


How would I be able to stop the router from advertising 10.A.2.0, 10.B.2.0, 10.C.2.0, 10.D.2.0, and 10.E.2.0 from being advertised via EIGRP through one particular interface. While allowing all other routes be advertised through that interface?

Tshi M Thu, 01/29/2009 - 10:55
User Badges:
  • Silver, 250 points or more

use distribute-list on your eigrp process. you create an ACL that permit the desired subnets and denied the others. you then use distribute-list acl out int x


regards

the_crooked_toe Thu, 01/29/2009 - 11:01
User Badges:

access-list 99 deny 10.120.2.0

access-list 99 deny 10.130.2.0

access-list 99 deny 10.140.2.0

access-list 99 deny 10.150.2.0

access-list 99 permit any


router eigrp 101

distribute-list 99 out Fa0/0.2


would this work?

Is the acl 99 permit any necessary?

Correct Answer
Tshi M Thu, 01/29/2009 - 11:04
User Badges:
  • Silver, 250 points or more

I would permit the desired subnets and use a deny at the end of the statement


ip access-list standard PERMIT-SUBNETS-OUT

remark allowed SUBNETS

permit x.x.x.0 0.0.0.255

permit y.y.y.0 0.0.0.255

deny any


router eigrp 10

network z.z.z.0 0.0.0.3

passive-interface default

distribute-list PERMIT-SUBNETS-OUT out int fa0/0.2

no auto-summary


regards,

the_crooked_toe Thu, 01/29/2009 - 11:18
User Badges:

thanks. this worked. I went the other way by denying the networks, then permitting the rest. Granted, I know with your config there is a lot more control of what is routed, but mine doesn't need all that maintenance.


Thanks again!

Actions

This Discussion