CUPS ->Exchange calendar NTLM authentication

Unanswered Question
Jan 30th, 2009


I'd like to integrate my presence with outlook calendar, but I'm not able to authenticate to an exchange server. I'm getting the error message:

Authentication failure on server; Could not authenticate to server: ignored NTLM challenge, ignoring empty Negotiate continuation Cluster ID:StandAloneCluster Node ID:presence.

We use CUPS 6.0.4 and Exchange 2003. My exchange account is OK and NTLM is turned on on exchange server.

Can anyone help me to solve this issue?



I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
htluo Fri, 01/30/2009 - 06:04

The messages in CUPS log are generic.

If you got an authentication issue, it could be:

1) You didn't configure the account in presence gateway in the right format. Depends on your Exchange configuration, you might want to try "domain\account" instead of "account".

2) The account does not have permission to open end user's mailbox.

The best way to test is to put an end user account into presence gateway configuration. Because an end user account is 100% sure have permission to open his own mailbox. If you still got "unauthorized" message, that must be the account format problem.

For more troubleshooting tips, see:

and my blog:

If still no luck, open a case between 12:45pm and 3:45pm and ask for Michael Luo.



kamil.bockay Mon, 02/02/2009 - 01:39


Thanks for your messahe. It helped. I tried to use my own account and it was ok. After that I have re-checked the "recieve as" account. It was set on only one storage group. Anyway, I'd like to ask 2 things:

1. The permission level. "Receive as" seems to be a strong permission. I can see the whole mailbox of users with it. Is there any way to set it lower and still be able to read the calendar?

2. Folder names. We use 6.0.4 version of CUPS. It should work also with non-english calendar folder names. But it is not. what needs to be done to solve this issue?


Kamil Bockay

htluo Mon, 02/02/2009 - 08:02

1. In order for this integration to work, the service account needs to read everybody's mailbox. This is a strong permission already. That's the reason we require SSL to protect the communication.

2. For non-English, there's a BUG ID CSCsj76758. Unfortunately, the fix is only integrated into CUPS 7.x.



This Discussion