Catalyst 2948 SNMP

Unanswered Question
Jan 30th, 2009

Dear all, I spent almost a day in searching for the correct way to set up SNMP in cisco, but all I can find is setting the community for a traps receiver, which results that I can not send requests.

May I ask if any one can help me, so I can snmpwalk to the cisco router please?

I thank you all with all my heart.



I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
glen.grant Fri, 01/30/2009 - 06:36

Its no different than other devices just snmpwalk -c community string . This is on a unix box to a cisco catos device.

MrCheHMqm Fri, 01/30/2009 - 06:56

hmm, I'm sorry for not being totally clear. I know how the snmpwalk works. but the problem is, if I snmpwalk the cisco switch, I get no response, although the snmp is enabled.

The reason is that I have no read access to the snmp, because I have tried to use IP permit to give myself access.

so I searched the internet for help to update the snmp access list, like in an snmpd.conf on a net-snmp host, so that another machine has access to it.

conclusion is that I don't know how to do it in CatOS I guess, because a lot cli lines I have found started with "snmp-server" those do not work on this switch.

I need something like set snmp access or something, just so I can do an snmpwalk from a host to the switch :)

Thx in advance.



MrCheHMqm Fri, 01/30/2009 - 07:26

done that one also. I have tried the "set snmp access" also by now, still doesn't work.

Perhaps I will have to reformulate my entire question to how do I set up snmp on a cisco, so that another host can snmpwalk to it (skipping the part of set snmp enable :p )

thx in advance



glen.grant Fri, 01/30/2009 - 08:24

If you currently have "no" permit list configured and you a a valid configured read or RW string then there should be no restrictions on accessing the snmp data with a snmpwalk. Otherwise you may have to post config so that we can see whats in there.

MrCheHMqm Fri, 01/30/2009 - 09:10

This is the result from show snmp

ip permit is also set.

SNMP: Enabled

RMON: Disabled

Extended RMON Netflow: Disabled

Memory usage limit for new RMON entries: 85 percent

EngineId: some ID

Chassis Alias:

Traps Enabled: None

Port Traps Enabled: None

Community-Access Community-String

---------------- --------------------

read-only somecommunity

read-write anothercommunity

read-write-all thebestcommunity

Additional- Access-

Community-String Access-Type Number View

-------------------- -------------- ------- -----------------------------------

Trap-Rec-Address Trap-Rec-Community Trap-Rec-Port Trap-Rec-Owner Trap-Rec-Index

---------------- ------------------ ------------- -------------- --------------

someIP somecommunity somePort CLI 1


This Discussion