Web Auth page not working on WLC

Unanswered Question
Jan 30th, 2009

I have a WLC 4402 and I upgraded the s/w from 4.1 to 4.2.176 since I did the web auth on my Guest wlan does not work. I can connect to the wireless ok and when I type in a web address I should get the web auth page but I just get "This page cannot be displayed". However if i type in the ip address of the WLC in the addrsss bar I get the web auth page and it work fine form then on. The web auth page worked fine on ver 4.1. Any ideas?

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
mark.cronin Fri, 01/30/2009 - 07:10

Does your wireless client get a DNS server address from the DHCP scope?

Can you use nslookup to check that you can resolve your web home page?

Scott Fella Fri, 01/30/2009 - 07:33

If this was working prior to your upgrade, then disable webauth and hit apply and then enable webauth again and hit apply and see if that fixes your issue. If not, verify that the webauth page is still in the wlc or just tftp the webauth page back in.

apishko Fri, 01/30/2009 - 07:53

I ran into this as well. There is a bug with the 4.2.176 version of code. It is referenced in CSCsv77075. The issue has to do with https. After the upgrade you cannot connect to the wlc mangagment ip address via https. The workaround was either to enable http or downgrade to 4.2.130. The http workaround works fine for managment access however, the URL redirection presented by the controller for guest authentication is also https, so the bug affects displaying that page as well. I downgraded my controller to 4.2.130 and that resolved the issue. Supposedly if you then upgrade back to 4.2.176.0 that resolves the bug, however I haven't had an opportunity to upgrade again.

Hope this helps.

Alex

hogant Mon, 02/02/2009 - 08:05

We required only SSL.

One more trick, If you allow SSH:

On the WLC command line enter the following:

>config network secureweb cipher-option sslv2 enable

you will then have to reboot, but https should now work, and you can disable http.

wesleyterry Mon, 02/02/2009 - 15:51

I opened a TAC case this morning on this same problem, and my solution is what is listed above (config network secureweb cipher-option sslv2 enable)

Basically, SSLv2 is disabled in 4.2. The Default is now SSLv3.

Depending on your Internet settings, if IE is configured to use SSLv2, the webpage will not work.

So in internet explorer, tools, internet options, advanced, There will be a checkbox next to Use SSLv2. (Even if Use SSLv3 is enabled, you still have the https issue).

Basically, my issues was that a select few users could not Web authenticate and a select few admins couldn't HTTPS manage the GUI. Turns out in all cases, the computers that were all able to work, did not have SSLv2 enabled.

By enabling SSLv2, all affected users now work (I think).

p21 Tue, 02/03/2009 - 03:12

This may be the answer, Some clients connect fine and soem do not, I will check the SSL setting on IE

Thanks

Actions

This Discussion

 

 

Trending Topics: Other Wireless Mobility

client could not be authenticated
Network Analysis Module (NAM) Products
Cisco 6500 nam
reason 440 driver failure
Cisco password cracker
Cisco Wireless mode