pppoe dsl

Unanswered Question

can anyone guide me? I have 2801 with integrated hwic 9 poe and 79xx phones,

can i bridge my (dynamic) dsl modem into router and access internet through switch port on 79xx phone? I can find no info on step by step in this or any forum.I have seen all the configs for pppoe on router ports 0 and 1, but no discussion of vlan on phone switchport.

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Paolo Bevilacqua Fri, 01/30/2009 - 13:23

Hi, preferably you will configure pppoe on the either lan 0 or 2, although it's possible to do that on a single vlan for the hwic ports. Why is that you want do that ?

I want to be able to use one any of my eight phones as connection to the internet( already wired and working phones) I tried the sample configs I found on the cisco site but couldn't get them to work. They all discuss pure router not one with integrated switch. I am not knowledgeable enough to know if it will work in my situation.

Paolo Bevilacqua Fri, 01/30/2009 - 14:42

Do you mean you need to connect the dsl router to the PC port of a phone ?

If you dedicate a vlan to it, then yes it should be doable, but it really would be better if you can connect the DSL modem to LAN 0 or 1 of the router directly.

I can't explain properly. Need to connect dsl to router fa/0/0 and plug pc into 7960 phone and access internet from dsl modem. I keep reading about svi for hwic ports and pppoe but can't find a step by step for this procedure.

And again not knowledgeable enough to even ask the proper question. I have asked local data guys this question and offered to pay them for successful implementation and they can't do it.

Paolo Bevilacqua Fri, 01/30/2009 - 14:58

Well, about that I told you before that yes it shold be possible and you would just dedicate a new vlan to a port, and configure pppoe client on it.

My next question was why you can't do that on either LAN 0 or LAN 1 to which you never answered.

Let me try another question. Has anyone out there ever succesfully used a working 2801 (ccme)( no current data use) with hwic 9  integrated switch  supporting 8 -79xx phones and added to the config to enable a bridged dynamic dsl modem into the router (RJ45 to FA0/0) r and have access to that same dsl from the 79xx  data  port (FA 0/0/0-7). I would like to see some config steps on this only. Phones and FXO's are working fine. This is a home use router for me to try to learn on and I am not a professional data person so I may be missing something obvious to others.

Paolo Bevilacqua Fri, 01/30/2009 - 16:57

Hi, FA0/0 is one of the router two embedded ports. It is where you normally would connect an ADSL modem.

The ports on hwic are then controlled by the setting under the corresponding vlan, eg vlan1. These are best used for phones and/or PCs.

This is how configure pppoe client on ethernet:


Note you do not need any of the VPDN config mentioned in the above doc.


Thanks for your patience! That is the config I tried, my confusion lies around the missing reference to hwic vllan ports (that's what I can't find or understand. My system has

interface FastEthernet0/3/0

 switchport trunk native vlan 200

 switchport mode trunk

 switchport voice vlan 100

 spanning-tree portfast

interface Vlan200

 ip address

(address I was playing with)

I don't know what is next. I keep searching for a sample in this website and can't find it here or elsewhere, surely someone uses this setup. I am over my head , thanks anyway .

Giuseppe Larosa Sat, 01/31/2009 - 00:28

Hello Robert,

let's follow the document provided by Paolo, you need to think of your 2801 as the 2611 in the picture.

so if fas0/1 is the "WAN" interface you want to use to connect to the DSL modem you need

int f0/1

no ip address

pppoe enable

pppoe-client dial-pool-number 1

a logical L3 interface is then added to handle PPP negotiation

interface Dialer1 
ip address negotiated
ip nat outside
ip mtu 1492
encapsulation ppp
no ip mroute-cache
dialer pool 1
dialer-group 1
ppp authentication pap
ppp pap sent-username cisco password cisco1

you need to adapt to your needs .

! NAT is needed and performs address translation

int vlan 200

ip nat inside

dialer-list 1 protocol ip permit 
ip nat inside source list 1 interface Dialer1 overload
ip route dialer1

access-list 1 permit

This should work


these new edit controls are not working well just focus on IOS commands and skip everything else

Hope to help




Paolo Bevilacqua Sat, 01/31/2009 - 04:07


For my curiosity, can you tell me why you can't use one fo the two embedded LAN ports to connect the DSL modem ?

Often is better to begin with the simpler things, then move to more complciated ones.


This Discussion