RPR-Plus- 7507 not working correctly

Unanswered Question
Jan 30th, 2009
User Badges:

I have a 7507 with 2 RSP4+s (that are identical with identical software)- they are configure to run in RPR-plus mode. The slave is not coming up- I get the following in the show redundancy command:


Redundant System Information :

------------------------------

Available system uptime = 3 minutes, 3 seconds

Switchovers system experienced = 0

Standby failures = 0

Last switchover reason = none


Hardware Mode = Duplex

Configured Redundancy Mode = rpr-plus

Operating Redundancy Mode = hsa

Maintenance Mode = Disabled

Communications = Down Reason: Simplex mode


Current Processor Information :

-------------------------------

Active Location = slot 2

Current Software state = ACTIVE

Uptime in current state = 1 minute, 34 seconds

Image Version = Cisco Internetwork Operating System Software

IOS (tm) RSP Software (RSP-PV-M), Version 12.0(32)S12, RELEASE SOFTWARE (fc1)

Technical Support: http://www.cisco.com/techsupport

Copyright (c) 1986-2008 by cisco Systems, Inc.

Compiled Mon 22-Dec-08 13:28 by leccese

BOOT =

Configuration register = 0x2102


Peer (slot: 3) information is not available because it is in 'DISABLED' state


Here is the sh ver off the router:


Cisco Internetwork Operating System Software

IOS (tm) RSP Software (RSP-PV-M), Version 12.0(32)S12, RELEASE SOFTWARE (fc1)

Technical Support: http://www.cisco.com/techsupport

Copyright (c) 1986-2008 by cisco Systems, Inc.

Compiled Mon 22-Dec-08 13:28 by leccese

Image text-base: 0x40011164, data-base: 0x415C7420


ROM: System Bootstrap, Version 12.0(10r)S1, RELEASE SOFTWARE (fc1)

BOOTLDR: RSP Software (RSP-PV-M), Version 12.0(32)S12, RELEASE SOFTWARE (fc1)


bottom-router uptime is 18 minutes

Uptime for this control processor is 18 minutes

System returned to ROM by reload at 17:00:07 CST Sat Jan 22 2000

System restarted at 17:01:29 CST Sat Jan 22 2000

System image file is "slot0:rsp-pv-mz.120-32.S12.bin"


cisco RSP4+ (R5000) processor with 262144K/2072K bytes of memory.

R5000 CPU at 200Mhz, Implementation 35, Rev 2.1, 512KB L2 Cache

Last reset from power-on

G.703/E1 software, Version 1.0.

G.703/JT2 software, Version 1.0.

X.25 software, Version 3.0.0.

Primary Rate ISDN software, Version 1.1.

Chassis Interface.

1 GEIP controller (1 GigabitEthernet).

2 VIP2 R5K controllers (1 FastEthernet)(2 Serial)(1 Channelized T3).

1 FastEthernet/IEEE 802.3 interface(s)

1 GigabitEthernet/IEEE 802.3 interface(s)

2 Serial network interface(s)

1 Channelized T3 port(s)

123K bytes of non-volatile configuration memory.


24576K bytes of Flash PCMCIA card at slot 0 (Sector size 128K).

16384K bytes of Flash internal SIMM (Sector size 256K).


Slave in slot 3 is running Cisco Internetwork Operating System Software

IOS (tm) RSP Software (RSP-DW-M), Version 12.0(32)S12, RELEASE SOFTWARE (fc1)

Technical Support: http://www.cisco.com/techsupport

Copyright (c) 1986-2008 by cisco Systems, Inc.

Compiled Mon 22-Dec-08 13:29 by leccese

Slave: Loaded from system

Slave: cisco RSP4+ (R5000) processor with 262144K bytes of memory.


Configuration register is 0x2102



Any suggestions?


  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
Yudong Wu Sat, 01/31/2009 - 08:18
User Badges:
  • Gold, 750 points or more


Redundancy RSP is in HSA mode now. Standby RSP is running (RSP-DW-M) which is subset image only.


Have you specified the image location in config like "hw-module slot 3 image "?


 


 

gregwoodson Mon, 02/02/2009 - 08:27
User Badges:

Yes I have- I looked in the logs- Im getting:


Jan 25 11:26:43 CST: %HA-5-NOTICE: Standby (slave) has probably received a watchdog timeout error. It will be reset now.



Yudong Wu Mon, 02/02/2009 - 08:49
User Badges:
  • Gold, 750 points or more

Can you try the following?

1. check if disk0 in standby has the image, "sh slavedisk0:"

2. reseat standby and collect/review the log.

3. in Maintenance window, try to force switchover to standby to see if it function correctly.

gregwoodson Mon, 02/02/2009 - 09:17
User Badges:

1. Done

2. Reset- same error


Logs:


Jan 25 11:51:53 CST: %MEM_ECC-3-BADADDR_MBE: Invalid MBE dram address: 0xFFFFFFFF latched by ECC Ctrl

Jan 25 11:51:53 CST: %RSP-3-ERROR: dbus read at 3E8410C2

-Traceback= 404D20C4 404D2484 404CB894 404CBD08 404CC160 404CAE00 00000000

-Traceback= 40355134 404849CC 4048707C 40444254 404365C0

Jan 25 11:51:53 CST: %RSP-3-ERROR: dbus read at 3E8410C2

-Traceback= 404D20C4 404D2484 404CB894 404CBD08 404CC160 404CAE00 00000000

-Traceback= 40355134 404849CC 4048707C 40444254 404365C0

Jan 25 11:51:53 CST: %RSP-3-ERROR: dbus read at 3E8410C2

-Traceback= 404D20C4 404D2484 404CB894 404CBD08 404CC160 404CAE00 00000000

-Traceback= 40355134 404849CC 4048707C 40444254 404365C0

Jan 25 11:51:53 CST: %RSP-3-ERROR: dbus read at 3E8410C2

-Traceback= 404D20C4 404D2484 404CB894 404CBD08 404CC160 404CAE00 00000000

-Traceback= 40355134 404849CC 4048707C 40444254 404365C0

Jan 25 11:51:54 CST: %DBUS-3-WCSFLOW: Slot 3, flow cntrl error loading WCS, last data 0x9A pos 1260251

Jan 25 11:51:54 CST: %UCODE-3-LDFAIL: Unable to download ucode from system image in slot 3, trying rom ucode

Jan 25 11:51:54 CST: %RSP-3-NOSTART: No microcode for RSP4 card, slot 3

Jan 25 11:52:05 CST: %RSP-3-SLAVECHANGE: Slave changed state from Unplugged to Non-participant

Jan 25 11:52:05 CST: %HA-5-MODE: Operating mode is hsa, configured mode is rpr-plus.

Jan 25 11:52:07 CST: %RSP-3-SLAVECHANGE: Slave changed state from Non-participant to Slave

Jan 25 11:52:08 CST: %RSP-3-SLAVECHANGE: Slave changed state from Slave to Non-participant

Jan 25 11:52:10 CST: %RSP-3-SLAVECHANGE: Slave changed state from Non-participant to Slave

Jan 25 11:52:15 CST: %RSP-3-SLAVECHANGE: Slave changed state from Slave to Non-participant

Jan 25 11:52:18 CST: %RSP-3-SLAVECHANGE: Slave changed state from Non-participant to Slave

Jan 25 11:52:22 CST: %RSP-3-SLAVECHANGE: Slave changed state from Slave to Non-participant

Jan 25 11:52:23 CST: %HA-5-NOTICE: Standby (slave) has probably received a watchdog timeout error. It will be reset now.

Jan 25 11:52:25 CST: %RSP-3-SLAVECHANGE: Slave changed state from Non-participant to Slave

Jan 25 11:52:52 CST: %HA-5-NOTICE: Standby (slave) configured to run HA image "disk0:rsp-pv-mz.120-32.S12.bin"

Jan 25 11:52:53 CST: %HA-5-NOTICE: Loading standby (slave) image: "disk0:rsp-pv-mz.120-32.S12.bin"

Jan 25 11:53:38 CST: %RSP-3-SLAVECHANGE: Slave changed state from Slave to Non-participant

Jan 25 11:54:08 CST: %HA-5-NOTICE: Standby (slave) has probably received a watchdog timeout error. It will be reset now.

Jan 25 11:54:10 CST: %RSP-3-SLAVECHANGE: Slave changed state from Non-participant to Slave

Jan 25 11:54:15 CST: %RSP-3-SLAVECHANGE: Slave changed state from Slave to Non-participant

Jan 25 11:54:17 CST: %RSP-3-SLAVECHANGE: Slave changed state from Non-participant to Slave

Jan 25 11:54:22 CST: %RSP-3-SLAVECHANGE: Slave changed state from Slave to Non-participant

Jan 25 11:54:25 CST: %RSP-3-SLAVECHANGE: Slave changed state from Non-participant to Slave

Jan 25 11:54:55 CST: %HA-5-NOTICE: Standby (slave) configured to run HA image "disk0:rsp-pv-mz.120-32.S12.bin"

Jan 25 11:54:55 CST: %HA-5-NOTICE: Loading standby (slave) image: "disk0:rsp-pv-mz.120-32.S12.bin"

Jan 25 11:55:40 CST: %RSP-3-SLAVECHANGE: Slave changed state from Slave to Non-participant


3. I forced switchover- just died out (over 10 minutes wait with no response) Rebooted with just that RSP in there- came up no problem




Yudong Wu Mon, 02/02/2009 - 09:24
User Badges:
  • Gold, 750 points or more

Please RMA it. It looks like a bad hardware.

Actions

This Discussion