LMS 3.1 failure on Windows VM

Unanswered Question
Jan 30th, 2009

<p>I have a new install of LMS 3.1, On a Windows 2003 VM.</p>

<p>I have 4, 3GHz CPUs configured and 4 GB RAM, 8 GB swap.</p>

<p>LMS runs for about 12 hours and it looks like several LMS processes die.</p>

<p>Here is what dies:  sysloganalyzer, CTMLrmServer, ChangeAudit, ConfigMgmtServer ICServer, EssentialDM, RMEOGEServer.</p>

<p>I Also noticed that a java.exe process was using 1.1GB on RAM</p>

<p>I haven't look at log or opened a TAC case yet, I think this may be memory related.</p>

<p> </p>

<p>What RAM and swap settings on a VM should I consider?</p>

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
Joe Clarke Sat, 01/31/2009 - 08:50

The root process is EssentialsDM.  Something is killing that process which in turn shuts down the other processes.  It is not uncommon for a Java process to take up 1.1 GB of RAM.  Some of them have a max heap size of 1 GB or more.

Memory may be an issue, but it depends on the number of devices you are managing.  Also, what version of VMWare is this?

It would also be helpful to see your EssentialsDM.log and EssentialsDM_Server.log.

DAVID SCHULTZ Mon, 02/02/2009 - 10:05

I don't have access to the log files at this moment.

The managed devices in LMS are about 550.

We also have about 20 managed devices in HUM.

My server admin is going to upgrade the OS to the 2003 Enterprise edition and run 8GB RAM and 16 GB swap.

Joe Clarke Mon, 02/02/2009 - 10:12

You should always budget one additional gigabyte of memory with ESX. So, you really need at least five in this server. Moving to eight should be fine.

However, it may still not solve the process crashing issue. Those logs would be useful if the problem persists.

Actions

This Discussion