ether channel not coming up on VSS(6509)

Unanswered Question
Feb 2nd, 2009
User Badges:

We are trying to configure VSS with two 6509 switches. The accsess(4507) is connteced to the vss(6509) distribution using MEC.


The port channel in the vss is not coming up. Following are the configurations on both switches.


in 6509 VSS

###########


int port-channel 100

switchport

switchport trunk encap dot1q

switchport mode trunk

switchport nonegotiate



int te1/1/1

switchport

switchport trunk encap dot1q

switchport mode trunk

switchport nonegotiate

channel-protocol pagp

channel-group 100 mode desirable


int te2/1/1


switchport

switchport encap dot1q

switchport mode trunk

switchport nonegotiate

channel-protocol pagp

channel-group 100 mode desirable


in 4507 access

##############


int port-channel 2

switchport

switchport mode trunk

switchport nonegotiate





int ten3/1

switchport

switchport mode trunk

switchport nonegotiate

channel-prot pagp

channel-group 100 mode desirable


int tn4/1

switchport

switchport mode trunk

switchport nonegotiate

channel-prot pagp

channel-group 100 mode desirable



can any one please suggest why my port channel is not coming up on VSS switch with the above config.

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
mahmoodmkl Mon, 02/02/2009 - 02:52
User Badges:
  • Gold, 750 points or more

Hi


Can u specify the channel protocol under the port-channel interface and check.


Thanks

Mahmood

shibi.er Mon, 02/02/2009 - 23:15
User Badges:

We can not applly that command in port-channel interface.

glen.grant Mon, 02/02/2009 - 04:35
User Badges:
  • Purple, 4500 points or more

Can you explain why on the 6500 you have int port channel 100 on the 6500 and you have int port channel 2 on the 4500 , assume that is a misprint on the 4500 side ? The channel-group under the interface looks ok though. Can you post a show etherchannel summary" for both sides? Usually in a negotiated etherchannel it will tell you in the logs why the etherchannel was not created .

Mohamed Sobair Mon, 02/02/2009 - 04:43
User Badges:
  • Gold, 750 points or more

At 4507 , the trunk ports uses ISL encapsulation instead of dot1q.


The Port's config has to be identical in order for ur Etherchannel to come up.


issue the following in both switches to examine the encapsulation type:


sh interfaces x/y switchport



HTH

Mohamed

hastwell Wed, 02/04/2009 - 03:26
User Badges:

The issue here appears to be that you have configured 802.1Q tagging at one end of the links, but not the other.


On the C4507 configure the EtherChannel to use 802.1Q and the EtherChannel should come up.


Cisco do numerous checks to prevent the mis-configuration of EtherChannels, which if un-checked can cause major problems in your network.


The fact your EtherChannel didn't come up is actually a good thing, different encapsulations on each end would otherwise have caused a black hole scenario.

Actions

This Discussion