VIC-4FXS does not work in ISR's

Unanswered Question
Feb 2nd, 2009

Hi!

<br /><br />

<br /><br />I have an issue with a number of VIC-4FXS cards installed at onboard HWIC slots in 2811 and 3825 routers. Gateways has enough PVDM's and voice ports appearing in configuration.

<br /><br />I'm trying to configure basic SIP trunk between two routers. IP connectivity is OK.

<br /><br />But all calls fails with 63 cause code, and there is no dialtone in connected phone.

<br /><br />What may be the problem? I changed IOS in 2811 from advententerprise to IP Voice but with no result.

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
Paolo Bevilacqua Mon, 02/02/2009 - 04:14

Is that new equipment? You can use "debug vpm signal" with "term mon" to check if the port detects the phone going off hook, if it doesn't I would know what to suggest because it should not happen.

Nicholas Matthews Mon, 02/02/2009 - 19:03

If debug vpm signal doesn't show anything, it is usually indicative of a bad card.

If can also be the sign of something really silly. For these reasons, make sure of a few things:

-Do a 'conf t' and 'exi' and make sure your logging is working

-'show voice call summary' and 'show voice port summary' to make sure the ports are not in an errored/stuck/admin down state

-try different ports on the card

-try different slots on the ISR

-try different wiring

-nick

ilyaavers Mon, 02/02/2009 - 21:11

It's some kind of a street magic. :)

The same FXS card works OK on 3825 with c3825-advipservicesk9-mz.124-15.T2.bin and does not work on 2811 with c2800nm-advipservicesk9-mz.124-21.bin.

The only serious difference I see - T train software in 3825. Now I'm downloading T train software for 2811, will try it. I'll update this thread after the test.

ilyaavers Tue, 02/03/2009 - 01:17

The same situation with other IOS version.

Right after reboot port's states is Dormant, UP.

After shut/no shut ports are stucks in 'Admin UP' but 'Operation down' state.

'sh voi call sum' shows same strange state:

fxs#sho voice call sum

PORT CODEC VAD VTSP STATE VPM STATE

============== ========= === ==================== ======================

0/2/0 - - - S_OPEN_PEND

0/2/1 - - - S_OPEN_PEND

0/2/2 - - - S_OPEN_PEND

0/2/3 - - - S_OPEN_PEND

fxs#sho voice port sum

IN OUT

PORT CH SIG-TYPE ADMIN OPER STATUS STATUS EC

============== == ============ ===== ==== ======== ======== ==

0/2/0 -- fxs-ls up down on-hook idle y

0/2/1 -- fxs-ls up dorm on-hook idle y

0/2/2 -- fxs-ls up dorm on-hook idle y

0/2/3 -- fxs-ls up dorm on-hook idle y

fxs#sh voice port 0/2/0

Foreign Exchange Station 0/2/0 Slot is 0, Sub-unit is 2, Port is 0

Type of VoicePort is FXS VIC-4DID

Operation State is DOWN

Administrative State is UP

The Last Interface Down Failure Cause is Administrative Shutdown

Description is not set

Noise Regeneration is enabled

Non Linear Processing is enabled

Non Linear Mute is disabled

Non Linear Threshold is -21 dB

Music On Hold Threshold is Set to -38 dBm

In Gain is Set to 0 dB

Out Attenuation is Set to 3 dB

Echo Cancellation is enabled

Echo Cancellation NLP mute is disabled

Echo Cancellation NLP threshold is -21 dB

Echo Cancel Coverage is set to 64 ms

Echo Cancel worst case ERL is set to 6 dB

Playout-delay Mode is set to adaptive

Playout-delay Nominal is set to 60 ms

Playout-delay Maximum is set to 250 ms

Playout-delay Minimum mode is set to default, value 40 ms

Playout-delay Fax is set to 300 ms

Connection Mode is normal

Connection Number is not set

Initial Time Out is set to 10 s

Interdigit Time Out is set to 10 s

Call Disconnect Time Out is set to 60 s

Supervisory Disconnect Time Out is set to 750 ms

Ringing Time Out is set to 180 s

Wait Release Time Out is set to 30 s

Companding Type is u-law

Region Tone is set for US

Analog Info Follows:

Currently processing none

Maintenance Mode Set to None (not in mtc mode)

Number of signaling protocol errors are 0

Impedance is set to 600r Ohm

Station name None, Station number None

Translation profile (Incoming):

Translation profile (Outgoing):

Voice card specific Info Follows:

Signal Type is loopStart

Ring Frequency is 25 Hz

Hook Status is On Hook

Ring Active Status is inactive

Ring Ground Status is inactive

Tip Ground Status is inactive

Digit Duration Timing is set to 100 ms

InterDigit Duration Timing is set to 100 ms

Hookflash-in Timing is set to max=1000 ms, min=150 ms

Hookflash-out Timing is set to 400 ms

No disconnect acknowledge

Ring Cadence is defined by CPTone Selection

Ring Cadence are [20 40] * 100 msec

Ringer Equivalence Number is set to 1

Nicholas Matthews Tue, 02/03/2009 - 05:50

May be a DSP issue. Try swapping DSPs from the 3800 and 2800 and see if it changes the results.

Then again, it could just be the card.

-nick

Actions

This Discussion