incoming FAX on SIP trunk - CME

Answered Question
Feb 2nd, 2009
User Badges:

hi guys,


I am trying to setup fax on my CME gateway, I have a SIP trunk to my PSTN provider and incoming and outgoing calls are SIP. My fax machine is connected to the network via a Cisco ATA and when I make a call the fax rings and gives me fax tone after few rings but there is no fax. Could you please tell me the SIP dial-peer config for fax and debug commands to troubleshoot.


many thanks,


K

Correct Answer by Nicholas Matthews about 8 years 2 months ago

Hi Kiran,


Check your SIP network for packet loss - 'show call active voice brief | i lost'.


Try this command:

voice service voip

fax passthrough codec g711ulaw fallback none


You can try T38, to see if your provider supports it (some do):


voice service voip

fax protocol t38 fallback none



There is more to faxing than just G.711 - it increases the jitter buffers and turns of echo cancellation. It is important for all DSPs involved to do this, so setting it to G.711 isn't enough.



hth,

nick

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (1 ratings)
Loading.
paolo bevilacqua Mon, 02/02/2009 - 04:22
User Badges:
  • Super Gold, 25000 points or more
  • Hall of Fame,

    Founding Member

Have you disabled fax relay ? "fax protocol none". Also make sure you're using G.711 with ITSP, else fax cannot work.

kiranoddiraju Mon, 02/02/2009 - 04:28
User Badges:

yes I am using G.711 and do I need to disable fax protocol?


voice class codec 1

codec preference 1 g711ulaw

codec preference 2 g711alaw


paolo bevilacqua Mon, 02/02/2009 - 05:05
User Badges:
  • Super Gold, 25000 points or more
  • Hall of Fame,

    Founding Member

Yes because it's unlikely that ITSP supports one.

Note in practice g711a is never used over voip even outside N.A. and you can safely omit it, so having a single coded under DP instead of codec class.

Correct Answer
Nicholas Matthews Mon, 02/02/2009 - 17:42
User Badges:
  • Red, 2250 points or more

Hi Kiran,


Check your SIP network for packet loss - 'show call active voice brief | i lost'.


Try this command:

voice service voip

fax passthrough codec g711ulaw fallback none


You can try T38, to see if your provider supports it (some do):


voice service voip

fax protocol t38 fallback none



There is more to faxing than just G.711 - it increases the jitter buffers and turns of echo cancellation. It is important for all DSPs involved to do this, so setting it to G.711 isn't enough.



hth,

nick

kiranoddiraju Tue, 02/03/2009 - 03:58
User Badges:

Thanks Nick, I have tried with t38 and passthrough g711ulaw but it doesnt work. The fax rings on the otherside and I can see on my fax it is trying to connect at different speed (9600,7200,4800 & 2400) and fails.


I have no DSP's on the gateway.


voice service voip

allow-connections h323 to h323

allow-connections h323 to sip

allow-connections sip to h323

allow-connections sip to sip

fax protocol t38 ls-redundancy 0 hs-redundancy 0 fallback none

h323

!


My Dial-peer config:

dial-peer voice 9 voip

description <<< Outbound to Telco >>>

translation-profile outgoing outgoing_digits

destination-pattern 9.T

voice-class codec 1

voice-class sip dtmf-relay force rtp-nte

session protocol sipv2

session target ipv4:xx.xx.xxx.x

dtmf-relay rtp-nte

no vad

!

dial-peer voice 10 voip

description <<>>

translation-profile incoming incoming_digits

voice-class codec 1

session protocol sipv2

session target ipv4:xx.xx.xxx.x

incoming called-number .

dtmf-relay sip-notify

no vad

!


Nicholas Matthews Tue, 02/03/2009 - 05:45
User Badges:
  • Red, 2250 points or more

CUBE will play no part in the faxing other than signaling.


Please make sure that this is configured on your endpoints.


We had some problems with faxing on CUBE in 20.T1 I believe. If you're not on 22T you may want to try it.



-nick

Nicholas Matthews Tue, 02/03/2009 - 06:49
User Badges:
  • Red, 2250 points or more

H323-SIP is CUBE. You shouldn't because it's how your calls are working :)


If you're using CUBE but not paying the licensing for it ... you may want to look into it :)



If the fax machine is hooked up to an FXS port, that that's the gateway you're interested in. If it's an IP fax server, you won't be able to change most of the fax settings on a gateway.


-nick

kiranoddiraju Tue, 02/03/2009 - 07:01
User Badges:

I have a SIP interconnection with my ITSP, so I assume it is SIP-SIP. I cant use FXS as I dont have DSP's on the gw.

kiranoddiraju Tue, 02/10/2009 - 05:46
User Badges:

Nick, its working now after I forced it to T38 and set fax rate to 9600 and did the same on the Telecom side.


Many thanks for your guidance.

Actions

This Discussion