Fax - Rightfax Sending , Receiving Problem

Unanswered Question
Feb 2nd, 2009

Hi , we have an deployment for cisco fax server 9.3

i have successfully setup the software ; the brooktrout SR140 boardless and H323 gateway and the corresponding route patterns as i have referenced form another thread in the forum.

i have g711 codecs configured in CUCM 6.1.

the fax call flow should be

FAX server >>>> CUCM6 H323 gateway >>>> MGCP gateway or ATA FAX .

The probelm now even i hear fax tone whether i receive or send to fax server , after i get the tone we hear silence and nothing is transmitted .

wish to find a clue to what im having

Thank you very much

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
jaison.joy Mon, 02/02/2009 - 18:55

Hi i have the same issue,

cisco fax server is integrated with cm with a h323 gw. i get a fax tone for 4 seconds and the call gets disconected soon. When i checked it with the RightFAX team they showed in the wireshark that the cm rejecting t38 fax request any quick idea? what could i be missing?

My call flow

Fax -> cm6.1 ->h323 gw-> Rightfax

Right fax team says that it is cisco's issue.

Any body please help!!

Attachment: 
Nicholas Matthews Mon, 02/02/2009 - 19:07

This should be posted somewhere because there are a ton of posts here.

We find that this is the best configuration for interop with CCM:

Configuration Tool ---> H323 ---> IP Parameters ---> Show Advanced to

h323_FastStart = 0

h323_H245Stage = 1

h323_h245Tunneling = 0

If you have audio cutover, this is probably not your problem.

hth,

nick

jaison.joy Tue, 02/03/2009 - 06:12

hi nick we have tried the same settings here. but I cant send or receive fax even internaly in the company. But i can here fax tone when calling the number.

How can i enable t38 on the call manager h323 gw side? As per the logs T38 request was blocked by call manager.

I did not find any parameter from where i can controll

Pablo Roman Reinoso Tue, 02/03/2009 - 17:27

This config is working for me, i had the same issue yesterday. Do you know any way for have the same number for fax and voice? im looking any solution.

dial-peer voice 1 pots

incoming called-number .

direct-inward-dial

voice class codec 1

codec preference 2 g711alaw

codec preference 3 g711ulaw

!

dial-peer voice 100 voip

destination-pattern 5939 *** fax number***

voice-class codec 1

session target ipv4:172.27.187.6 *** CCM ***

session transport udp

dtmf-relay h245-alphanumeric

fax protocol t38 ls-redundancy 2 hs-redundancy 0 fallback cisco

ip qos dscp cs5 media

no vad

voice service voip

allow-connections h323 to h323

fax protocol t38 ls-redundancy 2 hs-redundancy 0 fallback none

h323

session transport udp

incoming dial-peer voice pots must be enable fax rate only put "no fax rate disable"

http://www.cisco.com/en/US/docs/ios/12_3/vvf_c/cisco_ios_fax_services_over_ip_application_guide/t38.html#wp1157271

Pablo

Attachment: 
Pablo Roman Reinoso Tue, 02/03/2009 - 18:37

i forgot something are you using ata 186 and rightfax internally in your test? ata 186 dont work with t38.

jaison.joy Sat, 02/07/2009 - 14:24

I got it working with the help of Marco.

i was missing few commands in MGCP Gateway

mgcp package-capability fxr-package

no mgcp fax t38 inhibit

mgcp fax t38 ls_redundancy 2

mgcp fax t38 hs_redundancy 2

Now I am able to send faxes to Right fax.

Mohamed Fahmy Sun, 02/08/2009 - 04:00

i tried this modification , and something started to change (brooktrout writes sending ..) but with nothing sent

i captured with wireshark it gave me t30ind: no-signal in the T.38 packets .

would you please jaison write the full configuration for mgcp t.38

Nicholas Matthews Sun, 02/08/2009 - 08:55

The no-signal is normal. It's a filler packet while the signaling is getting established. You're more interested in the packets that say something.

hth,

nick

graham1965 Thu, 05/14/2009 - 23:57

Hi, we had similar problems with our install of Rightfax to CUCM 6.1. We then noted our gateways IOS needed updating to allow some missing T38 commands so went to 12.4(22). Faxes now come in ok and forward onto a Lotus notes account, but we cannot forward back out of Rightfax to a fax machine on an ATA. Incidentally what is the IP address on the example shown under H323 local ip address 10.1.200.35 for. Is this the Call managers address.

Mohamed Fahmy Fri, 05/15/2009 - 07:12

the 10.1.200.35 is the fax server IP and i have it working perfect .by the way i have to dial the ata from external pstn number thus the gateway will handle the T.38 session .

and the call manager address is 10.1.200.10 .

Thank you very much

graham1965 Sun, 05/17/2009 - 23:57

Thanks for updated info.So to clarify, within Rightfax you have the ability to forward from a user account to a phsical fax machine connected to an ATA, via the default receive settings tab, then automatic forward options, forward to fax machine and you are entering the external pstn number here ?

Thanks

spazziani Tue, 11/29/2011 - 11:54

Hi,

I'm a problem seems you. I can't recive and send Faxes, follow my topology:

RighFax (SIP TRUNK)<---------->CUCM (H323) <------------->GW (R2-Digitl) <-------------->PSTN <-----------> fax machine

Regards,

Vinicius

Actions

This Discussion