IP Phone not getting DHCP address

Unanswered Question
Feb 2nd, 2009

IP Phones which are connected to a 2950 switch [PC on vlan10 and Phone on 20] {Siemens optipoint phone] .

R*-C1800 , on debugging dhcp packets ,i could see that packets are forwared to the dhcp server and its getting back an ip address and it is unicasted to the phone , but the phone is not accepting the ip .

query : i have noticed that the mac address for the phone is registering on the access vlan mac table and its forwared from the router as the access vlan subnet .

DHCP Server is located in the Branch office connected to the Core 4510 Switch ,

When the phones are connected to any port in the Core switch , it fires up straight .

Please assist .

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
adhityakarthik Mon, 02/02/2009 - 16:14


1) is CDP is enabled on switch which is connected to Ip phone, ru able to see IPPHONE BY ISSUSING CDP neighbout in switch

2)stpe: try to disable DHCP option in the cisco phone(NETWORK CONFIGURATION Tab) and give try giving static ip to the phone

Could you please give the sh runof port config and also error message



glen.grant Mon, 02/02/2009 - 16:18

Make sure the trunk feeding from the 2950 to your core is working ok and allowing both vlans .Layer 2 vlans are created on the 2950. If the dhcp server is not on the phone vlan then you will need helper addresses on the layer 3 interface for vlan 20 . If you can post the config and uplink port configs.

vineesh.viswanath Mon, 02/02/2009 - 16:22


Yes , trunk is working fine ... Everything was fine till we had a dhcp Server scheduled maintenance ..

if i use an ip which is not been used in dhcp scope , ie -: a staic reservation , the phone will get the ip .

vineesh.viswanath Mon, 02/02/2009 - 16:30

IP is CEF Switched on Core

DHCP server VLAN and Access VLAN are different , but on the Same VRF.

ohassairi Mon, 02/02/2009 - 21:33

use a sniffer (such as ethereal) and follow your packets:

-does your phone generate dhcp request packets?

-do they arrive to dhcp server?

-where they block?

w.kuhn Mon, 02/02/2009 - 21:23

Problem could be at couple of places...

Check if DHCP server has correct gateway for VLAN 20.

Not sure with Siemens phones.. but worth checking DHCP server if you require an "option" string on Data and Voice VLAN scope. As always, make sure your network is setup correctly.

Example with Avaya IP phones it requires "option 242" which has a string entry that tells the phone to reboot and get IP from voice vlan (subnet). Again with Avaya the voice vlan scope has the same option 242 but string has phone specific values ie. CMA server IP, HTTP/TFTP server etc. Check Siemens doco for how this needs to be setup.

Hope it helps.

vineesh.viswanath Mon, 02/02/2009 - 23:57

DHCP Server GW is correct .

I have enabled debub dhcp events and packets in distribution .

I am able to see the dhcp request which is forwarded to the helper address[DHCP Srvr]

in return , DHCP sending an ip back to the phone . [in distri debug i a able to see the unicast ] .

janf Tue, 02/17/2009 - 11:05


Did you ever resolve this issue. I'm having a similar problem with Siemens phones and a voice vlan/dhcp.

Thank you,


vineesh.viswanath Tue, 02/17/2009 - 12:51

still its going on ...

btw , are you assigning vlan on the phone ??

Mac address of the phone is not getting recognised as voice vlan packet . ie suppose vlan 10 data and vlan 20 voice , the mac which is coming to the distribution switch is forwarded to the dhcp server as a data subnet class .

setting vlan on the phone could solve this problem ...

janf Tue, 02/17/2009 - 12:57

do you mean hard-coding the vlan into the phone?

janf Tue, 02/17/2009 - 14:11

Tried that and it didn't work. I see the DHCP offer from the client but that's it. I doesn't take the address.

We do however have a similar problem at another site (different LAN) where they can bypass the problem by hardcoding the vlan.

Did you ever report this issue to Siemens? That's what I'm going to have our phone guy do. Nothing changed on the LAN or DHCP server that I am aware of and now things are no longer working.

vineesh.viswanath Tue, 02/17/2009 - 14:18

oh is that not working ....

temp fix ... note the mac and reserve the ip in dhcp server it works for sure

janf Tue, 02/17/2009 - 14:38

mac reservation does not work for one phone but it did however work for another

vineesh.viswanath Tue, 02/17/2009 - 23:45

for this what i have done is , put a reservation for the PC also, whose mac coming out from the phone port


This Discussion